Testing coils? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old May 31st, 2009, 9:25 pm Thread Starter
Junior Member
 
Join Date: May 2009
Location: Sunrise, Fl., USA
Posts: 3
Testing coils?

Hey guys new to the forum and new to the K75 world.I recently purchased a 94 k75.The bikes in pretty good shape and just started to have problems with a ruff idle.I searched the
forums but couldn't find an answer so I started this one.I found that when I removed the #3
wire it runs the same.So I thought it could be a wire so I swapped it with the #2 with the same results.I removed the spark plug and connected it to the wire and cranked it and got
spark but not sure if enough.(looks to be the same as the other 2 but not sure)This is what leads me to my question.How do I test the coil? Can I switch the #2 coil with the #3 to see if its not the computer telling that coil not to fire? idk.. Thanks for any advice.
Drod is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Jun 1st, 2009, 10:42 am
Senior Member
 
SilverBuffalo's Avatar
 
Join Date: May 2005
Location: St. Petersburg, FL, USA
Posts: 3,208
Re: Testing coils?

This place might have your answers.


Hans
St. Petersburg FL

2002 K1200LTE
"Silver Buffalo" Totaled 5/06
2005 LT
"Esperanza"
BushtecGenesisTrailer
"Our preferred long distance carrier"



SilverBuffalo is offline  
post #3 of 6 Old Jun 1st, 2009, 11:28 am Thread Starter
Junior Member
 
Join Date: May 2009
Location: Sunrise, Fl., USA
Posts: 3
Re: Testing coils?

Thanks for the link,Great info but still couldn't find t my answer.
Drod is offline  
 
post #4 of 6 Old Jun 1st, 2009, 12:56 pm
Senior Member
 
Palerider's Avatar
 
Join Date: Aug 2008
Location: Big Piney, Wyoming, USA
Posts: 1,745
Re: Testing coils?

Check the compression and read the plug.................?...................
Palerider is offline  
post #5 of 6 Old Jun 1st, 2009, 2:06 pm
Senior Member
 
SilverBuffalo's Avatar
 
Join Date: May 2005
Location: St. Petersburg, FL, USA
Posts: 3,208
Re: Testing coils?

I'm not sure how to answer your question, if you're getting spark that would suggest that the coil is working,
I don't have any idea how you would determine if you're getting "enough" spark,
if you've got compression and fuel I would think "any" spark would cause ignition.

I've had a couple of the older K-bikes
put almost a hundred thousand miles on a K75RT
and about the same on a K1100LT,
never had any problems other than fuel related.

The reason I bring that up is if your bikes running rough
I would suggest you look into the fuel filter (it's inside the tank) and the injectors,
they are extremely sensitive to dirt,

My advice is: try the simple stuff first
run some fuel injector cleaner through it, its cheap and easy,
you'll know in about 20-30 miles whether it worked.


Hans
St. Petersburg FL

2002 K1200LTE
"Silver Buffalo" Totaled 5/06
2005 LT
"Esperanza"
BushtecGenesisTrailer
"Our preferred long distance carrier"



SilverBuffalo is offline  
post #6 of 6 Old Jun 1st, 2009, 11:07 pm Thread Starter
Junior Member
 
Join Date: May 2009
Location: Sunrise, Fl., USA
Posts: 3
Re: Testing coils?

Well it turned out to be a broken wire inside the connector that goes to the #3 injector.I only found it cause I was checking the connections and pulled the wire out from the plug.It must have been barely making because when I removed the injector before and tested it was working.must have been when I twisted it back to have a look it made contact.I removed the fuel filter and gonna order one tomorrow.Thanks again for the help.
Drod is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
California SB435 - Smog Testing Motorcycles!! Tom_Becker South West 3 May 25th, 2009 6:15 pm
Mandatory M/C Emission Testing in Nazifornia Lopaca Bike Talk 6 May 24th, 2009 11:10 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome