2002 K1200RS ABS questions - BMW Luxury Touring Community
 3Likes
  • 1 Post By juda5
  • 1 Post By juda5
  • 1 Post By juda5
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Jun 18th, 2017, 12:09 pm Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 5
2002 K1200RS ABS questions

Hi,

I just purchased an 02 K1200RS that appears to have been rebuilt.

The front ABS sensor has better than 5mm of gap to the sensor ring -- this can't possibly work, nad the manual shows it should be closer to 1mm.

I have checked the part number for the sensor, and it appears correct -- it shows 2 333 484.

There does not appear to be any adjustment available, so my questions are:

1. Were there different lengths of sensor on different years?
2. Were there different thicknesses of sensor ring on different years?
3. is it possible the fork legs have been replace with different year?

Any help is greatly appreciated.

Thanks,
Judas
juda5 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old Jun 18th, 2017, 12:51 pm
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 3,872
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by juda5 View Post
Hi,

I just purchased an 02 K1200RS that appears to have been rebuilt.

The front ABS sensor has better than 5mm of gap to the sensor ring -- this can't possibly work, nad the manual shows it should be closer to 1mm.

I have checked the part number for the sensor, and it appears correct -- it shows 2 333 484.

There does not appear to be any adjustment available, so my questions are:

1. Were there different lengths of sensor on different years?
2. Were there different thicknesses of sensor ring on different years?
3. is it possible the fork legs have been replace with different year?

Any help is greatly appreciated.

Thanks,
Judas

Don't have an RS but I will ask a few questions.

Judas, the sensors are adjusted by a shim pack for proper clearance. Have you removed the sensor and are there any shims being used?

Next thing I am going to ask, what do the front brake calipers have on them. Brembo or BMW? Just trying to verify what braking system is installed, ABS-II or I-ABS The P/N you listed is for the servo assisted I-ABS so I would expect to see BMW calipers.

Can you look at the sensor ring also. Equating some of this to the LT and not the RS but probably very similar systems. Is the sensor ring cast metal or stamped sheet metal. It is possible that if the sheet metal type used on the I-ABS, it is installed on the wrong side of the brake rotor if it was ever removed but that is only a guess for a large clearance. Not sure if an earlier RS wheel with the cast sensor would fit but if it did, the sensor gap might be totally wrong in that case if it was farther away and not impacting the sensor with too little clearance.

I guess I also should ask, is there a problem you are trying to resolve? ABS light on and doesn't go out or such?

Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride) Lazy Susan
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by bmwcoolk1200; Jun 18th, 2017 at 2:24 pm.
bmwcoolk1200 is offline  
post #3 of 9 Old Jun 18th, 2017, 4:37 pm Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 5
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by bmwcoolk1200 View Post
Don't have an RS but I will ask a few questions.

Judas, the sensors are adjusted by a shim pack for proper clearance. Have you removed the sensor and are there any shims being used?

Next thing I am going to ask, what do the front brake calipers have on them. Brembo or BMW? Just trying to verify what braking system is installed, ABS-II or I-ABS The P/N you listed is for the servo assisted I-ABS so I would expect to see BMW calipers.

Can you look at the sensor ring also. Equating some of this to the LT and not the RS but probably very similar systems. Is the sensor ring cast metal or stamped sheet metal. It is possible that if the sheet metal type used on the I-ABS, it is installed on the wrong side of the brake rotor if it was ever removed but that is only a guess for a large clearance. Not sure if an earlier RS wheel with the cast sensor would fit but if it did, the sensor gap might be totally wrong in that case if it was farther away and not impacting the sensor with too little clearance.

I guess I also should ask, is there a problem you are trying to resolve? ABS light on and doesn't go out or such?
Thank you for your response.

I have removed the sensor, there are no shims.

The calipers are marked BMW, I believe it is I-ABS.

The sensor ring is stamped, and was installed between the wheel and the brake rotor. Looking at a parts fiche, this appears wrong (the factory manual did not specify, only stated "put parts back in reverse order of disassembly.")

The problem I am trying to solve is both ABS and Red Triangle lights flashing alternately, and ABS not working.

After relocating the sensor ring outboard of the brake rotor, and shimming the sensor to within spec., my symptoms have changed somewhat.

Currently, with key on, I get ABS light on, red triangle off.
I hear servo actuate, etc.
If I start engine and begin driving immediately, the ASB light goes off after a few feet, and I'm pretty sure the ABS is functional at that point.
After 30 seconds or so (either driving or just key on) the system returns to alternately flashing both lights.

I have checked fluid levels in the rear reservoirs, but I have not yet checked front (heading out to do that now.)

With key on, engine off, I hear servo whine when actuating either brake -- I'm led to believe that is a good sign...?

I have not yet flushed and bled the lines -- I expect that to be entertaining, but I have an SBS vacuum bleeder, so maybe not too bad?
juda5 is offline  
 
post #4 of 9 Old Jun 18th, 2017, 5:25 pm
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 3,872
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by juda5 View Post
Thank you for your response.

I have removed the sensor, there are no shims.

The calipers are marked BMW, I believe it is I-ABS.

The sensor ring is stamped, and was installed between the wheel and the brake rotor. Looking at a parts fiche, this appears wrong (the factory manual did not specify, only stated "put parts back in reverse order of disassembly.")

The problem I am trying to solve is both ABS and Red Triangle lights flashing alternately, and ABS not working.

After relocating the sensor ring outboard of the brake rotor, and shimming the sensor to within spec., my symptoms have changed somewhat.

Currently, with key on, I get ABS light on, red triangle off.
I hear servo actuate, etc.
If I start engine and begin driving immediately, the ASB light goes off after a few feet, and I'm pretty sure the ABS is functional at that point.
After 30 seconds or so (either driving or just key on) the system returns to alternately flashing both lights.

I have checked fluid levels in the rear reservoirs, but I have not yet checked front (heading out to do that now.)

With key on, engine off, I hear servo whine when actuating either brake -- I'm led to believe that is a good sign...?

I have not yet flushed and bled the lines -- I expect that to be entertaining, but I have an SBS vacuum bleeder, so maybe not too bad?
The alternate flashing of the lights indicates a low fluid condition in one of the reservoirs and on the 2002, both of those are located under the rear seat on the right side. Double check those and top them off. The handle bar reservoirs have no sensors on them so the front one would not cause the lights to alternate. Check to make sure the sensors are plugged in and no pins bent.

Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride) Lazy Susan
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwcoolk1200 is offline  
post #5 of 9 Old Jun 19th, 2017, 12:18 pm Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 5
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by bmwcoolk1200 View Post
The alternate flashing of the lights indicates a low fluid condition in one of the reservoirs and on the 2002, both of those are located under the rear seat on the right side. Double check those and top them off. The handle bar reservoirs have no sensors on them so the front one would not cause the lights to alternate. Check to make sure the sensors are plugged in and no pins bent.
The innermost reservoir was just at the minimum mark, the outer one was full.

I topped up the inner reservoir, and the flashing appears to have stopped!

I'm headed out for a long ride, so we'll see how it goes.

Thank you very much for your help!!

Judas
bmwcoolk1200 likes this.
juda5 is offline  
post #6 of 9 Old Jun 19th, 2017, 1:47 pm
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 3,872
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by juda5 View Post
The innermost reservoir was just at the minimum mark, the outer one was full.

I topped up the inner reservoir, and the flashing appears to have stopped!

I'm headed out for a long ride, so we'll see how it goes.

Thank you very much for your help!!

Judas
Sounds good. Just be aware that when you replace the brake pads you will have to remove some fluid from the reservoirs or it will squirt all over your bike when you compress the pistons back in. One of those two reservoirs is shared by the rear control circuit and the rear wheel circuit. Very likely the one that was low is the shared one.

Maybe have a look at the existing pads if one reservoir was at minimum with no leaks. They may be OK but you would need to check to be sure.

Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride) Lazy Susan
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by bmwcoolk1200; Jun 19th, 2017 at 1:58 pm.
bmwcoolk1200 is offline  
post #7 of 9 Old Jun 23rd, 2017, 7:36 am Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 5
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by bmwcoolk1200 View Post
Sounds good. Just be aware that when you replace the brake pads you will have to remove some fluid from the reservoirs or it will squirt all over your bike when you compress the pistons back in. One of those two reservoirs is shared by the rear control circuit and the rear wheel circuit. Very likely the one that was low is the shared one.

Maybe have a look at the existing pads if one reservoir was at minimum with no leaks. They may be OK but you would need to check to be sure.
Pads look good.

I plan a full flush and bleed once I am home. No idea when the fluid was last changed.

The brakes have been flawless for the last 4 days of riding -- now to find a decent set of panniers...
bmwcoolk1200 likes this.
juda5 is offline  
post #8 of 9 Old Jun 27th, 2017, 5:21 pm Thread Starter
Junior Member
 
Join Date: Jun 2017
Posts: 5
Re: 2002 K1200RS ABS questions

Quote:
Originally Posted by juda5 View Post
Hi,

I just purchased an 02 K1200RS that appears to have been rebuilt.

The front ABS sensor has better than 5mm of gap to the sensor ring -- this can't possibly work, and the manual shows it should be closer to 1mm.

1. Were there different lengths of sensor on different years?
2. Were there different thicknesses of sensor ring on different years?
3. is it possible the fork legs have been replace with different year?

Thanks,
Judas
Addendum to answer my own questions:

Sensors appear to be same length.

Sensor rings are quite different: 98-01 is a cast ring, 02-05 is stamped stainless steel. There is roughly 3mm of difference in total thickness between the 2.

Fork legs appear to be the same.

It also appears that the front wheel is different between the 98-01 and 02-05 generations. The cast mounts that the ABS sensor ring and the brake disk ride on are machined roughly 3mm shorter on the early generation wheel.

On both generations, the ABS sensor ring s installed between the wheel and the brake disk (the factory manual is unclear.)

On my rebuilt 02, it appears the front wheel was replaced with an early generation wheel, but the later generation sensor ring was used. Because the ABS sensor ring was shallower, and its mounting ears much thinner, this caused 2 problems. First, there was too much gap between the ABS sensor and the ring, so the system tripped a code. Second, the brake disk was not centered in the caliper - it was well inboard. I attempted to rectify this by re positioning the sensor ring outboard of the brake rotor. This made the rotor ride even more off-center in the caliper, and I had to grind the rolled edge off of the mounting ears on the sensor ring, otherwise the brake disk would no longer have been able to float. This also caused the air gap for the ABS sensor to be too small, but I made a spacer to rectify that (factory shims would have worked, but this was proof of concept, not a permanent fix.) Once the air gap was correct, my code went away and I had functioning ABS -- for about 30 seconds. The rear inner brake fluid reservoir was just at the minimum mark, and required topping up to restore full functionality. I replaced the sensor ring with an early generation cast ring, to match the front wheel, and located it correctly between the wheel and the brake rotor. My brake disk is now centered correctly in the caliper, and my ABS sensor air gap is just under 1mm. There are no codes, and the ABS is functioning correctly.

Hopefully this can be of use to someone in the future.

Huge thanks to bmwcoolk1200 for all his help -- I would likely still be scratching my head otherwise!
bmwcoolk1200 likes this.
juda5 is offline  
post #9 of 9 Old Aug 14th, 2017, 2:27 am
cws
Senior Member
 
cws's Avatar
 
Join Date: Aug 2005
Location: Sydney, NSW, Australia
Posts: 3,178
Garage
Re: 2002 K1200RS ABS questions

Hi Juda5....
most of the info you'll need on the RS can be found either on i-bmw or k-bikes (dot com).
A lot more riders of the RS/GT on those forums... although some of us frequent all 3.
cheers

Chris
Sydney, NSW
2005 Dark Graphite Metallic K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 Orient Blue Metallic K1200GT SE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(sold 2019)
2000 Red Honda CB250 (the toy)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ulysses #45310
GS911


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

cws is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake, ABS and Clutch Bleed questions 14wntr K1200LT 8 May 14th, 2011 10:52 pm
Alternating ABS Lights OKUIII K1200LT 12 Jul 14th, 2008 10:09 pm
General Brake And Abs Questions starky K1200LT 4 Jan 10th, 2006 7:06 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome