BMW Luxury Touring Community - Reply to Topic
Thread: Cruise Control Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Feb 28th, 2013 8:44 am
dsherman
Re: Cruise Control

Last year on my '09 I was having problems with the CC and while under warranty BMW replaced the cable and the CC unit and has been good to go ever since. I would do the cable thing first if I was going to foot the bill.
Feb 27th, 2013 9:12 pm
av8trto
Re: Cruise Control

Ron, I'm not sure what year LT you have. I have a '99.

I was having various CC problems. I changed my throttle cables to the "new" style" and while I was doing this I made sure all the other parameters were by the book and everything down by the throttle bodies was correct when the throttle was moved. To be honest I'm not sure what the actual fix was.

Since then my CC is rock solid. (2 riding seasons ago, going on third) The cruise does everything it's supposed to do.

This might not be the quick fix answer but taking it from the top to the bottom gives a greater chance of success.

I'm relating this from a rider that has the skills and tools to do his/her own maintenance. If you are relying on a shop for your maintenance you might not have the same success.?

Probably one of the best things I have done to improve this bike.
Feb 27th, 2013 1:14 pm
bjedruszczak
Re: Cruise Control

Quote:
Originally Posted by ronslaverda
Hi,
My cruise control has stopped working, I have checked the fuse (OK) and when it is switched on the small red light in the switch illuminates the instrument panel light doesn't come on when it is switched on.
Does this ring a bell with anybody, thanks for any forthcoming help.
The link provided by Sailor is great. Nice video editing and great tips - thanks Sailor.

From my experience, there two major categories of Cruise not working:
1. (Fairly easy to fix) Failure or missadjustment of any of the following switches: Front brake, Rear brake, Clutch.
2. Everything else (repairing may get very involving)

The built in diagnostics as described in the link provided should clearly sort thing out and hopefully let you fix the problem easily.

Hope that helps,
BJ
Feb 26th, 2013 8:02 pm
sailor
Re: Cruise Control

Quote:
Originally Posted by ronslaverda
Hi,
My cruise control has stopped working, I have checked the fuse (OK) and when it is switched on the small red light in the switch illuminates the instrument panel light doesn't come on when it is switched on.
Does this ring a bell with anybody, thanks for any forthcoming help.
A good starting point is to use the built-in diagnostic procedure of the cruise-control.
A while ago I made a video tutorial and a PDF written summary:

1) The original thread when I first published the video tutorial is available here:
http://www.bmwlt.com/forums/showthread.php?t=61130

2) See also a more recent thread where I posted an improved version of the PDF summary:
http://www.bmwlt.com/forums/showthread.php?t=68072

Let me know how it goes...
Feb 25th, 2013 7:16 pm
johnbaker15
Re: Cruise Control

This link will lead to a youtube diagnostic for the K12RS. Follow it for your LT.
Feb 25th, 2013 6:49 pm
r_figueroa
Re: Cruise Control

Look in the Hall of Wisdom. It has a procedure for testing the cruise control.
Feb 25th, 2013 6:27 pm
AlaskaFish
Re: Cruise Control

One of the most common ailments here is the Clutch Lever switch. Try pushing the lever forward and then setting the cruise. Also check the Brake switches and the Throttle cable switch.

Good Luck,
John
Feb 25th, 2013 12:37 pm
ronslaverda
Cruise Control

Hi,
My cruise control has stopped working, I have checked the fuse (OK) and when it is switched on the small red light in the switch illuminates the instrument panel light doesn't come on when it is switched on.
Does this ring a bell with anybody, thanks for any forthcoming help.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome