BMW Luxury Touring Community - Reply to Topic
Thread: BC-1 on a 99 LT questions... Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
May 26th, 2007 2:40 pm
stevek1200lt Hi
We have a 99 LT with BC-1 and have used both old and new style of headset connectors. Old style is single cord. New style is universal - dual cord. The bike needs to be on for the headset to work. Also insure that the mute button is not engaged. Here is an article on the adjustments for the BC-1

http://www.geocities.com/weirsoft/bc1.html

Hope that helps

Steve
Olympia
May 26th, 2007 10:47 am
jericbrinley
BC-1 on a 99 LT questions...

I own a 99 LT that came with the BC-1 set-up. I have purchased a headset and the connect cables. I am committed to using this system rather than investing in a newer set up due to budgetary considerations.

Does anyone out there have experience on the set up and use of the BC-1 system? I have plugged in the headset and at this point can not hear music or connect to the CB (Midland) the prior owner installed.

Any help would be appreciated... Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome