BMW Luxury Touring Community - Reply to Topic
Thread: LT Charging Question Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Nov 21st, 2016 8:19 pm
dfinazzo
Re: LT Charging Question

Thanks for the link to Battery Minders - I have been using Optimate for years now and I am in the market for another charger looks like I will be shopping and comparing . . .
Nov 21st, 2016 7:49 pm
GaryEm
Re: LT Charging Question

Quote:
Originally Posted by Patric View Post
I get the charger attached to the battery, then plug the charger to the power. I use a weatherproof 800 MA battery tender, . It has a light that goes from red, for a low charged battery to yellow to green.

I have had it go red after a ride if the AC power was onto the charger before the battery was conected . But if I have the battery to the charger before the charger is powered up , I never get the red or yellow, it goes green every time.
It does not matter which way I do the charger plug in before or after putting the clips on the battery It starts yellow after a ride and goes to green
Nov 20th, 2016 9:29 pm
Patric
Re: LT Charging Question

I get the charger attached to the battery, then plug the charger to the power. I use a weatherproof 800 MA battery tender, . It has a light that goes from red, for a low charged battery to yellow to green.

I have had it go red after a ride if the AC power was onto the charger before the battery was conected . But if I have the battery to the charger before the charger is powered up , I never get the red or yellow, it goes green every time.
Nov 20th, 2016 8:15 pm
GaryEm
Re: LT Charging Question

Quote:
Originally Posted by Patric View Post
Do you plug the charger in to the AC after in is attached to the battery, or ? I have found for me it works better that way.
I attache the charger right to the battery
Nov 20th, 2016 6:57 pm
Patric
Re: LT Charging Question

Do you plug the charger in to the AC after in is attached to the battery, or ? I have found for me it works better that way.
Nov 20th, 2016 4:08 pm
GaryEm
Re: LT Charging Question

Just a Scorpion battery YT51913-22 (255 CCA) sealed With a Schumacker battery maintainer
Nov 20th, 2016 5:19 am
simoncharles
Re: LT Charging Question

BMW Battery Information BMW MOTORCYCLES OF SAN FRANCISCO SAN FRANCISCO, CA (415) 503-9988

I normally purchase the battery shown here (Exide) and use the charger shown in the middle.

I once purchased an Odyssey but quite frankly didn´t notice any difference.
Nov 19th, 2016 8:28 pm
Voyager
Re: LT Charging Question

Quote:
Originally Posted by JVRx7 View Post
I very highly recommend VDC Electronics BatteryMINDer products for the proper care & maintenance of lead acid batteries.

They understand the chemistry & physics involved and build their equipment accordingly.

Sent from my LG-H900 using Tapatalk
I concur. I own three of them. 🙂
Nov 19th, 2016 6:35 pm
TWAustin
Re: LT Charging Question

Thanks, Gordon - I'll do that.
Nov 18th, 2016 6:08 pm
JVRx7
Re: LT Charging Question

Quote:
Originally Posted by TWAustin View Post
I have a 2009 LT that I keep on a battery tender when not in use. The battery tender indicates when the battery is less than 85% charged, more than 85% and less than 100%, and when it is 100%.

So here is my question - after riding for several hours, 200 or more miles, when I put the tender on the bike after riding, it shows less than 85% charged, always. Shouldn't the charge be at or near 100% if the charging system is working properly? Especially after riding at highway speeds for an extended period?


Thanks for any help you can give.
I very highly recommend VDC Electronics BatteryMINDer products for the proper care & maintenance of lead acid batteries.

They understand the chemistry & physics involved and build their equipment accordingly.

Sent from my LG-H900 using Tapatalk
Nov 18th, 2016 4:16 pm
simoncharles
Re: LT Charging Question

Nov 18th, 2016 3:32 pm
bmwcoolk1200
Re: LT Charging Question

Quote:
Originally Posted by TWAustin View Post
Thanks much for the help. The battery is a sealed Odyssey battery that is about 6 months old. The voltmeter shows 12.98, so my assumption has been that the battery is ok.

When I put the voltmeter on it, I took it off the tender, and then when I put the tender back on it, it showed red again, but just briefly. Sounds like you hit the nail on the head and I have my answer. Thanks a lot for the input.
Sounds like you are in good shape then and the operation of your tender is in fact normal.

If you want to do one more test, take the tender off and leave it for several hours or even over night. There is a slight drain from the electronics but it should not effect this unless it is excessive. Check the battery voltage after it has been off the tender for awhile and the batter has settled. At 100% charge ( NEW), the Odyssey will be at 12.84 or higher and 90% at about 12.5 per their site. Being pretty new, I would expect it to be pretty close in that range after settling off float. If it stays pretty close to 12.98 after several hours or over night, baring some strange fault, I would agree with you that you are making a good assumption that your battery is OK and you should look for changes in the time it takes to move from testing or evaluating to 100%. If you see that changing, then look at it more closely again.
Nov 18th, 2016 2:54 pm
TWAustin
Re: LT Charging Question

Quote:
Originally Posted by bmwcoolk1200 View Post
I have a simpler tender and it has a red and green light and yes, even after riding, the red light comes on for a short period but fairly quickly moves to green.

Telling Tony not to worry about it with no other information on age and type has not answered his question. A few simple tests will give more peace of mind and validate that normal is what he is seeing rather than having a several year old flooded battery that is low on fluid and getting out 100 miles from home and not being able to start your bike because you didn't worry about it.


It may truly be normal but lets see if we can validate a few things before saying don't worry about it. Batteries fail in many ways.
Thanks much for the help. The battery is a sealed Odyssey battery that is about 6 months old. The voltmeter shows 12.98, so my assumption has been that the battery is ok.

When I put the voltmeter on it, I took it off the tender, and then when I put the tender back on it, it showed red again, but just briefly. Sounds like you hit the nail on the head and I have my answer. Thanks a lot for the input.
Nov 18th, 2016 1:55 pm
bmwcoolk1200
Re: LT Charging Question

Quote:
Originally Posted by simoncharles View Post
I wouldn´t worry too much about it.

I think it´s because the tender needs time to evaluate the battery´s condition.

I have just installed a brand new battery on ( in ? ) my bike, and the same thing happens.
I have a simpler tender and it has a red and green light and yes, even after riding, the red light comes on for a short period but fairly quickly moves to green.

Telling Tony not to worry about it with no other information on age and type has not answered his question. A few simple tests will give more peace of mind and validate that normal is what he is seeing rather than having a several year old flooded battery that is low on fluid and getting out 100 miles from home and not being able to start your bike because you didn't worry about it.


It may truly be normal but lets see if we can validate a few things before saying don't worry about it. Batteries fail in many ways.
Nov 18th, 2016 1:04 pm
simoncharles
Re: LT Charging Question

I wouldn´t worry too much about it.

I think it´s because the tender needs time to evaluate the battery´s condition.

I have just installed a brand new battery on ( in ? ) my bike, and the same thing happens.
Nov 18th, 2016 12:18 pm
bmwcoolk1200
Re: LT Charging Question

Quote:
Originally Posted by TWAustin View Post
I have a 2009 LT that I keep on a battery tender when not in use. The battery tender indicates when the battery is less than 85% charged, more than 85% and less than 100%, and when it is 100%.

So here is my question - after riding for several hours, 200 or more miles, when I put the tender on the bike after riding, it shows less than 85% charged, always. Shouldn't the charge be at or near 100% if the charging system is working properly? Especially after riding at highway speeds for an extended period?


Thanks for any help you can give.
If you can have the battery load tested, it will let you know if it is in good shape or not.

Couple questions.
How old is the battery and what type is it? Flooded, AGM, LION
If it is it a flooded battery, how is the acid level in the cells?
Do you have a volt meter to test the battery voltage and the running charge voltage of the system?
Nov 18th, 2016 12:11 pm
TWAustin
LT Charging Question

I have a 2009 LT that I keep on a battery tender when not in use. The battery tender indicates when the battery is less than 85% charged, more than 85% and less than 100%, and when it is 100%.

So here is my question - after riding for several hours, 200 or more miles, when I put the tender on the bike after riding, it shows less than 85% charged, always. Shouldn't the charge be at or near 100% if the charging system is working properly? Especially after riding at highway speeds for an extended period?


Thanks for any help you can give.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome