Fogs Problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Mar 21st, 2018, 5:07 am Thread Starter
Junior Member
 
Denisse's Avatar
 
Join Date: Mar 2018
Posts: 7
Red face Fogs Problem

Hello, I recently ordered WeePro visor insert online, since they give away free sample. Have any of you tried any visor inserts in your helmet like this? I just want to know if these inserts helps you out with your visor fogging problem. What are also the pros and cons in using this kind of products because I'm afraid if there's a possibility that it might damage my visor. Btw, I use Shark Helmet. Thanks!. :-)
Denisse is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Mar 21st, 2018, 8:41 am
Lifetime Supporter
 
PadG's Avatar
 
Join Date: Aug 2008
Location: Solon, OH, USA
Posts: 4,564
Re: Fogs Problem

Quote:
Originally Posted by Denisse View Post
Hello, I recently ordered WeePro visor insert online, since they give away free sample. Have any of you tried any visor inserts in your helmet like this? I just want to know if these inserts helps you out with your visor fogging problem. What are also the pros and cons in using this kind of products because I'm afraid if there's a possibility that it might damage my visor. Btw, I use Shark Helmet. Thanks!. :-)
I have the pinlock unit in my Neotec helmet, and I will say that it is excellent! Definitely will not fog up. The differences in different brand will probably be in the optical property of the insert, and perhaps how well they work. I can only tell you about the pinlock.

Pad. Gajajiva
Solon, OH, USA

2015 R1200RT (San Marino Blue Met.)
2014 R1200RT (Quartz Metallic Blue - Returned to BMW)
2007 R1200RT (Sold!)


Once Upon a Time........
1963 Norton Dominator 650 SS
1960 Triumph Bonneville (T120)
1960 Triumph Thunderbird (6T)
1952 Triumph Thunderbird (6T)
1932 Triumph 500
1952 BSA Goldstar
PadG is offline  
post #3 of 3 Old Mar 22nd, 2018, 8:03 pm
cws
Senior Member
 
cws's Avatar
 
Join Date: Aug 2005
Location: Sydney, NSW, Australia
Posts: 3,178
Garage
Question Re: Fogs Problem

Quote:
Originally Posted by Denisse View Post
Hello, I recently ordered WeePro visor insert online, since they give away free sample. Have any of you tried any visor inserts in your helmet like this? I just want to know if these inserts helps you out with your visor fogging problem. What are also the pros and cons in using this kind of products because I'm afraid if there's a possibility that it might damage my visor. Btw, I use Shark Helmet. Thanks!. :-)
Hello Denisse, or Samantha, or whoever you are!

I recently contacted Taylors Lei at Weetect to ask about the WeePro, (no free samples offered) and they offered me a shipment deal which would only be worthwhile if I bought say 10 of the visors and then resold them.

So if you'd like to send me your one to test out (I'm in Sydney...) if you are "concerned" with what it might do to your visor, then I'll happily do a real-world test on it in Australian conditions. I also wear a Shark helmet (flip-face).

BTW, did you buy it or get it free? In 2 posts you say different things...???

best regards.....


(also BTW, building up post counts by commenting on old threads is a bit of a give-a-way....)

Chris
Sydney, NSW
2005 Dark Graphite Metallic K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 Orient Blue Metallic K1200GT SE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(sold 2019)
2000 Red Honda CB250 (the toy)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ulysses #45310
GS911


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Last edited by cws; Mar 22nd, 2018 at 8:11 pm.
cws is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 LT a No Start Problem knlkern K1200LT 11 Aug 26th, 2008 9:00 pm
Very strange electrical problem starvingdrummer K1200LT 10 May 21st, 2008 10:17 am
Could my '05 center stand problem be this simple? mrbiker K1200LT 3 May 6th, 2008 8:17 pm
Computer Problem Response Form Lonewuff Humor 3 Mar 14th, 2008 3:53 pm
Problem with a BMW car - Am I being unreasonable? DanDiver Chit Chat 8 Dec 20th, 2007 11:51 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome