Low beam HID works and quits - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Mar 20th, 2006, 7:02 pm Thread Starter
 
Join Date: Jul 2005
Posts: 326
Low beam HID works and quits

Buddy of mine has an 05 LT and his low beam HID will work sometimes and sometimes not. Any thoughts?
SeaMarshal is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Mar 20th, 2006, 7:23 pm
 
Join Date: Feb 2004
Posts: 4,905
Connectors good? Does he have a relay?
messenger13 is offline  
post #3 of 4 Old Mar 20th, 2006, 7:25 pm
Senior Member
 
grifscoots's Avatar
 
Join Date: May 2002
Location: Outside New Braunfels , TX, USA
Posts: 13,451
Have him check the ground wire at the light.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

-=grif=-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Grok
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
grifscoots is offline  
 
post #4 of 4 Old Mar 20th, 2006, 7:32 pm
 
Join Date: Feb 2004
Posts: 4,905
Quote:
Originally Posted by grifscoots
Have him check the ground wire at the light.
Bam! Good call.
messenger13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome