HID Headlight Won't Lite - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Apr 6th, 2014, 1:52 am Thread Starter
Senior Member
 
dwillie's Avatar
 
Join Date: Aug 2002
Location: Far West of Chicago, Illinois, USA
Posts: 192
HID Headlight Won't Lite

Hi everyone. My formally working HID headlight is now _not_ working. Fuse is fine, so maybe the bulb or igniter has failed. When a normal bulb is burned out, you can see the filament is broken. How do you tell if a HID bulb is burned out? Any suggestions as I begin to trouble shoot? Thanks, dwillie.
dwillie is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Apr 6th, 2014, 6:25 am
cwo
Senior Member
 
cwo's Avatar
 
Join Date: Nov 2009
Location: Baldwin City, KS, USA
Posts: 374
Re: HID Headlight Won't Lite

I HAVE THE DDM HID ON MY LT, AND SOMETIMES I HAVE TO REMOVE BULB, AND RE-INSERT FOR THE HID TO WORK. MAYBE A GROUND OR SOMETHING??

CHRIS OGLE

Life is ephemeral. Don't waste it lookin up big words.
cwo is offline  
post #3 of 8 Old Apr 6th, 2014, 7:24 am
Senior Member
 
mtrevelino's Avatar
 
Join Date: Apr 2002
Location: Williamsburg, VA, USA
Posts: 2,552
Re: HID Headlight Won't Lite

For as cheap as they are, just order another kit and be done with it. Mine went out on my LT after about five years, I just replaced the kit and be done with it.

Mike Trevelino
Williamsburg, VA
2008 RT
2000 LT - Totaled at 99,960 miles


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mtrevelino is offline  
 
post #4 of 8 Old Apr 6th, 2014, 8:42 am
Senior Member
 
vespacar's Avatar
 
Join Date: Oct 2013
Location: Toronto, Ontairo, Canada
Posts: 151
Re: HID Headlight Won't Lite

I go as far as having a spare bulb and ballast around. On my Piaggio I went through a few (cheap chinese ones). But what I did find that my battery was going as well. Replaced the battery with a nice AGM battery and guess what , no more burnt out HID bulbs/ballasts, could there be a connection, maybe. There's not really much to fault check, you can make sure all of the connections are connected, move the wires around, but really that's about all.

Who did you order the kit from and how long ago? Some offer a warranty. Remember you can always put back a H11 so you can ride until your new Kit arrives. Also I've always ended up replacing both the bulb and the ballast. You could get lucky, but order both anyway.

Cheers,
Tross

2002 K1200lt
2010 Piaggio MP3 500
1982 Lambretta GP225


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
vespacar is offline  
post #5 of 8 Old Apr 6th, 2014, 11:37 am
Senior Member
 
rowie's Avatar
 
Join Date: Sep 2009
Location: An hour southwest of Boston, MA, USA
Posts: 476
Re: HID Headlight Won't Lite

These things can be sensitive to a low battery. Make sure your battery is fully charged and try again. Mine was a bit intermittent until the battery was charged, then it was fine. If this isn't the problem, the bulbs rarely die, usually the box that the bulb is connected to is the culprit.

Hope this helps.

BMWMOA member

Current rides:
2005 Dark Graphite Metallic BMW K1200LT
2002 Pearl Orange Honda VTX1800 Retro

Prior rides:
Suzuki GS425E (Australia)
Suzuki T250R (Australia)
rowie is offline  
post #6 of 8 Old Apr 6th, 2014, 2:51 pm
Senior Member
 
Zeke's Avatar
 
Join Date: Aug 2002
Location: Loxahatchee, Fl, USA
Posts: 986
Re: HID Headlight Won't Lite

They are cheap now for the whole kit,Not sure what year you have but on my 02
what i did was just switch the high and low, if it works you know the issue.
But I think I bought mine ,30$ for 2 bulbs.

45 years riding and still more places to see.
2002 K1200LT
2016 R1200RT
IBA # 41935
Zeke is offline  
post #7 of 8 Old Apr 6th, 2014, 5:37 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,263
Re: HID Headlight Won't Lite

If the quartz globe in the center of your HID bulb is shattered then the bulb is bad. Otherwise it is your ballast/igniter. heck any in line fuse for corrosion as well and the ground run (stock headlight area).

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #8 of 8 Old Apr 6th, 2014, 8:59 pm Thread Starter
Senior Member
 
dwillie's Avatar
 
Join Date: Aug 2002
Location: Far West of Chicago, Illinois, USA
Posts: 192
Re: HID Headlight Won't Lite

Thank you all for your suggestions. I am on it. Possible relay gone bad (Song Chuan 804-1a-c1), 30Amp. I will also check the bulb and all ground connections. d.
dwillie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ducati Design Headlight HID upgrade ridinredfox K1200LT 3 May 18th, 2011 11:19 am
HID xenon headlight bulb on eBay??.. And is my relay goin bad? beemerguywhotravelsalot K1200LT 3 Jun 23rd, 2009 2:49 pm
Pondering pathBlazer &/or HID Headlight Addition? lawrider K1200LT 2 Mar 15th, 2009 5:44 pm
'02 Headlight with HID Low & High a headlight on ebayon EBay carl_faller Chit Chat 1 Sep 7th, 2007 3:36 am
Headlight Modulator and Low Beam HID ihbond K1200LT 8 May 9th, 2007 5:39 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome