Dagnamit...! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Feb 21st, 2014, 9:01 am Thread Starter
Member
 
Brianmered's Avatar
 
Join Date: Nov 2009
Location: Coventry
Posts: 62
Dagnamit...!

Pulled the tupperware and successfully fitted and wired in calliper motolights. Put it all back together and wouldn't you know it, windscreen doesn't raise...not sure when it stopped working as I hardly ever use it. I like to wash the bike with the windscreen raised as it's easy to get access under the screen for drying.

Where do I start, apart from the fuse which I have already checked. I am worse than useless at electrics....
Brianmered is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Feb 21st, 2014, 9:26 am
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Dagnamit...!

Quote:
Originally Posted by Brianmered View Post
Pulled the tupperware and successfully fitted and wired in calliper motolights. Put it all back together and wouldn't you know it, windscreen doesn't raise...not sure when it stopped working as I hardly ever use it. I like to wash the bike with the windscreen raised as it's easy to get access under the screen for drying.

Where do I start, apart from the fuse which I have already checked. I am worse than useless at electrics....
Darn, I wuz gonna tell ya to check 'both' fuses relative to the windshield adjustor (one for the switch 4A and one for the adjustor motor 15A as on my '99), butt just recalled that you have a 2007 LT and I don't know the fuse layout for that model year. Just check your fuse list close and see if there might be two fuses for the 2007. Stay tuned for an electric guru, coming up!
Dick is offline  
post #3 of 7 Old Feb 21st, 2014, 10:43 am
Senior Member
 
Join Date: May 2011
Location: Oshawa, Ontario, Canada
Posts: 978
Re: Dagnamit...!

if you do not use it much likely the 4 pivot pins are seizing, have you tried helping screen to move manually while pushing button to raise, if it goes up and down with help lubricate the pins

Gary
2018 R1200RT
Past rides
2012 K1600GTL
2000 K1200LT
1992 K1100LT
2000 V Star 650/Velorex sidecar
1985 K100RT
1965 R60/2
1960 AJS 500 single
gary45 is offline  
 
post #4 of 7 Old Feb 21st, 2014, 12:39 pm Thread Starter
Member
 
Brianmered's Avatar
 
Join Date: Nov 2009
Location: Coventry
Posts: 62
Re: Dagnamit...!

Thanks Dick...I don't have my manual with me at the moment so I just went through all the fuses to be sure. I thought there was only one 15 amp fuse but I'll double check them all again to be sure. Didn't know about the 4 amp switch fuse.

Gary, I read about maintaining the lifter arms and did WD40 the pivot points while I had the windscreen off but it all looks as good as new....I tried a helping hand but to no avail.
Brianmered is offline  
post #5 of 7 Old Feb 21st, 2014, 12:51 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,269
Re: Dagnamit...!

It is a 7.5 amp F6 on the 05 and up units vs. a 4 amp.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #6 of 7 Old Feb 21st, 2014, 1:35 pm Thread Starter
Member
 
Brianmered's Avatar
 
Join Date: Nov 2009
Location: Coventry
Posts: 62
Re: Dagnamit...!

Thanks Wrencher Extraordinaire, that's worth knowing...
Brianmered is offline  
post #7 of 7 Old Mar 2nd, 2014, 12:59 pm Thread Starter
Member
 
Brianmered's Avatar
 
Join Date: Nov 2009
Location: Coventry
Posts: 62
Re: Dagnamit...!

The good Lord smiles on the righteous....wife and I went for a last spin before she (not the wife) gets crated for her trip to the UK. Tried the windscreen switch and lo and behold it worked. Can only think that I was too generous with the WD40 that I sprayed onto the lifting mechanism pivots and it somehow got into something it shouldn't have!. Anyway good news is I don't have to do anything with it when it arrives in Blighty.
Brianmered is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome