FD Castle Speedo Ring Failure - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Nov 23rd, 2013, 2:44 pm Thread Starter
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,851
FD Castle Speedo Ring Failure

I thought I would post a few pic's of a 1999 LT FD that the castle speedo ring came off & got beat up pretty good. I have been able to repair them before without removing the tapered bearing but not this one.

The ring was deformed & three of the tabs were bent. one of the tabs was out .043". The rings are unavailable so I got it straight within .001" & I'll have to get a little creative to make sure it does not come off again.

This FD also had the pinion needle bearing race that had moved into the FD housing.
Attached Thumbnails
Click image for larger version

Name:	Christian Hugener 005.JPG
Views:	141
Size:	902.2 KB
ID:	45225   Click image for larger version

Name:	Christian Hugener 004.JPG
Views:	108
Size:	909.8 KB
ID:	45233   Click image for larger version

Name:	Christian Hugener 003.JPG
Views:	88
Size:	903.6 KB
ID:	45241   Click image for larger version

Name:	Christian Hugener 009.JPG
Views:	117
Size:	847.3 KB
ID:	45249  

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Nov 23rd, 2013, 3:42 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 12,928
Re: FD Castle Speedo Ring Failure

Wow that was beat up pretty good. I have one from my CCR demo drive if you ever need one.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 7 Old Nov 23rd, 2013, 3:58 pm Thread Starter
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,851
Re: FD Castle Speedo Ring Failure

Any idea why the pic's are so big ?.

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
 
post #4 of 7 Old Nov 23rd, 2013, 4:21 pm
Senior Member
 
mycamel's Avatar
 
Join Date: Jun 2012
Location: roswell , ga, usa
Posts: 512
Re: FD Castle Speedo Ring Failure

Hijack: look at the pockets in the background of the 1st photo. wonderful

ok

end jack

Mike Hammel (My Camel) [WB9GMO/4]
2002 K1200LT-E
1998 ACE Burgundy (now 'retired')
1998 ACE Yellow/Black Tourer (now 'retired')
19?? Suzuki 500 (now 'retired')
1962 modifed 49cc>~55cc Sears MoPed (LONG 'retired')

US Army Security Agency 0582L68 ('64-68)
moderator and owner:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Retired from the business world (finally--sigh --poor and proud)
Georgia Patriot Guard Riders
Roswell, GA
mycamel is offline  
post #5 of 7 Old Nov 24th, 2013, 7:41 pm Thread Starter
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,851
Re: FD Castle Speedo Ring Failure

I cured the 620 Locktite at 65 degrees fahrenheit for 24 hours while still in the press & now the parts will cure for another 24 hours at 160 degrees fahrenheit in a oven.
Attached Thumbnails
Click image for larger version

Name:	Knee Pockets 008.JPG
Views:	76
Size:	809.1 KB
ID:	45266  

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
post #6 of 7 Old Nov 25th, 2013, 5:35 am
Senior Member
 
CharlieVT's Avatar
 
Join Date: Jun 2002
Location: , ,
Posts: 4,382
Re: FD Castle Speedo Ring Failure

Hi Dave,

I'm curious, did the pinion bearing race wear through the housing? Do you think the "creeping" race was it the cause of the speedo sending ring being displaced? Or were they two unrelated events?

I've seen examples where the creeping race traveled far enough to actually rub on the speedo ring and cause it to be displaced. If the displacement of the speedo ring wasn't caused by the creeping pinion bearing, I wonder what caused it to come loose. Any ideas?

10 degrees F here this AM plus windy. Cool.

Happy Thanksgiving
CharlieVT is online now  
post #7 of 7 Old Nov 25th, 2013, 7:05 am Thread Starter
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,851
Re: FD Castle Speedo Ring Failure

Hi Curtis, The two are unrelated. I've had two other speedo rings that were loose but they had not come off. I was able to Loctite them on without removing the taper bearing.

I'm not sure what causes the ring to come loose other than there is not very much area for a press fit. I have no way I can measure how much press fit it had because the ring was out of round.

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Poll...How many folks have had final drive problems missusfinz RT Series 126 Aug 16th, 2015 7:59 pm
What are the suspected reasons for final drive failures av8trto K1200LT 49 May 31st, 2012 7:02 pm
00 Speedo jerky, Sensor Ring loose jello4 K1200LT 16 Oct 1st, 2010 11:14 am
Final Drive Failures at 4% rate? hallzee K1200LT 27 Nov 24th, 2007 3:49 pm
Speedo failure 1st bustedknuckles K1200LT 6 Feb 15th, 2007 8:17 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome