Backfire on throttle roll-off - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Sep 30th, 2013, 1:19 pm Thread Starter
Senior Member
 
dvgb131's Avatar
 
Join Date: Jul 2013
Location: Guilderland, NY, USA
Posts: 207
Garage
Backfire on throttle roll-off

What causes a backfire when rolling-off the throttle in third or fourth gear, usually around 60MPH? Not hard to repeat.

2000 LT 132,000 miles.
2002 motor 40,000 miles.
Less than 1,000 miles are mine. Only had bike since late July.
New fuel filter and hoses, TPS, oil and filter.
Mileage sucks too. 30-35MPG.

Thanks.

Doug B.
2000 LT purchased July 2013
dvgb131 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Sep 30th, 2013, 1:24 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,301
Re: Backfire on throttle roll-off

With that kind of mileage I would replace the O2 sensor. Unless you spend all your time at 7,000 RPM or pull a trailer in a head wind your mileage should be well above 42 MPG.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 4 Old Sep 30th, 2013, 1:51 pm Thread Starter
Senior Member
 
dvgb131's Avatar
 
Join Date: Jul 2013
Location: Guilderland, NY, USA
Posts: 207
Garage
Re: Backfire on throttle roll-off

Quote:
Originally Posted by jzeiler
With that kind of mileage I would replace the O2 sensor. Unless you spend all your time at 7,000 RPM or pull a trailer in a head wind your mileage should be well above 42 MPG.
That's what I got from this forum about the mileage. Part came in last week. Anything I need to watch out for? I bought the Bosch universal replacement from Beemer Boneyard.

Doug B.
2000 LT purchased July 2013
dvgb131 is offline  
 
post #4 of 4 Old Sep 30th, 2013, 8:09 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,301
Re: Backfire on throttle roll-off

If it has a round four pin connector it should be install and play.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Throttle cable replacement notes johnrehder K1200LT 26 Aug 8th, 2013 8:54 am
Throttle Cable Repl CONCERN?? JimMc K1200LT 6 Apr 26th, 2012 10:46 am
Throttle body sync question bobmwmz K1200LT 5 Oct 9th, 2011 10:46 am
Throttle balance ramblings BigKev RT Series 15 Jun 23rd, 2011 11:05 am
Rather longish, but good tips & info! vvk Bike Talk 7 Jun 19th, 2011 5:43 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome