Brake lights not working with front brake. - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Sep 14th, 2013, 7:21 pm Thread Starter
Junior Member
 
Join Date: Sep 2013
Location: , , USA
Posts: 2
Brake lights not working with front brake.

I've got a 2001 K1200LT with the ABS II system. I discovered today that the brake lights don't come on with the front brake. I have a very good understanding of automotive electrical systems, I'm just looking for some details on this particular system so I don't have to tear the entire bike apart to find the problem. The brake lights work when the rear brake lever is pressed, that confirms that the relay and bulbs are good. I've checked the front switch, it closes when the lever is pulled. I've checked the wiring from the switch down to the two wire connector behind the headlight, all good. I'm getting 12v up to that connector (and through to the switch), so I suspect a wire between that connector and the relay is broken or disconnected somewhere. I just want someone to confirm that it's as simple as that, switch activates relay activates lights, and that the ABS module has nothing to do with it. I've read something about the ABS module controlling the light relay, but I think that only pertains to the newer integrated ABS models. If someone can point me to a schematic that would be great.
Interceptor is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Sep 14th, 2013, 8:03 pm
Senior Member
 
Join Date: Sep 2011
Location: Middleburg, Fl, Usa
Posts: 193
Re: Brake lights not working with front brake.

According to the schematic in the Clymer manual, the green/black wire to the switch is 12V, the gray/yellow is switch output, which joins with another gray/ yellow to go to the brake light relay.

And, yes, the same fuse (fuse box 1 fuse 1) feeds both brake light switches.

Be aware the Clymer schematics are not 100% accurate.

Current:
2006 BMW K1200LT
2010 BMW R1200RT
Previous:
1999 BMW K1200LT
2007 Yamaha FZ6
1986 Suzuki GS550L
1985 Suzuki GS650L
1977 Kawasaki KZ650
1975 Kawasaki F7
1973 Honda CB175
r_figueroa is offline  
post #3 of 4 Old Sep 14th, 2013, 8:25 pm
Senior Member
 
sailor's Avatar
 
Join Date: Nov 2004
Location: Montreal ,QC , Canada
Posts: 1,171
Re: Brake lights not working with front brake.

Quote:
Originally Posted by Interceptor
I've got a 2001 K1200LT with the ABS II system. I discovered today that the brake lights don't come on with the front brake. I have a very good understanding of automotive electrical systems, I'm just looking for some details on this particular system so I don't have to tear the entire bike apart to find the problem. The brake lights work when the rear brake lever is pressed, that confirms that the relay and bulbs are good. I've checked the front switch, it closes when the lever is pulled. I've checked the wiring from the switch down to the two wire connector behind the headlight, all good. I'm getting 12v up to that connector (and through to the switch), so I suspect a wire between that connector and the relay is broken or disconnected somewhere. I just want someone to confirm that it's as simple as that, switch activates relay activates lights, and that the ABS module has nothing to do with it. I've read something about the ABS module controlling the light relay, but I think that only pertains to the newer integrated ABS models. If someone can point me to a schematic that would be great.
Correct that the brake switches of the Integral-ABS are controlled by ABS unit. Earlier ABSII, have regular (more simple) brake switches that should have continuity when brake (lever or pedal) are applied. Just be careful with 2001 year models as Canada and Europe got the Integral-ABS in 2001, BUT the USA got them starting in 2002 only. Based on the noise they do, you would know is you have Integral-ABS (with servos).

FOR ABSII ONLY:
Check attached picture for location of the connector AND location of brake light relay. To get to this relay you need to remove lots of stuff including the fuel-tank, Note that this relay is lower than all other relays - as it is in lower section of the electrical box.

As Input-Output to the Relay, the official BMW electrical diagram shows:
1) One GRAY-YELLOW wire (input from both brake switches)
2) One BROWN wire (normally ground in BMW bikes)
3) One RED-BLACK wire (power from FUSE #3)
4) One GRAY-YELLOW wire (Output to rear light unit)
Attached Thumbnails
Click image for larger version

Name:	K1200LT (1999-2001) Front_brake-switch_wiring.jpg
Views:	1307
Size:	173.7 KB
ID:	41026  

-------------------------------------------------
John (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 96,000 miles)
-------------------------------------------------
Think twice before you hit [SUBMIT REPLY] - famous quote by another member:
"The value of this board is not founded on dismissing the ideas of others, but by posting to share our experiences and what we've learned from them."
sailor is online now  
 
post #4 of 4 Old Sep 15th, 2013, 6:58 am Thread Starter
Junior Member
 
Join Date: Sep 2013
Location: , , USA
Posts: 2
Re: Brake lights not working with front brake.

Thanks for the help guys, I've got it figured out. The brake and clutch switches were swapped at the row of connectors behind the headlight. They use the same connector and same wire colors on the handlebar side, I must have mixed them up during a previous repair. I never noticed that the brake lights were coming on when I pulled the clutch!
Interceptor is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear brake stuck/ not fully releasing joseph_p K1200LT 16 Aug 28th, 2013 7:38 pm
Comfortable riding: pegs? LeftCoastMan RT Series 41 Aug 24th, 2013 11:20 am
Rear Brake Reservoir Hollywood K1200LT 10 Oct 20th, 2009 1:49 pm
Help! Odd front brake problem. 430flyer K1200LT 0 Sep 30th, 2007 5:16 pm
Front Brake Lever Issue Jerrod Maguire K1200LT 2 Jan 21st, 2006 12:49 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome