Radio Inop 1999lt - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Sep 7th, 2013, 7:49 pm Thread Starter
Junior Member
 
Lefty's Avatar
 
Join Date: Feb 2007
Location: LlIGHTHOUSE POINT, FLORIDA, USA
Posts: 14
Smile Radio Inop 1999lt

Hello to all,
After sitting for about 15 months my radio on my 1999LT will not come on. No display no sound.....any thoughts on where to start ?

ALL BMW OWNERS SHARE THE SAME QUALITIES, TECHNICAL,SMART AND HELPFUL
Lefty is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Sep 7th, 2013, 8:20 pm
Lifetime Supporter
 
johnbaker15's Avatar
 
Join Date: Sep 2010
Location: Chelmsford, Ma, USA
Posts: 1,595
Re: Radio Inop 1999lt

Quote:
Originally Posted by Lefty
Hello to all,
After sitting for about 15 months my radio on my 1999LT will not come on. No display no sound.....any thoughts on where to start ?
Sometimes you can bring it back to life by disconnecting the battery for a few minutes and reconnecting. BTW how is the battery.

John Baker

2005 BMW K1200LT
1979 Suzuki GS1000E
1978 Honda CB350
1975 Suzuki GT380
johnbaker15 is offline  
post #3 of 4 Old Sep 8th, 2013, 8:05 am Thread Starter
Junior Member
 
Lefty's Avatar
 
Join Date: Feb 2007
Location: LlIGHTHOUSE POINT, FLORIDA, USA
Posts: 14
Re: Radio Inop 1999lt

The battery is about 3 years old and has been on a tender.

ALL BMW OWNERS SHARE THE SAME QUALITIES, TECHNICAL,SMART AND HELPFUL
Lefty is offline  
 
post #4 of 4 Old Sep 8th, 2013, 5:53 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,266
Re: Radio Inop 1999lt

Battery condition is not a factor here as John said disconnect the negative terminal and leave it off for a few minutes. Then re-connect. This does a "hard reboot" of the radio (computer controlled) and will often correct a malfunction.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 10:24 am
Radio Repair Update - When is the next LT ready? Vince_nj1 K1200LT 28 Oct 2nd, 2010 3:46 pm
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 11:12 am
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 7:55 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome