Kickstand light flashing - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old May 31st, 2013, 1:07 pm Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Halifax, Nova Scotia, Canada
Posts: 8
Hydraulic center light flashing

I recently changed out my battery to an odyssey and took my first ride today worked good for 20 miles and then the hydraulic center stand light began flashing. I pulled over to ensure the center stand was up. I tried lowering the center stand with the bike running and in neutral and it would not descend. I put the bike in reverse and tried the stand and it worked and the light stayed out temporarily 3 or 4 minutes. Its back on now and I drove another 20 miles now even when I try it in reverse the stand will lower but doesn't have the power to lift the bike. The graphic for temperature were also spiking up down etc...but no warning lights.

Last edited by ScottNSLT; May 31st, 2013 at 2:25 pm. Reason: improper title
ScottNSLT is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old May 31st, 2013, 1:09 pm
Senior Member
 
TeddyTelco's Avatar
 
Join Date: Jan 2013
Location: Boston, Ma, USA
Posts: 308
Re: Kickstand light flashing

do you mean center stand?

2009 BMW K1200LT "Shelly"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 Honda VT1100 Sabre Sold
1979 Harley Davidson FXEF 1340 Sold
1975 Norton 850 Commando Sold
TeddyTelco is offline  
post #3 of 4 Old May 31st, 2013, 1:27 pm Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Halifax, Nova Scotia, Canada
Posts: 8
Re: Kickstand light flashing

Hi There yes i should have been a bit clearer its the electric center stand I have an 05 lt
ScottNSLT is offline  
 
post #4 of 4 Old May 31st, 2013, 8:39 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: Kickstand light flashing

It should not work in gear or in reverse (have not tried it yet). Sounds like the controller may be going out. Have not seen one so far on this board but there is always a first time. May want to check all your battery connections if you just changed it out. As strange things happen when one of the many wire on the positive terminal are accidentally left off. Stock there should but at least four red ones and one black yellow with a red sleeve.

If the motor (electric on the unit) is running and it will not fully lift the bike then it has lost fluid and should be re-built.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Failure Warning Light Flashing JoeTJ K1200LT 15 Jun 14th, 2013 5:34 pm
Turning off the ABS Flashing light tpfeffer RT Series 4 Jul 7th, 2011 12:18 pm
Flashing brake failure? gglove K1200LT 9 Oct 2nd, 2008 10:41 pm
Red flashing light question???? NOGILLS2 K1200LT 4 Sep 9th, 2008 8:48 pm
Flashing ABS lights budzee K1200LT 8 Aug 18th, 2006 11:48 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome