Radio problem: "NO RADIO" advice? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Mar 22nd, 2013, 1:25 pm Thread Starter
Senior Member
 
petevandyke's Avatar
 
Join Date: Jun 2006
Location: Dallas, TX, USA
Posts: 1,741
Radio problem: "NO RADIO" advice?

2004 K1200LT.

I haven'.t ridden it in about 5 months, took her out today and turned on the radio unit. Got "NO RADIO" flashing for about 20 seconds, when I hit the on/off button to turn it off, the display showed " |X| |X| |X| |X| |X|" even after shut-off. Turned the bike off, waited, turned on again, same thing.

Any ideas?

========================================
When life throws you a curve, LEAN INTO IT!!!
2000 R1100RT-P...R.I.P. "Old motorcycle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 K1200LT "Lick and Tickle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


FU*K Cancer. If I have one more MRI, I'll stick to the refrigerator door.
petevandyke is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Mar 22nd, 2013, 3:15 pm
Lifetime Supporter
 
PMitchell's Avatar
 
Join Date: Aug 2006
Location: Hudson, OH, USA
Posts: 2,878
Re: Radio problem: "NO RADIO" advice?

Pete,
Did you try the battery disconnect procedure?

pm
--
Life is too short to do anything
other than that about which you
are absolutely passionate . . .
Ride till you can't!

"Der Weg ist das Ziel"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 South Africa
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2014 The Dolomites of Italy, Alps of Switzerland & Austria and returning to Milan via the "Gold Coast" of the French Riveria.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2016 Spain & Portugal
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 Central & Eastern Europe: Slovenia, Austria, Poland,Hungary, Czech Republic & Slovakia!

'18 R1200RTW
'00 K1200LTC (Dealer is taking on consignment!)
'90 K75-Sold to a new BMW owner (2016)
'62 R 50/2 (Rode hard and put away wet)-Sold in '81
'63 Vespa 150 (1st and only dirt bike!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sold in '67


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PMitchell is offline  
post #3 of 7 Old Mar 22nd, 2013, 3:30 pm Thread Starter
Senior Member
 
petevandyke's Avatar
 
Join Date: Jun 2006
Location: Dallas, TX, USA
Posts: 1,741
Re: Radio problem: "NO RADIO" advice?

Will give that a try this weekend (including resetting the throttle position sensor).

In reading past threads on this, it seems exposure to water is the common element, mine has been in my garage for months on a battery tender, so that's odd.

========================================
When life throws you a curve, LEAN INTO IT!!!
2000 R1100RT-P...R.I.P. "Old motorcycle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 K1200LT "Lick and Tickle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


FU*K Cancer. If I have one more MRI, I'll stick to the refrigerator door.
petevandyke is offline  
 
post #4 of 7 Old Mar 24th, 2013, 11:10 am
Lifetime Supporter
 
PMitchell's Avatar
 
Join Date: Aug 2006
Location: Hudson, OH, USA
Posts: 2,878
Re: Radio problem: "NO RADIO" advice?

Any resolution of the problem?

pm
--
Life is too short to do anything
other than that about which you
are absolutely passionate . . .
Ride till you can't!

"Der Weg ist das Ziel"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 South Africa
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2014 The Dolomites of Italy, Alps of Switzerland & Austria and returning to Milan via the "Gold Coast" of the French Riveria.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2016 Spain & Portugal
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 Central & Eastern Europe: Slovenia, Austria, Poland,Hungary, Czech Republic & Slovakia!

'18 R1200RTW
'00 K1200LTC (Dealer is taking on consignment!)
'90 K75-Sold to a new BMW owner (2016)
'62 R 50/2 (Rode hard and put away wet)-Sold in '81
'63 Vespa 150 (1st and only dirt bike!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sold in '67


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PMitchell is offline  
post #5 of 7 Old Mar 24th, 2013, 11:14 am
Senior Member
 
deputy5211's Avatar
 
Join Date: Oct 2006
Location: Dallas Area, TX, USA
Posts: 4,877
Re: Radio problem: "NO RADIO" advice?

If you want to come by, we can strip her down, clean the contacts, put some dielectric on 'em, and see if that works. Making sure the control head is dry is also good. If you can get to it, remove it from stingray and pack in Ziploc full of plain white rice for a week or so. Have successfully used this method on a variety of electronics.

Antony (Tripod)
Dallas' Northern Suburbs
-----------------------------------------------

If you want to be happy for a day, drink.
If you want to be happy for a year, marry.
If you want to be happy for a lifetime, ride a motorcycle.

-----------------------------------------------


'05 K1200LT - Dark Graphite - RIP 04 OCT 2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'99 Road King Classic - Custom Blue/Silver & Chrome - "My Baby" Gone but forever in my heart!

and many, many others.
*

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
deputy5211 is offline  
post #6 of 7 Old Mar 24th, 2013, 8:55 pm Thread Starter
Senior Member
 
petevandyke's Avatar
 
Join Date: Jun 2006
Location: Dallas, TX, USA
Posts: 1,741
Re: Radio problem: "NO RADIO" advice?

Thanks, Tony.

Disconnected the battery for a couple hours, re-connected, and.......


NO RADIO.


I don't think it's water, as I haven't ridden in the rain or anything for months. I'll take a hairdryer on low to it and try the disconnect again, see if that helps.

Fortunately I usually listen to headphones and not the stereo system, but this will drag down the resale value when I sell her.

========================================
When life throws you a curve, LEAN INTO IT!!!
2000 R1100RT-P...R.I.P. "Old motorcycle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 K1200LT "Lick and Tickle"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


FU*K Cancer. If I have one more MRI, I'll stick to the refrigerator door.
petevandyke is offline  
post #7 of 7 Old Mar 24th, 2013, 10:47 pm
Senior Member
 
deputy5211's Avatar
 
Join Date: Oct 2006
Location: Dallas Area, TX, USA
Posts: 4,877
Re: Radio problem: "NO RADIO" advice?

Unless you put in a Jensen or other replacement, perhaps.

Antony (Tripod)
Dallas' Northern Suburbs
-----------------------------------------------

If you want to be happy for a day, drink.
If you want to be happy for a year, marry.
If you want to be happy for a lifetime, ride a motorcycle.

-----------------------------------------------


'05 K1200LT - Dark Graphite - RIP 04 OCT 2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'99 Road King Classic - Custom Blue/Silver & Chrome - "My Baby" Gone but forever in my heart!

and many, many others.
*

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
deputy5211 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
k 1200 lt radio problem airplane K1200LT 16 Apr 23rd, 2018 4:48 pm
"No Radio" JK75RT K1200LT 3 Jul 8th, 2009 11:09 am
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
Help, radio flashing "no Radio" docwagner K1200LT 9 Jun 28th, 2006 4:32 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome