Radio problems - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Mar 13th, 2013, 7:35 am Thread Starter
Junior Member
 
Wrodriguez3's Avatar
 
Join Date: Mar 2012
Location: Fayetteville, NC, USA
Posts: 8
Radio problems

This is my dilemma I have a BMW K1200LT 2005, with a Becker professional radio/CD. I had some problems with the radio and had it repair at the Becker Auto Sound Shop in NJ. They installed a new mother board with the proper program. Now I can hear a radio station but I have no control in changing either the radio station or the volume- it does not response, also the radio shutoff after 20 t0 25 seconds after is turn on. Can anyone give me an advice? At this point Iím at lost, I have trace all wires and check all harnesses and seems to be OK.
Wrodriguez3 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old Mar 13th, 2013, 11:39 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,139
Re: Radio problems

Sounds like they did not fix it or just introduced a new problem. One thing you can try is to force a hard re-boot of the radio. Disconnect the battery for 10-20 minutes them re-connect. That has been known to re-set the radio and sometimes fixes a glitch like yours.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is online now  
post #3 of 9 Old Mar 14th, 2013, 7:43 am
Junior Member
 
Join Date: Feb 2013
Location: newhall, derbyshire, United Kingdom
Posts: 8
Re: Radio problems

This sounds exactly the same as the faults on my radio.Had the radio/CD unit repaired and tested by Baris ,so I'm suspecting the display/button unit on the tank, but I'll try to re-boot
as this would be easier than removing all the Tupperware again.
Does the radio need to be switched on when you disconnect the battery prior to re-boot?
martinswad is offline  
 
post #4 of 9 Old Mar 14th, 2013, 11:24 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,139
Re: Radio problems

Quote:
Originally Posted by martinswad
Does the radio need to be switched on when you disconnect the battery prior to re-boot?
No it does not. There is unswitched power to the radio all the time that is why you disconnect the battery lead.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is online now  
post #5 of 9 Old Mar 14th, 2013, 12:06 pm
Junior Member
 
Join Date: Feb 2013
Location: newhall, derbyshire, United Kingdom
Posts: 8
Re: Radio problems

Thanks for that,
I'll give it a go.
martinswad is offline  
post #6 of 9 Old Mar 15th, 2013, 9:01 am
Junior Member
 
Join Date: Feb 2013
Location: newhall, derbyshire, United Kingdom
Posts: 8
Re: Radio problems

That didn't work
Back to the drawing board, and the search to find the elusive display/control unit for a reasonable price
martinswad is offline  
post #7 of 9 Old Mar 15th, 2013, 1:53 pm
Senior Member
 
deputy5211's Avatar
 
Join Date: Oct 2006
Location: Dallas Area, TX, USA
Posts: 4,877
Re: Radio problems

Have you contacted Becker for support on their recent repair?

Antony (Tripod)
Dallas' Northern Suburbs
-----------------------------------------------

If you want to be happy for a day, drink.
If you want to be happy for a year, marry.
If you want to be happy for a lifetime, ride a motorcycle.

-----------------------------------------------


'05 K1200LT - Dark Graphite - RIP 04 OCT 2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'99 Road King Classic - Custom Blue/Silver & Chrome - "My Baby" Gone but forever in my heart!

and many, many others.
*

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
deputy5211 is offline  
post #8 of 9 Old May 31st, 2013, 8:37 am
Junior Member
 
Join Date: Feb 2013
Location: newhall, derbyshire, United Kingdom
Posts: 8
Re: Radio problems

Finally found a control unit at a reasonable price, had the Tupperware party and .......


IT WORKS!!!!!!!!

The supplier, Dave at Freedom Trikes, Sheffield, UK has at least one more plus loads of LT spares. He's listing on ebay at the moment so maybe worth a look.
martinswad is offline  
post #9 of 9 Old May 31st, 2013, 7:13 pm
Miles of Smiles
 
Hilton's Avatar
 
Join Date: Oct 2002
Location: Touring Europe
Posts: 1,038
Garage
Re: Radio problems

Glad to hear you solved the problem.

I had a similar issue once. Erratic channel selection and volume control.
Chased it down to a missing pin in one of the connectors under the stingray.
Replaced with a fine needle and all was well again.
I have been using a dielectric grease from day one.

Enjoy the tunes.

Jenna: Ocean Blue '06
Hilton: Head of the Steering Committee.
Rena: The Committee.
ET4 Thing 1
ET4 Thing 2
Hilton is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
k 1200 lt radio problem airplane K1200LT 16 Apr 23rd, 2018 4:48 pm
New radio wiring question wyliedave K1200LT 4 Aug 12th, 2009 11:36 pm
radio problems jmc88_2 K1200LT 7 May 3rd, 2007 2:26 pm
No Radio hschisler K1200LT 19 Apr 19th, 2007 12:33 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome