ABS pump problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Feb 23rd, 2013, 8:06 pm Thread Starter
Member
 
medo10's Avatar
 
Join Date: Feb 2010
Location: Chicago, Il., USA
Posts: 47
ABS pump problem

In early October went for 12k service and few days later got dreaded call from service people that ABS unit is leaking by servo pump and will cost over 3k to be replaced. ( it was not leaking before 100% positive on that). I decided to take bike and do it my self. To be short I found unit on ebay for $500 it says for k1200s look the same, my question is it fit for 05LT or I have still to wait. II also contacted module master and they told me to wait couple of months, they may be able to get new gasket for and will give me buz then. Also I want to replace transmission output shaft seal and if anyone can confirm part no; for me, one no i have is 23122330135 and the other 23127705085

2005 K1200LT
2002 r1150gs Just for fun
1997 Heritage Soft tail Resting in Europe
1996 Heritage Soft tail For my Ego days
medo10 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Feb 24th, 2013, 7:17 am
Senior Member
 
Join Date: Nov 2003
Location: Mesa, AZ, USA
Posts: 224
Smile Re: ABS pump problem

Quote:
Originally Posted by medo10
In early October went for 12k service and few days later got dreaded call from service people that ABS unit is leaking by servo pump and will cost over 3k to be replaced. ( it was not leaking before 100% positive on that). I decided to take bike and do it my self. To be short I found unit on ebay for $500 it says for k1200s look the same, my question is it fit for 05LT or I have still to wait. II also contacted module master and they told me to wait couple of months, they may be able to get new gasket for and will give me buz then. Also I want to replace transmission output shaft seal and if anyone can confirm part no; for me, one no i have is 23122330135 and the other 23127705085
I am curious where you are seeing the part numbers. I have a working abs unit from a 2003 that I want to sell and the attached is what I see for numbers. Is the servo pump something different? I probably need to know what I am selling
Lowell
Attached Thumbnails
Click image for larger version

Name:	abs3.jpg
Views:	52
Size:	98.4 KB
ID:	37728   Click image for larger version

Name:	abs.jpg
Views:	65
Size:	185.2 KB
ID:	37729  
lvahl is offline  
post #3 of 7 Old Feb 24th, 2013, 11:34 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,225
Re: ABS pump problem

No the ABS unit will not work - different PNs. Similar but not the same.


If you want the seal where the drive shaft attaches that is the 25x40x6 ...330135 PN the one where the slave goes is ... 705 085.

Just curious how bad is the leak and where? Did it fail the bleed test or did they just see spilled fluid maybe?

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 7 Old Feb 24th, 2013, 11:42 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,225
Re: ABS pump problem

Quote:
Originally Posted by lvahl
I am curious where you are seeing the part numbers. I have a working abs unit from a 2003 that I want to sell and the attached is what I see for numbers. Is the servo pump something different? I probably need to know what I am selling
Lowell
You unit is the entire ABS system and it will work on any late 2001 to 2004 LT. There is a guy in Holland looking for one if the price is right. hstrattus50 is his user name.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #5 of 7 Old Feb 24th, 2013, 11:53 am
Senior Member
 
Join Date: Nov 2003
Location: Mesa, AZ, USA
Posts: 224
Re: ABS pump problem

Quote:
Originally Posted by jzeiler
You unit is the entire ABS system and it will work on any late 2001 to 2004 LT. There is a guy in Holland looking for one if the price is right. hstrattus50 is his user name.
Thanx, I got a PM from him, so I quoted a real good price to him.

Lowell
lvahl is offline  
post #6 of 7 Old Feb 24th, 2013, 4:12 pm Thread Starter
Member
 
medo10's Avatar
 
Join Date: Feb 2010
Location: Chicago, Il., USA
Posts: 47
Re: ABS pump problem

Work is done in dealers shop and start leaking probably when they are doing test. They still charge me a full 12k service price, NOT happy at all.
If anyone have one laying around let me know I'm buyer. also thanks for seal part no,I have to start assembling soon.

2005 K1200LT
2002 r1150gs Just for fun
1997 Heritage Soft tail Resting in Europe
1996 Heritage Soft tail For my Ego days
medo10 is offline  
post #7 of 7 Old Feb 24th, 2013, 4:24 pm Thread Starter
Member
 
medo10's Avatar
 
Join Date: Feb 2010
Location: Chicago, Il., USA
Posts: 47
Re: ABS pump problem

Forgot this. Leak is between the cylinder part on the bottom of unit ( i think that is the one of servo pumps) and body of the unit where is connected too probably some kind of seal or gasket got messed up. It leaked for few days after i got bike back home.

2005 K1200LT
2002 r1150gs Just for fun
1997 Heritage Soft tail Resting in Europe
1996 Heritage Soft tail For my Ego days
medo10 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New to me 2003 K1200LT - ABS problem Jim_McG K1200LT 13 Nov 23rd, 2012 7:13 am
01 ABS Pump on eBay $475 deputy5211 K1200LT 3 Apr 25th, 2012 5:51 pm
fuel pump problem stanleyman RT Series 9 Aug 27th, 2010 11:51 pm
R1200 RT ~ Fuel pump sensor problem mark555 Other R-Bike Discussion 3 Jun 5th, 2009 10:55 am
Computer Problem Response Form Lonewuff Humor 3 Mar 14th, 2008 3:53 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome