BMW Navigator III Question - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Oct 23rd, 2012, 4:03 pm Thread Starter
Senior Member
 
Geoff's Avatar
 
Join Date: Oct 2012
Location: Plainfield, IL, USA
Posts: 102
BMW Navigator III Question

I recently added a Navigator III to my 2009 LT. I bought the GPS used. When I received it I cleared all user data to reset the unit and restore all original settings.

While using the GPS in map view, I noticed the moving position arrow (small triangle) sometimes points the in the wrong direction compared to the direction I'm travelling. The map shown is correct, but the display is nearly 180 degrees off. There's no information on this topic in the manual. Any idea what's wrong?
Geoff is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Oct 23rd, 2012, 4:36 pm
Senior Member
 
Woolly's Avatar
 
Join Date: Jul 2005
Location: , Co. Durham, England
Posts: 1,492
Re: BMW Navigator III Question

Hi Geoff, you can set the display to 'North Up' or 'Direction of Travel Up'. It sounds like you have it set to the former.

Attached Thumbnails
Click image for larger version

Name:	gps.jpg
Views:	285
Size:	81.6 KB
ID:	36906  

  • 2005 LT - 17 countries, 2 CONTINENTS & counting !
  • MB SLK 350 MT
  • 1974 Triumph Bonneville 750

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Woolly; Oct 23rd, 2012 at 4:42 pm.
Woolly is offline  
post #3 of 8 Old Oct 23rd, 2012, 5:11 pm Thread Starter
Senior Member
 
Geoff's Avatar
 
Join Date: Oct 2012
Location: Plainfield, IL, USA
Posts: 102
Re: BMW Navigator III Question

Wolly, thanks for the reply. I will set the orientation to "3D Track Up" since this is the default map view.
Geoff is offline  
 
post #4 of 8 Old Oct 23rd, 2012, 7:26 pm
Junior Member
 
Join Date: Jul 2012
Location: Fredericksburg, VA, USA
Posts: 3
Re: BMW Navigator III Question

I have a 2007 LT with the Navigator III and am also having some problems. I recently purchased the bike and I immediately hooked the gps up to my computer and updated the maps. I didn't have the ac adaptor cord so I had to leave the gps attached to the bike with the key turned on when it was updating through my computer. The Garmin website said the maps were updated successfully. However, when I use the GPS now there is no detail and it frequently just shows the arrow on a white screen with none of the side roads or other topographical features. I have the setting set to the most details as possible but still no details. Should I restore or what? Thanks for your help.
dthicks20 is offline  
post #5 of 8 Old Oct 23rd, 2012, 9:25 pm
Lifetime Supporter
 
johnbaker15's Avatar
 
Join Date: Sep 2010
Location: Chelmsford, Ma, USA
Posts: 1,595
Re: BMW Navigator III Question

Sounds like you lost the base maps during the update, I would reapply the update.

Not sure about Garmin but Magellan has a reset function that will bring it back to the base map. Some Garmin model have a reset function on the back under the serial number label. You might want ot try that reset first.

John Baker

2005 BMW K1200LT
1979 Suzuki GS1000E
1978 Honda CB350
1975 Suzuki GT380

Last edited by johnbaker15; Oct 23rd, 2012 at 9:30 pm.
johnbaker15 is offline  
post #6 of 8 Old Nov 12th, 2012, 1:28 pm
Senior Member
 
bikerj's Avatar
 
Join Date: May 2011
Location: Garland
Posts: 1,079
Re: BMW Navigator III Question

Quote:
Originally Posted by dthicks20
I have a 2007 LT with the Navigator III and am also having some problems. I recently purchased the bike and I immediately hooked the gps up to my computer and updated the maps. I didn't have the ac adaptor cord so I had to leave the gps attached to the bike with the key turned on when it was updating through my computer. The Garmin website said the maps were updated successfully. However, when I use the GPS now there is no detail and it frequently just shows the arrow on a white screen with none of the side roads or other topographical features. I have the setting set to the most details as possible but still no details. Should I restore or what? Thanks for your help.

I recently had this problem after doing a map update with my Garmin Streetpilot 2730. the triangle and highlighted route is displayed, but nothing else. I just learned this model is no longer supported, but Garmin has no problem taking people's money for new maps on these obsolete models.

Jeff
Big D is my neck of the woods

99 K1200LT (don't need loud pipes w/ 8 spk. stereo)
08 HD wide glide
prior:
07 HD XL1200C (sold!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
78 KZ750 twin
76 CB750F
71 CL175 Scrambler
73? Yamaha 100 enduro

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bikerj is offline  
post #7 of 8 Old Nov 12th, 2012, 1:41 pm
Senior Member
 
Join Date: May 2010
Location: Austin, TX, USA
Posts: 616
Re: BMW Navigator III Question

It sounds like you're not seeing the detailed street maps, but just the base map, which has very little detail.

I don't have a Nav III, but on the Nav IV/660, you would do this:

Tools>Settings>Map>MapInfo

then see if you see the CN North America NT 2013.30 map (or something similar). Then see if the little checkbox is checked.

If you don't have a detailed map, or you have it and it is not selected, you will just see major roads.
JimE is offline  
post #8 of 8 Old Nov 12th, 2012, 6:06 pm
Senior Member
 
taylorjn's Avatar
 
Join Date: May 2002
Location: Minneapolis, MN, USA
Posts: 1,391
Re: BMW Navigator III Question

Also, if running the load from a Mac, be sure you have the up-to-date download/ orient/ install. Current version is all in one execute, with three steps.

Jim Taylor
Minneapolis
07 Black LT "Dancing Heart", 03 Quantum "Ice"
02 Black LTC "Raven" (RIP 8/26/06)
08 Can-Am Spyder (hers) (#731)
taylorjn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW Zumo Coming soon... Ted Shred GPS 19 Jul 24th, 2013 12:14 am
Question about BMW Charger BobB Batteries, Chargers, & Electrical 6 Apr 24th, 2008 9:51 am
BMW Boulder Jacket Question bgudmest Rider's Gear & Luggage 1 Jan 15th, 2008 4:33 pm
BMW Battery Charger Question mrkolivers RT Series 6 Dec 27th, 2007 9:34 am
BMW Nav II Cradle Question... BlackBMW GPS 5 Feb 24th, 2007 4:17 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome