Question about resetting nonworking LT radio - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Oct 21st, 2012, 8:23 am Thread Starter
Senior Member
 
Lynn_Keen's Avatar
 
Join Date: Jun 2002
Location: North East Florida, FL, USA
Posts: 2,239
Question about resetting nonworking LT radio

The radio on my '05 LT has required the "disconnect the battery reset" twice now in about 3 or 4 weeks. Wondering what the general experience is with this issue. Is this a sign of impending catastrophic failure or just another one of those exclusive BMW features?

Lynn Keen
North East Florida
MSF #28271 Retired
'99 Canyon Red RETIRED AT 93,000 MI
'05 GRAPHITE METALLIC retired at 87,000 MI
'01 R1150 GS- totaled
'02 R1150 GS sold
'85 K100/EML sidecar sold
'11 R1200RT currently being enjoyed

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lynn_Keen is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Oct 21st, 2012, 9:52 am
Senior Member
 
Woolly's Avatar
 
Join Date: Jul 2005
Location: , Co. Durham, England
Posts: 1,492
Re: Question about resetting nonworking LT radio

Hi Lynn,

Mine did the same a few months back round about the two times when my bike wouldn't start..

I usually keep the bike on a battery tender. Twice, the bike wouldn't start (once at work & once when I forgot to plug the tender in), so I thought time for a new battery (2005 bike, still on original battery - not bad). Put a new battery on, and the radio has been fine ever since.

  • 2005 LT - 17 countries, 2 CONTINENTS & counting !
  • MB SLK 350 MT
  • 1974 Triumph Bonneville 750

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Woolly is offline  
post #3 of 4 Old Oct 23rd, 2012, 10:21 am Thread Starter
Senior Member
 
Lynn_Keen's Avatar
 
Join Date: Jun 2002
Location: North East Florida, FL, USA
Posts: 2,239
Re: Question about resetting nonworking LT radio

Woolly, thanks for sharing your experience. My battery is due for replacement and I was suspicious that it might be related to my radio issue. Your experience supports that suspicion.

Quote:
Originally Posted by Woolly
Hi Lynn,

Mine did the same a few months back round about the two times when my bike wouldn't start..

I usually keep the bike on a battery tender. Twice, the bike wouldn't start (once at work & once when I forgot to plug the tender in), so I thought time for a new battery (2005 bike, still on original battery - not bad). Put a new battery on, and the radio has been fine ever since.

Lynn Keen
North East Florida
MSF #28271 Retired
'99 Canyon Red RETIRED AT 93,000 MI
'05 GRAPHITE METALLIC retired at 87,000 MI
'01 R1150 GS- totaled
'02 R1150 GS sold
'85 K100/EML sidecar sold
'11 R1200RT currently being enjoyed

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lynn_Keen is offline  
 
post #4 of 4 Old Oct 23rd, 2012, 10:39 am
Senior Member
 
kellenbenz's Avatar
 
Join Date: Apr 2002
Location: Tyler, TX, USA
Posts: 2,057
Re: Question about resetting nonworking LT radio

I also noticed that the radio would crash when attempting a start with low voltage. Mine would do it in the winter on cold days with a marginal battery. I also found that when I would be using heated gear and running the grips, using high beam, and seat heat the alternator would not keep a top off charge on short trips.


Ron


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


747,891 miles on touring motorcycles since 1990

IBA 45658 MOA167437

2000 LTC 90,600 miles KIA (new)
2003 LTE 164,188 miles Silver (Purchased with 1687)
2008 R1200RT 176,196 miles (Purchased with 16458)
2017 R1200RT 96,669miles (new)
Total BMW miles 509,508
1982 GL1100 rode 84108 miles (bought with 12012 sold 96120)
1988 GL1500 rode 12067 miles (bought with 19893 totaled 31960)
1989 GL1500 rode 142208 miles (bought with 20302 sold 162510)
Goldwing miles 238,383
kellenbenz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 10:24 am
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 11:12 am
Radio and speaker question 0208 K1200LT 2 Jun 18th, 2008 9:09 pm
Question for MyFi XM Radio users??? Portguyofva Satellite Radio 4 Mar 9th, 2006 8:46 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome