No Power.... - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Aug 5th, 2012, 5:26 am Thread Starter
Member
 
Panman-Chips's Avatar
 
Join Date: Apr 2011
Location: Stockport, Cheshire, United Kingdom
Posts: 55
No Power....

Morning all...

Whilst on my Euro trip back in June I developed an oil and water leak on the housing unit at the front of the block, apparently the both the impeller's are shot causing the gaskets to fail, so having waited nearly 6 weeks to be slotted in for repair I went down to the garage to start her up to take her the few miles to the shop.....

Put the key in and turned and.....nothing !

No dash lights, no clicks and no whirrs !! I've checked the battery terminals for anything loose but all tight there.

I rode her back from the shop around 4 weeks ago, parked her in the garage and all was fine.

I put Optimate on yesterday morning and have just tried the key in her this morning and it's still the same... Nothing at all, no lights on dash.

Any possible solutions Guys ??

Panners
Panman-Chips is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Aug 5th, 2012, 5:53 am
Senior Member
 
Join Date: Feb 2007
Location: Helsinki, Finland, Europe, Northern hemisphere
Posts: 594
Re: No Power....

Battery is toasted, deep dis-charged, dead...

Born to be wild so why not

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
C-A-D is offline  
post #3 of 6 Old Aug 5th, 2012, 6:11 am Thread Starter
Member
 
Panman-Chips's Avatar
 
Join Date: Apr 2011
Location: Stockport, Cheshire, United Kingdom
Posts: 55
Re: No Power....

I do think you may be spot on there....

Found a couple of threads that point to the same direction.... Have just found a local supplier and I'm off to pick it up in an hour !!

Thanks for your quick reply !!

Panman-Chips is offline  
 
post #4 of 6 Old Aug 5th, 2012, 7:28 pm
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
Re: No Power....

Try putting a heavy duty charger on it for an hour or so to see if it will take a charge.

Bob

"He was a foul caricature of himself, a man with no soul, no inner convictions, with the integrity of a hyena, and the style of a poison toad." H. S. Thompson
BecketMa is offline  
post #5 of 6 Old Aug 5th, 2012, 11:59 pm
Senior Member
 
K100Dennis's Avatar
 
Join Date: Jul 2008
Location: Railton, Tasmania, Australia
Posts: 876
Re: No Power....

Yes, I agree, try a normal battery charger, as if the Optimate is the same in function as some other tenders it will not offer a current till it senses some resistance.

Dennis
1987 Yamaha TY250R
1991 Aprilia Climber 280
1988 K100RT (the pack horse)
2005 K1200LTE Light yellow metallic
K100Dennis is offline  
post #6 of 6 Old Aug 6th, 2012, 1:30 pm Thread Starter
Member
 
Panman-Chips's Avatar
 
Join Date: Apr 2011
Location: Stockport, Cheshire, United Kingdom
Posts: 55
Re: No Power....

Thanks Guys....

I figured out what I'd done..... Twas my fault !! Hopefully not the first and even moreso not the last to do it....

Before we went to Europe I asked a freind of mine to install a charger socket under my seat so that I could plug in a mobile phone charger and have the cable run up to the pocket in front of the tape player.... He did just that and I left the phone charger plugged into the socket upon my return. Had it not been for the oil leak I sprung whilst away I doubt it would have affected the bike at all with daily use, so £60 later and 1 brand new battery she purred back to life yesterday for me to take her to the shop to be repaired !!

I did put the trickle charger on her overnight with no luck....I'll try a heavy duty charge at the weekend

One day I learn

Many thanks

Panners
Panman-Chips is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Japan's Nuclear "Disaster" hoog62 Chit Chat 16 Mar 16th, 2011 6:55 pm
Switched power from power outlets - caution pilgrim RT Series 8 Sep 16th, 2010 6:12 am
iWay 500c audio problem was GPS 11 Apr 26th, 2007 8:07 pm
No power at lower Power Outlets MattKas K1200LT 7 Mar 6th, 2007 10:49 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome