Right turn signal not working - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old May 3rd, 2012, 1:25 pm Thread Starter
Junior Member
 
Join Date: Feb 2008
Location: Austin, TX, USA
Posts: 1
Right turn signal not working

Right turn signal not working. The bulbs are ok; work on flashers and on security. So, is this the switch in the right grip or ?
jkermit is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old May 3rd, 2012, 3:13 pm
Senior Member
 
tips727's Avatar
 
Join Date: Sep 2011
Location: Madisonville, KY, USA
Posts: 334
Re: Right turn signal not working

I had that problem with my '00 model soon after I bought it in '05. I assumed it was a bulb burned out but a new bulb didn't fix it. Instead, the problem was that the light socket in the front turn signal was rusted, likely caused by moisture having gotten past the seal. I cleaned up the rust with some emery cloth and it lit right up and was still working great with the old bulb 6 years later when I sold the bike. Maybe you will have an easy fix, too.

Tips


BMW K1200LT - 2005

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tips727 is offline  
post #3 of 6 Old Mar 20th, 2015, 4:52 pm
Junior Member
 
Join Date: Nov 2012
Location: Corvalllis, OR, USA
Posts: 29
Re: Right turn signal not working

My right turn signal also failed. The first time, spraying contact cleaner into/around the switch brought it back for several months. Then it started sporadically failing, eventually total failure. Contact spray didn't help. Emergency flashers work, so it's not the flasher unit or bulbs. The right button won't cancel the left blinker like it should, so I assume it's just not making contact at all.
My questions: Can the switch be cleaned, repaired or replaced without replacing the whole right switchbank ($140 for used unit on BB)? I tried removing the two screws (front one obvious, back one hidden in the second mirror mount hole. I couldn't get the switchbank to pop off--afraid to force it. Are there other screws that need to be removed (i.e., the ones on the bottom plate?)?
If I do replace the switchbank, are there plugs for the harnesses on the handlebar end, or do you have to replace the harness with the switches, which means tearing off a lot of tupperware.
bartman49 is offline  
 
post #4 of 6 Old Mar 20th, 2015, 6:55 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,229
Re: Right turn signal not working

Ok you have half the screws out. There are two on the bottom cover, a chrome one and a black one. Then the switch gear will come off. Thanks to a fellow in Brazil who sourced them, the switches are available from Digi-Key . Here are a few pics from the other side switch gear to show what to look for.
Attached Thumbnails
Click image for larger version

Name:	20140425_114943-2.jpg
Views:	192
Size:	742.7 KB
ID:	76394   Click image for larger version

Name:	20140425_114956-1.jpg
Views:	192
Size:	303.2 KB
ID:	76402   Click image for larger version

Name:	20140425_115000-2 (1).jpg
Views:	195
Size:	944.6 KB
ID:	76410  

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #5 of 6 Old Mar 20th, 2015, 7:16 pm
Junior Member
 
Join Date: Nov 2012
Location: Corvalllis, OR, USA
Posts: 29
Re: Right turn signal not working

Thanks John. Is this a soldering job or do the switches plug in to a receptacle?
bartman49 is offline  
post #6 of 6 Old Mar 21st, 2015, 10:07 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,229
Re: Right turn signal not working

Solder job.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 r1100rt blown turn signal fuse Danrt1100 RT Series 5 Apr 28th, 2012 8:00 am
Turn signal problem 2005RT cnc_dude RT Series 2 Dec 4th, 2010 5:41 pm
right side turn signals not working. sheldan2 K1200LT 15 Jun 11th, 2009 6:16 am
TurnSmart Turn Signal Mirrors Walnetto K1200LT 3 Jun 1st, 2009 9:42 pm
Turn signal light Janitor K1200LT 1 Jun 8th, 2007 7:07 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome