radio problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Feb 15th, 2012, 6:53 pm Thread Starter
Junior Member
 
Join Date: Feb 2012
Location: Hamburg , PA, USA
Posts: 4
radio problem

i just bought a 2002 with the single cd player in where the cassette player was. everything works but it only plays out of the front left speaker.can anyone tell me what i need to replace.
rmpf61 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Feb 15th, 2012, 7:10 pm
Junior Member
 
Join Date: Nov 2011
Location: friendswood, tx, usa
Posts: 9
Re: radio problem

pull your radio out, send it in to Becker Audio in NJ..... they'll fix it.
pinero2 is offline  
post #3 of 8 Old Feb 15th, 2012, 7:58 pm
Lifetime Supporter
 
johnbaker15's Avatar
 
Join Date: Sep 2010
Location: Chelmsford, Ma, USA
Posts: 1,595
Re: radio problem

Last I checked Becker had a flat rate around $400.

John Baker

2005 BMW K1200LT
1979 Suzuki GS1000E
1978 Honda CB350
1975 Suzuki GT380
johnbaker15 is offline  
 
post #4 of 8 Old Feb 16th, 2012, 5:54 am
Senior Member
 
Join Date: Sep 2004
Location: Athens, OH, USA
Posts: 132
Re: radio problem

My 05 is only playing out of the rear speakers. I hate to spend $400 on that problem. I might pull it and see if any local shops can fix the problem.
Painterman is offline  
post #5 of 8 Old Feb 16th, 2012, 2:35 pm
Lifetime Supporter
 
PMitchell's Avatar
 
Join Date: Aug 2006
Location: Hudson, OH, USA
Posts: 2,882
Re: radio problem

Try toggling from left to right. . .

Press (musical note sign) to toggle between Bass, Treble, Fade, Balance, Loudness. Use thumb dial, L or R to adjust setting. If you press and hold (musical note sign) for more than 2 seconds, all parameters will revert to default (midrange) settings

If that doesn't work, disconnect the battery for an hour or so and reconnect. Worked for me!

pm
--
Life is too short to do anything
other than that about which you
are absolutely passionate . . .
Ride till you can't!

"Der Weg ist das Ziel"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 South Africa
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2014 The Dolomites of Italy, Alps of Switzerland & Austria and returning to Milan via the "Gold Coast" of the French Riveria.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2016 Spain & Portugal
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 Central & Eastern Europe: Slovenia, Austria, Poland,Hungary, Czech Republic & Slovakia!

'18 R1200RTW
'00 K1200LTC (Dealer is taking on consignment!)
'90 K75-Sold to a new BMW owner (2016)
'62 R 50/2 (Rode hard and put away wet)-Sold in '81
'63 Vespa 150 (1st and only dirt bike!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sold in '67


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PMitchell is offline  
post #6 of 8 Old Feb 16th, 2012, 3:32 pm
Senior Member
 
amarider's Avatar
 
Join Date: Jul 2002
Location: Brentwood, CA, USA
Posts: 5,849
Re: radio problem

dielectric grease


Pull the stingray off and remove the radio go all the way to plug in at the back of the radio unit. Clean all connections and use dielectric grease on every connection as you reassemble. Then go under the back seat and use it on the connection to the rear speakers.

This has repair both the LT's over the years.

John & Cathy
Northern CA
01 K1200LTC Basalt - Moose


Posse #2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

If you don't know where you're going, you might end up somewhere else
amarider is offline  
post #7 of 8 Old Feb 16th, 2012, 7:45 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,226
Re: radio problem

Quote:
Originally Posted by Painterman
My 05 is only playing out of the rear speakers. I hate to spend $400 on that problem. I might pull it and see if any local shops can fix the problem.
They won't be able to due to the type of IC used for the final amp. It is impossible to replace since it is a ball grid array mounting type. Becker doesn't een replace the IC they just replace the board for $400. Better to go the Jensen Marine radio way unless you are intent on keeping her stock.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #8 of 8 Old Mar 20th, 2012, 3:30 pm Thread Starter
Junior Member
 
Join Date: Feb 2012
Location: Hamburg , PA, USA
Posts: 4
Re: radio problem

Sorry it took so long to get back to it. Took a while to get to the plugs and connectors and just did the same thing. Tried calling Becker the number didn't work. Think I'll just try the Jensen. Any suggestions on the install will be appreciated.
rmpf61 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
Another Radio Problem sh059 K1200LT 1 Jan 16th, 2011 5:22 pm
An 'Other" wierd Radio problem K1200LT-TH K1200LT 5 Oct 14th, 2009 10:24 am
Radio problem erichotdoc Bike Talk 3 Sep 11th, 2009 11:21 pm
radio problem on 1200LTE couleekid Chit Chat 0 Jul 3rd, 2008 11:40 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome