Run poor after battery reconect - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old Feb 6th, 2012, 5:04 pm Thread Starter
Member
 
Join Date: Dec 2008
Location: DUNEDIN, FL, USA
Posts: 39
Run poor after battery reconect

Hey guys

I leave my 2005 LT at various locations around the country for months at a time. I disconnect the battery on my departure, on return the charge is always still up but the bike runs very poorly for a couple hours. I think I recall a procedure that I can go threw involving turning the key on & off & so forth. Does anyone know the fix?
jameshawk is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old Feb 6th, 2012, 5:29 pm
Senior Member
 
Palerider's Avatar
 
Join Date: Aug 2008
Location: Big Piney, Wyoming, USA
Posts: 1,745
Re: Run poor after battery reconect

Turn the key to the on position without starting:
Twist the throttle all the way open 3 times;
Turn the key back to the off position:
Turn the key back to the on position and start normally.........should retrip everything and set the fuel mapping...............



Jim and Cyndy
'03 Black..."Ol' Dollar"
TDMTT
Palerider is offline  
post #3 of 14 Old Feb 6th, 2012, 5:30 pm
Senior Member
 
wa1200lt's Avatar
 
Join Date: Apr 2009
Location: Vancouver, WA, USA
Posts: 2,745
Re: Run poor after battery reconect

Turn key to on position
Do NOT start the engine.
Twist throttle to full on and back to idle
Do the above step two times
Turn key off

Now you can start as usual.

Loren

WAK1200LT
Loren

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cave quid dicis, quando, et cui
wa1200lt is offline  
 
post #4 of 14 Old Feb 6th, 2012, 5:34 pm
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Run poor after battery reconect

Yes it is the TPS reset.
Just after you reconnect the battery.
Turn on the ignition, but don't start the engine,
Then twist the throttle full open and closed twice.
Next turn the key off.
Last start the bike again.

Stevie Shreeve
katnapinn is offline  
post #5 of 14 Old Feb 6th, 2012, 5:36 pm
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Run poor after battery reconect

OK Jim & Loren I guess you two are a lil faster then I.

Stevie Shreeve
katnapinn is offline  
post #6 of 14 Old Feb 6th, 2012, 6:19 pm
Senior Member
 
DMiller's Avatar
 
Join Date: Oct 2005
Location: Riverside, CA, USA
Posts: 225
Re: Run poor after battery reconect

Yep! We all agree.
DMiller is offline  
post #7 of 14 Old Feb 6th, 2012, 6:30 pm
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,897
Re: Run poor after battery reconect

Sometimes the throttle reset doesn't work and you just have to ride for awhile and let it sort it out on it's own.

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
post #8 of 14 Old Feb 6th, 2012, 7:48 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: Run poor after battery reconect

Could be old gas as well. Better to fill it to reduce condensation of moisture but then you have a full tank of old gas. Tough call. Depends on how long it sits. May try a little StaBil in the tank next time.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #9 of 14 Old Feb 6th, 2012, 8:02 pm
Senior Member
 
Palerider's Avatar
 
Join Date: Aug 2008
Location: Big Piney, Wyoming, USA
Posts: 1,745
Re: Run poor after battery reconect

Good point John; and it does bring up the question of the corn liquor fuels..............I've heard stories they break down faster than dinosaur fuel..........Maybe I should do some surfin'.....

But none the less; a good point John......................



Jim and Cyndy
'03 Black..."Ol' Dollar"
TDMTT
Palerider is offline  
post #10 of 14 Old Feb 7th, 2012, 12:53 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: Run poor after battery reconect

Yeah now that I think about it the gas in my LT is about three months old - I need to ride!!!

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #11 of 14 Old Feb 7th, 2012, 2:32 pm
Senior Member
 
Palerider's Avatar
 
Join Date: Aug 2008
Location: Big Piney, Wyoming, USA
Posts: 1,745
Re: Run poor after battery reconect

Roads here are totally iced over......................



Jim and Cyndy
'03 Black..."Ol' Dollar"
TDMTT
Palerider is offline  
post #12 of 14 Old Feb 7th, 2012, 9:16 pm
Senior Member
 
tonygret's Avatar
 
Join Date: May 2008
Location: Thousand Oaks, California, USA
Posts: 407
Re: Run poor after battery reconect

I have replaced my battery twice. Both times I did the throttle twisting thing. It still ran rough for a while but eventually worked itself out both times.
tonygret is offline  
post #13 of 14 Old Feb 8th, 2012, 7:15 am
Senior Member
 
New2rt's Avatar
 
Join Date: Jun 2009
Location: Kingston, PA, USA
Posts: 728
Re: Run poor after battery reconect

FI is equipped with adaptives. When in closed loop the O2sensor reading will sweep above and below a center line. As things change (air filter or fuel filter restriction, etc) the O2 sensor will bump against it's limit it's at that time adaptives will correct (rich or lean) to get the O2 sensor back into it's operating range. There are long term and short term adaptives. You can reset the adaptives to their base settings either through diagnostics or disconnecting the battery. If they are reset without doing anything else (tune up) the adaptives will need to go back to where they were and this will happen with riding. Until they relearn the correction the engine can run a little rough. It's a good practice to reset the adaptives after a major service. Based on the above posts that seems to be what's happening.
New2rt is offline  
post #14 of 14 Old Apr 22nd, 2012, 6:11 pm
Senior Member
 
Join Date: Apr 2012
Location: Brockport , NY, USA
Posts: 228
Re: Run poor after battery reconect

So that's why my bike ran funny for awhile after unhooking the batt.
Great info!
Bones1955 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery question CMV K1200LT 9 Aug 26th, 2010 12:13 am
My battery story. motorman587 K1200LT 3 Nov 26th, 2008 4:19 pm
'05 Lt Battery And Recharging With An Electronic Low Amps Tender ajs K1200LT 2 Apr 9th, 2007 11:11 am
Battery Concern please advise Hulkster Batteries, Chargers, & Electrical 8 Feb 6th, 2006 1:41 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome