No Set or Switch lights for CC - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Mar 16th, 2006, 3:59 pm Thread Starter
 
Join Date: Oct 2003
Posts: 315
No Set or Switch lights for CC

I can't find any info in the HOW about problems associated with Cruise Control not powering-up at all. I have no set light on cluster or red light at the Switch. Any possible points of electrical disconnect other than fuse I should check?
I don't recall what other systems are tied in with CC but I know it's not a fuse. My repair manual is useless.
Macker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Mar 16th, 2006, 5:29 pm Thread Starter
 
Join Date: Oct 2003
Posts: 315
Quote:
Originally Posted by DaveDragon
There is a CC test procedure posted here somewhere.
The procedure involves Ignition Switching, Clutch switch, Brake Switch (Front & Rear) and Throttle as well as the Set and Resume switches.
I'll attempt to find it.

Found it HERE.
O.K., I think I get it.

I saw this...
This is the diagnostic function that uses the light to tell me why the light isn't coming on!?!


I trust you Dave!! I'll try it tonight.
Macker is offline  
post #3 of 3 Old Mar 17th, 2006, 6:40 am
Senior Member
 
Join Date: Apr 2005
Location: , , USA
Posts: 607
I had a similar problem. No light at the CC switch intermittently. It turned out to be the contacts in the switch. A new switch was $$$, so I got the cruise switch to turn on, and I just leave it on. No big deal to me. All cruise functions work (set, cancel, resume).
Tat_n_Telle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Auxiliary Lights hschisler Lighting 55 Nov 29th, 2014 10:00 pm
PIAA 1100X mod - Daytime Running Lights Daza Lighting 7 Jul 10th, 2009 12:11 pm
Hella FF50 Driving Lights installed unleashd Lighting 22 Aug 21st, 2006 2:11 pm
Lights & Ezy Mount Brackets EzyMount Lighting 3 Feb 24th, 2006 5:04 pm
Oops, I let out the magic smoke jkersh1 K1200LT 4 Oct 27th, 2005 8:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome