O' crap I dropped my GPS. :( - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Mar 14th, 2006, 8:26 pm Thread Starter
Senior Member
 
motorman587's Avatar
 
Join Date: Mar 2003
Location: , FL, USA
Posts: 2,910
O' crap I dropped my GPS. :(

I was moving it off my motorcycle to the car. I got distracted and left it on the roof as I drove off. I slung it cross the parking lot. It still works however, there is a small yellow spot, not a solid, and it is getting bigger. Has anybody done this????
motorman587 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Mar 14th, 2006, 9:04 pm
Cat Herder
 
andy's Avatar
 
Join Date: Apr 2002
Location: Houston, TX, USA
Posts: 5,852
Quote:
Originally Posted by motorman587
I was moving it off my motorcycle to the car. I got distracted and left it on the roof as I drove off. I slung it cross the parking lot. It still works however, there is a small yellow spot, not a solid, and it is getting bigger. Has anybody done this????
Sounds like a broken LCD display. You will be able to use it for a while until the spot gets too big, then repair or replacement will be needed.
andy is offline  
post #3 of 5 Old Mar 14th, 2006, 9:29 pm
Senior Member
 
OKUIII's Avatar
 
Join Date: Oct 2002
Location: Irvine, California,
Posts: 565
I had my center dtand break at the weld crossbar and the bike went over to the right and came to rest on the windscreen against my workbench,. All is well now, replaced windscren adjuster, center stand, windsheild and only need the right rear speaker housing. I checked my GPS and it worked with bike power......checked it in the car and worked with the cigarette lighter power.........checked it on brand new charged batteries and it will not turn on.....

Its a SPIII and I love it. Sent to Garmin and it is going to cost @225 for a tune-up! Jason told me that they would fix the batter power-on and make sure all systems are current revisions. WoW....

O. K. Upchurch III
Irvine, California

2016 R1200gs
2000 K1200LT (Best Bike #1)
1997 R1100RT (Best Bike #2)
1995 K1100LT
1990 K75RT
OKUIII is offline  
 
post #4 of 5 Old Mar 14th, 2006, 9:30 pm Thread Starter
Senior Member
 
motorman587's Avatar
 
Join Date: Mar 2003
Location: , FL, USA
Posts: 2,910
Thanks, that is what I was thinging too. Sounds $$$$
motorman587 is offline  
post #5 of 5 Old Mar 14th, 2006, 10:10 pm
Cat Herder
 
andy's Avatar
 
Join Date: Apr 2002
Location: Houston, TX, USA
Posts: 5,852
Quote:
Originally Posted by motorman587
Thanks, that is what I was thinging too. Sounds $$$$
Sorry that I can't give you better news. It would have been a slight chance that you have "just" an electrical problem, but the fact that you said the spot is getting bigger tells me pretty much that the LCD is broken.
andy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Garmin GPS Question KYchris02 GPS 9 Mar 3rd, 2006 12:56 pm
GPS purchase--newbie! rattso GPS 1 Dec 29th, 2005 2:49 pm
GPS Rookie Question KYLT05 GPS 14 Dec 6th, 2005 9:13 am
GPS Speed accuracy Triker GPS 4 Oct 25th, 2005 1:18 pm
VoiceII GPS audio in: Help please hammick Intercom, CB, & 2-Way Radios 2 Oct 24th, 2005 8:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome