Speedo question (not the swim suit) - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 16 Old Oct 13th, 2011, 8:11 am Thread Starter
Member
 
Join Date: Mar 2011
Location: Forney, TX, USA
Posts: 63
Speedo question (not the swim suit)

I am a happy owner of an 06 LT. I check my speed often.... the GPS (garmin) sez one thing, the speedometer sez another and the digital one on the computer sez something else. between the three there is a 5-6 mph spread.

Comments? don't tell me to average, I hate math.

Keith Barrow
Forney, TX
2006 K 1200 LT (My Fav)
2004 HD FLSTC Scremin Eagle Stage 4
2008 Honda TR 230
2002 I/O go-fast boat
2008 Yamaha Waverunner
Keithkmb is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old Oct 13th, 2011, 8:58 am
Member
 
Join Date: Jun 2006
Location: Olathe, Kansas, USA
Posts: 52
Re: Speedo question (not the swim suit)

You don't need to average. Your GPS is probably accurate, and the LT has a pretty well-known speedo error of up to 10%. The odometer is off, too. The threads listed at the bottom of this page should be good reading, and there are articles in the FAQ and HOW (in the Technical Forum) about the error and what can be done about it. I followed the instructions and corrected the error on my 2001. On my next one, I may not bother.
bgerrity is offline  
post #3 of 16 Old Oct 13th, 2011, 9:05 am
cwo
Senior Member
 
cwo's Avatar
 
Join Date: Nov 2009
Location: Baldwin City, KS, USA
Posts: 374
Re: Speedo question (not the swim suit)

I use the GPS. Had a cop do a radar check at 55mph, and the GPS was right on. The speedo read 60.

05 LT

Chris Ogle

Life is ephemeral. Don't waste it lookin up big words.
cwo is offline  
 
post #4 of 16 Old Oct 13th, 2011, 9:42 am
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
Re: Speedo question (not the swim suit)

Once upon a time, BMW decided that the only customers who needed accurate speedos were police. All other customers "needed" speedos that read around 10% higher than actual speed.

But, one day, an LT owner discovered that the speedos for police and everyone else were identical except for a jumper wire between two pads on a pc board.

It seemed that customers, for some strange reason, wanted accurate speedos.

Of course, if you called BMW NA and complained about the speedo on your brand new motorcycle being inaccurate, Big Brother was silent.

When modified the LT speedo is accurate.

The odometer is accurate.

I didn't pay attention to what BMW did with the speedos when they changed the dash board.

Bob

"He was a foul caricature of himself, a man with no soul, no inner convictions, with the integrity of a hyena, and the style of a poison toad." H. S. Thompson

Last edited by BecketMa; Oct 13th, 2011 at 9:50 am.
BecketMa is offline  
post #5 of 16 Old Oct 13th, 2011, 10:32 am
Senior Member
 
DMiller's Avatar
 
Join Date: Oct 2005
Location: Riverside, CA, USA
Posts: 225
Re: Speedo question (not the swim suit)

For all the hassle of getting to the circuit board I too have done nothing, and when I want to check my speed I look at my GPS. Maybe, when I've got too much time and energy I'll take it apart and fix it....not! ya gotta love it ;-)
DMiller is offline  
post #6 of 16 Old Oct 13th, 2011, 11:07 am
Senior Member
 
Kra961's Avatar
 
Join Date: Jun 2009
Location: University Place, WA, USA
Posts: 656
Re: Speedo question (not the swim suit)

LOL I stopped worrying about it awhile back seems that no matter what I do its never the speed limit.
Can't drive 55

The supreme irony of life is that hardly anyone gets out of it alive.

09 K1200 LT
Project LT:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Future plans
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


University Place, WA
Riding since 1969
Kra961 is offline  
post #7 of 16 Old Oct 13th, 2011, 12:33 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,134
Re: Speedo question (not the swim suit)

The only way to fix the 05 and up is to pull the pointer off and replace it so it then reads correctly. The instant read on the digital dash is very accurate following a reset, then it goes into an average mode. The analog speedo has tick marks that are 3.333 mph. Who thunk that one up?
I just use my GPS.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #8 of 16 Old Oct 13th, 2011, 1:09 pm
Senior Member
 
Boatzo's Avatar
 
Join Date: Jun 2010
Location: Hartfield, VA, USA
Posts: 1,105
Re: Speedo question (not the swim suit)

Been lazy here too and never corrected the jumpers. I use the GPS.

Bill
Eastern Virginia (Middle Peninsula)
K3ZXV
05 Honda Sabre 1100
04 Triumph Speedmaster , Black with
California Sidecar Friendship II
99 K1200LT, Basalt Gray "DELILAH" (SOLD)
99 R1100RT ,Glacier Green (SOLD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
Boatzo is offline  
post #9 of 16 Old Oct 13th, 2011, 1:22 pm
Senior Member
 
wa1200lt's Avatar
 
Join Date: Apr 2009
Location: Vancouver, WA, USA
Posts: 2,745
Re: Speedo question (not the swim suit)

You see! once again the old ones reign .......superior? I fixed my '01 and it is spot on with the GPS. I find it satisfying to know how fast I'm going so that I can know how hard to pucker up when I pass LEO.

Truthfully though it really is nice to have an accurate speed displayed.

Bob, great story! Did anyone live happily ever after?

John, is the shaft on the speedo indicator as fragile as the shaft on the fuel gauge? If so then I would definitely leave it alone. $$$$$$$$$$

Loren

Quote:
Originally Posted by jzeiler
The only way to fix the 05 and up is to pull the pointer off and replace it so it then reads correctly. The instant read on the digital dash is very accurate following a reset, then it goes into an average mode. The analog speedo has tick marks that are 3.333 mph. Who thunk that one up?
I just use my GPS.

WAK1200LT
Loren

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cave quid dicis, quando, et cui
wa1200lt is offline  
post #10 of 16 Old Oct 13th, 2011, 3:32 pm
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
Re: Speedo question (not the swim suit)

After the "White Knight" told us how to slay the dragon, only those who could solder on pads made for surface mount technology rid their kingdoms of the 110% dragons.

Bob

"He was a foul caricature of himself, a man with no soul, no inner convictions, with the integrity of a hyena, and the style of a poison toad." H. S. Thompson
BecketMa is offline  
post #11 of 16 Old Oct 13th, 2011, 7:21 pm
Member
 
Join Date: Oct 2011
Location: Sturgis, MI,
Posts: 36
Re: Speedo question (not the swim suit)

Quote:
Originally Posted by jzeiler
The only way to fix the 05 and up is to pull the pointer off and replace it so it then reads correctly. The instant read on the digital dash is very accurate following a reset, then it goes into an average mode. The analog speedo has tick marks that are 3.333 mph. Who thunk that one up?
I just use my GPS.
So on my 09 I cant just solder the jumpers? I was going to do that this winter. I did not know they removed the jumpers after 05.
oosel is offline  
post #12 of 16 Old Oct 13th, 2011, 9:04 pm
Lifetime Supporter
 
Patric's Avatar
 
Join Date: Feb 2004
Location: Zephyrhills, Florida USA
Posts: 1,424
Re: Speedo question (not the swim suit)

I don't know if it works on the newer bikes , but if you get to a steady speed on the older bikes. You can put the computer on MPH then hit the reset. It will tell you exactly how fast you are going.

Patric Blackman
2002 K1200LT/Hannigan2+2
2010 R1200GSA ...1987 Helix...
AMA Charter Lifemember
37 Year Member of both BMWMOA & BMWRA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Patric is offline  
post #13 of 16 Old Oct 13th, 2011, 10:21 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,134
Re: Speedo question (not the swim suit)

Quote:
Originally Posted by oosel
So on my 09 I cant just solder the jumpers? I was going to do that this winter. I did not know they removed the jumpers after 05.
Totally different design on the board. 1. is old board on the back of the speedo itself.
2 & 3 are the entire integrated dash on the 05 and up. Quite a difference.
Attached Thumbnails
Click image for larger version

Name:	solder points.JPG
Views:	47
Size:	60.2 KB
ID:	33223   Click image for larger version

Name:	inst_front_full_85.jpg
Views:	39
Size:	85.0 KB
ID:	33224   Click image for larger version

Name:	inst_rear_full_85.jpg
Views:	39
Size:	571.3 KB
ID:	33225  

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #14 of 16 Old Oct 13th, 2011, 10:24 pm
Senior Member
 
tconnell's Avatar
 
Join Date: Oct 2010
Location: Valdosta, GA, USA
Posts: 509
Re: Speedo question (not the swim suit)

Find the post on the 'Spedo Fix' probably below somewhere.

You'll have to remove the most of the Tupperware to get to where you need to get and that starts with each top side first and work your way in. Best to remove top and bottom of handlebar covers and loosen the handlebars and lay a towel on the tank under them. This way you won't scratch the dash and related parts then they come off. You'll have to get to and remove the instrument panel, and I'd suggest taking a good clear digital pic of the rear of the dash so you can get the 17 (I think it was) lights back in their sockets and all the wires attached to the correct places. A Clymers Manual will help here also. On you digital pic. Set camera to Close Up or Macro mode. I'd suggest, if you know how, reduce flash by about 2/3 stop as you'll be in close and be sure you are at a slight angle to the rear of the instrument panel when you shoot so you'll not get glare on the shot. You'll probably need this pic later.

Read the article and you jumper a couple of places using something like #20 wire across the two places. Use a very small soldering iron to do that. Don't let it be a cold joint and don't burn it up.

Did all that to my '99 LT right after getting it and it's spot on at 70 and 80. I had a couple of burnt out dash lights and had found the temp sensor and a good used On Board Computer so installed all that in one go.

Good luck

Tommy
77 years old and gittin' younger
__________________________________________________ __
'07 K1200LT Black w/color matched Hannigan Europa II Trailer
'09 KLR650 heavily modified for the TAT


IBA #48786
MOA #164466



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tconnell is offline  
post #15 of 16 Old Oct 13th, 2011, 10:26 pm
Senior Member
 
tconnell's Avatar
 
Join Date: Oct 2010
Location: Valdosta, GA, USA
Posts: 509
Re: Speedo question (not the swim suit)

Sorry - didn't note your bike was an '06. Just disregard my above post

Tommy
77 years old and gittin' younger
__________________________________________________ __
'07 K1200LT Black w/color matched Hannigan Europa II Trailer
'09 KLR650 heavily modified for the TAT


IBA #48786
MOA #164466



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tconnell is offline  
post #16 of 16 Old Oct 14th, 2011, 6:56 am
Member
 
Beemerick's Avatar
 
Join Date: Jun 2011
Location: Hughesville, MD, USA
Posts: 84
Re: Speedo question (not the swim suit)

FWIW, I mounted a $20 Sigma bicycle computer on my LT. It was easy to mount with NO mods to the bike, it's calibratable to the millimeter and works great (except at night...it's has no lights).

Rick
<><

2000 K1200LT
1977 R75/7
2004 R1150RT (sold)
Beemerick is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just Bought a New RT. Speedo Question. 150flyer RT Series 18 Apr 18th, 2011 3:52 pm
Speedometer Question BUGKILLER K1200LT 15 Jun 22nd, 2007 4:13 pm
Speedo inop 02' k1200 bustedknuckles K1200LT 2 Jan 21st, 2007 12:19 pm
speedo correction for older RT retiredjj RT Series 0 Sep 13th, 2006 9:18 pm
Speedo Error Correction for '06 LTs CriticalMass K1200LT 14 Nov 27th, 2005 9:43 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome