Headlight again:-( - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Sep 8th, 2011, 4:26 pm Thread Starter
Cooler on the east coast!!!
 
gglove's Avatar
 
Join Date: Oct 2007
Location: Mount Pleasant South Carolina
Posts: 1,239
Headlight again:-(

Well I am looking for some advice once again. The low and high beam are not working once again. I thought I had the problem solved when I check the ground wires on the clip for the high beam. Well the high beam indicator light came on again tuesday on the way home from work. I replaced the low and high beam bulbs and checked the connections as well as the ground wires on the high beam clip and all seems good. Is it time to give in and take it to the dealer? Any help is much appreciated.
Thanks

G-Glove
2003 Silver LTC
gglove is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Sep 8th, 2011, 5:22 pm
Senior Member
 
JPSpen's Avatar
 
Join Date: Jul 2005
Location: Jones, OK, USA
Posts: 3,525
Re: Headlight again:-(

Didja check the fuse ?

Troubleshooting that circuit should be pretty straightforward unless you've got some strange wiring going on...With neither working I'd be double checking that ground wire...Both ends..

John

Live and direct from the new earthquake capitol of the U.S. Jones, Oklahoma
08 Can-Am Spyder (Miss Lindy's)
03 R1200CLC Capri Blue "Flipper"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 R1100RT Glacier Blue "Lucky"
91 R100GS "It'sNotAMoneyPit"
The voices in my head may not be real, But they have some good ideas!


"I like the wind in my face and Boobies on my back. No, Wait, I got that backwards"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JPSpen is offline  
post #3 of 3 Old Sep 8th, 2011, 8:34 pm Thread Starter
Cooler on the east coast!!!
 
gglove's Avatar
 
Join Date: Oct 2007
Location: Mount Pleasant South Carolina
Posts: 1,239
Re: Headlight again:-(

Quote:
Originally Posted by JPSpen
Didja check the fuse ?

Troubleshooting that circuit should be pretty straightforward unless you've got some strange wiring going on...With neither working I'd be double checking that ground wire...Both ends..

John
John thanks I will try and follow it to check the other end. I am hoping I can figure it out or I am going to be taking it up the other end from the dealer

G-Glove
2003 Silver LTC
gglove is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
headlight question itspossible K1200LT 11 Dec 2nd, 2011 12:44 pm
Headlight protector falls off. biggums RT Series 5 Sep 25th, 2009 10:11 pm
Xenon headlight available on RT bikes? bmwbuyer RT Series 4 Nov 8th, 2008 3:54 pm
Adjusting Headlight Preload on '08 RT w/ESA BCVBeck RT Series 2 Sep 2nd, 2008 9:49 pm
Anybody break a headlight from a rock? TimVipond K1200LT 11 Oct 1st, 2006 5:40 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome