Blowing fuse - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Aug 22nd, 2011, 3:51 pm Thread Starter
Member
 
kgt1200's Avatar
 
Join Date: May 2009
Location: Waynesboro, Mississippi, USA
Posts: 38
Blowing fuse

Last week I noticed my horn (STEBEL) stopped working on my 2006 K1200LT. This weekend I noticed my brake light does not work either. They are on the same fuse along with the central locking system and the alarm system. I have never used either of these two. Each time I put in a new fuse it blow it.
Anyone have any clues as to what may be causing this? 15 Amp fuse. .

2006 K LT1200 Ridin'
2007 K GT1200 Sold
2005 ST 1100 Sold
1985 V65 1000 Magna Sold
1973 CB 750 4 Sold
1966 305 SuperHawk Sold
kgt1200 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Aug 22nd, 2011, 3:55 pm
Senior Member
 
zippy_gg's Avatar
 
Join Date: Jun 2004
Location: Kennesaw, GA, USA
Posts: 8,110
Re: Blowing fuse

15A fuse is good enough. Don't try a "bigger" fuse or you will have smoke and some burnt wire.
Your fuse is blowing most likely because there is a short somewhere. Check your wires and see when there would be rubbing.
Try disconnecting your horn, put a good fuse in and see if your brake light works. That would indicate something wrong with the Stebel wiring.
On top of the Stebel check if the + side may be touching the frame, or anything grounded.

Gilles & Kathy
BMWMOA# 154719
IBA# 71594
2011 Ostra Gray RT
06 Mercedes-Benz E350 Estate (parts and people hauler)
2012 BMW X3 (parts and people hauler)
86 Porsche 911 Cabriolet (my "new" baby)



For her I climbed the highest mountain!
For her I swam across the deepest ocean!
For her I walked through the largest desert!
And then she left me... She said I was never home!!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by zippy_gg; Aug 22nd, 2011 at 6:35 pm.
zippy_gg is offline  
post #3 of 5 Old Aug 22nd, 2011, 5:16 pm Thread Starter
Member
 
kgt1200's Avatar
 
Join Date: May 2009
Location: Waynesboro, Mississippi, USA
Posts: 38
Re: Blowing fuse

Thanks. I will try that tonight.

2006 K LT1200 Ridin'
2007 K GT1200 Sold
2005 ST 1100 Sold
1985 V65 1000 Magna Sold
1973 CB 750 4 Sold
1966 305 SuperHawk Sold
kgt1200 is offline  
 
post #4 of 5 Old Aug 22nd, 2011, 7:16 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,128
Re: Blowing fuse

Quote:
Originally Posted by zippy_gg
Don't try a "bigger" fuse or you will have smoke and some burnt wire.
Actually that is the quickest way to find the problem just put a paper clip in the fuse holer and watch for "smoke". Find the smoke - find the problem!!

Just kidding. But I too would look at the horn installation and look at the relay for shorts. They did use a relay on the horn? If not that could be the cause as the Stiebel horn draws too much current for the normal horn wire and would likely melt it.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #5 of 5 Old Aug 27th, 2011, 10:48 am Thread Starter
Member
 
kgt1200's Avatar
 
Join Date: May 2009
Location: Waynesboro, Mississippi, USA
Posts: 38
Re: Blowing fuse

Can you say "DUH"? My bad. My horn is not a Stebel after all. It looks to be a Bosch. I guess that is the stock horn. I was not aware of the loud horn on a 2006 LT. When it worked it sure sounded like a Stebel. My question now is how to disconnect the horn? If I can get it disconnected and put in a fuse and it does not blow, I will know it is the horn or horn wiring causing the problem. I can feel the wires going into the horn. I am reluctant to pull them. Do you twist and pull or do they unplug straight out or what? Maybe they don't plug at all. Can anyone tell me how to disconnect the horn?

2006 K LT1200 Ridin'
2007 K GT1200 Sold
2005 ST 1100 Sold
1985 V65 1000 Magna Sold
1973 CB 750 4 Sold
1966 305 SuperHawk Sold
kgt1200 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Alarm fuse F3 keeps blowing sparky_k1200lt Batteries, Chargers, & Electrical 3 May 6th, 2013 7:44 pm
Keep blowing a fuse from Hyperlites sydvicioustx K1200LT 2 Jul 16th, 2008 4:03 pm
My 2005 Lt blowing fuse after reconnected battery n2taq K1200LT 3 Apr 23rd, 2008 4:39 pm
Fuel pump fuse blown RealWing K1200LT 9 Nov 24th, 2007 8:37 am
Centech AP-1 fuse panel and relay kit installed wcarter Batteries, Chargers, & Electrical 0 Feb 18th, 2007 4:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome