Front brakes pulsing...why????? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Aug 17th, 2011, 10:00 pm Thread Starter
Junior Member
 
peair's Avatar
 
Join Date: Dec 2010
Location: sudbury, ontario, canada
Posts: 9
Unhappy Front brakes pulsing...why?????

My 2000K1200LT has ABS, but the front brakes pulse a lot when used. The rotors were checked and deemed OK by a mechanic using a dial gauge. The tires up front were badly cupped so I changed out both tires. The same mechanic took off the pads and examined them. They appeared good for wear and even thickness. The rear brakes work good and have no pulsing. The front is so bad that the brake lever moves about 1/2 inch back and forth during braking. Any answers or ideas?????
peair is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No front brakes - weird... ClaytonB K1200LT 18 Jun 2nd, 2010 5:17 pm
Bleeding brakes K1200LT Caveno K1200LT 7 May 5th, 2008 2:40 pm
02 Front Brakes Grabbing / Pulsing vipergman2 K1200LT 6 Aug 16th, 2006 6:30 pm
Front Brakes BMWeasyrider K1200LT 9 Apr 26th, 2006 9:58 am
Rear brake squeal linked to front brakes? Vince_nj1 K1200LT 19 Apr 2nd, 2006 10:37 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome