Rear Speakers - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Oct 5th, 2005, 5:18 pm Thread Starter
Junior Member
 
Join Date: Sep 2004
Location: Dublin, , Ireland
Posts: 2
Rear Speakers

Hi All,

Am now the proud owner of a '02 K12 lt. We (Carol) and me really love the ride and comfort. I have noticed the rear speakers are very low in volume and the right side is a bit distorted in the sound. I have tried all the usual easy things, like fade etc., but to no avail. Any suggestions?

Bren
Bren is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Oct 5th, 2005, 5:45 pm
 
Join Date: Feb 2004
Posts: 4,905
Either you have a case of some connectors getting corroded . . . or your amp is starting to bite the dust. The connectors are located under the left side of the radio's stingray, and you best take care of the one at the rear of the amp while you're in there. Take them all apart and apply some dielectric grease to them all. (RadioShack carries it) Good stuff Maynard. Also adds some zing to a good, thick Reuban...but that's for another forum. If that doesn't do the trick, you might be looking at replacing the amp.
Here's to hoping it's just corrision.
messenger13 is offline  
post #3 of 3 Old Oct 5th, 2005, 8:20 pm
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
I was skeptical about greasing any electrical connector. But, since many mentioned using it, I tried it after my rear speakers went out, and I started hearing distortion in the remaining front speakers.

I pulled all the electrical connectors apart in the radio's wiring harness, shot them with a cleaner, ProGold, greased them up with contact grease from Auto Zone.

It solved the problem which hasn't resurfaced again.

Bob
BecketMa is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear brake issues kamike K1200LT 29 Sep 16th, 2014 9:26 pm
Rear Wheel Drive Good Arthur K1200LT 7 Nov 1st, 2013 12:44 pm
Rear or Final Drive Failure fitzy79 Australia, New Zealand, and AsiaPac 33 Jan 3rd, 2012 8:25 pm
Fixed rear PTT neodoc K1200LT 4 Nov 28th, 2005 4:18 pm
Rear Tire Rubbing... LJSMITH1 Tires 7 Nov 9th, 2005 6:26 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome