2006 LT Horn Relay - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Apr 10th, 2011, 11:50 am Thread Starter
Senior Member
 
roadking04's Avatar
 
Join Date: Jun 2006
Location: Baton Rouge, Louisiana, USA
Posts: 253
2006 LT Horn Relay

Horn not working on my 2006 LT. Fuses are good on same fuse as alarm. can anyone tell me horn relay is located?

Tim
roadking04 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Apr 10th, 2011, 12:18 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,438
Re: 2006 LT Horn Relay

Quote:
Originally Posted by roadking04
Horn not working on my 2006 LT. Fuses are good on same fuse as alarm. can anyone tell me horn relay is located?

Tim
Don't know if ole Toad's (a '99) is same as '06, butt if so, it's in the electronics box under the fuel tank and shares the same duplex house as the air filter box. Slight pita and would be nice if you had other service to do near there!! Good luck.

BTW - IF you go in and the locations and sorting are the same as on a '99, the horn relay is on the outside row, second from left.
Dick is offline  
post #3 of 6 Old Apr 10th, 2011, 2:34 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,647
Re: 2006 LT Horn Relay

These relays are not known to fail. I would check the ground on the horn if fuse F12 is good.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 114 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 6 Old Sep 24th, 2011, 6:50 am
Junior Member
 
Join Date: Sep 2011
Location: gahanna, OH, USA
Posts: 4
Re: 2006 LT Horn Relay

I have perhaps a unique problem.on 2000 K1200T

Battery was dead, jumped it off a car that was running.... I know NOW that is not the best thing to do.

Here is the issue, it started on the jump. I turned it off and now it won't start at all, BUT the horn is on continually. I unplugged both horns and still no start.

I talked to the local dealer / techs and they suggested I replace the horn relay. The question now is which one of the under tank relays operates the horn.

And next how do I fix the no start.
I have read all about the stuck starter relay, but that is where the starter is running all the time. Mine starter won't do anything.

Help - I want ride!!
moneyseeds is offline  
post #5 of 6 Old Sep 24th, 2011, 11:32 am
Lifetime Supporter
 
zippy_gg's Avatar
 
Join Date: Jun 2004
Location: Kennesaw, GA, USA
Posts: 8,136
Re: 2006 LT Horn Relay

Quote:
Originally Posted by moneyseeds
I have perhaps a unique problem.on 2000 K1200T

Battery was dead, jumped it off a car that was running.... I know NOW that is not the best thing to do.

Here is the issue, it started on the jump. I turned it off and now it won't start at all, BUT the horn is on continually. I unplugged both horns and still no start.

I talked to the local dealer / techs and they suggested I replace the horn relay. The question now is which one of the under tank relays operates the horn.

And next how do I fix the no start.
I have read all about the stuck starter relay, but that is where the starter is running all the time. Mine starter won't do anything.

Help - I want ride!!
The first step I would take is to disconnect the battery and leave it off for a good hour before reconnecting. The electronics are sensitive to current drops and some may need to be reset.
How did you jump start the bike? Did you connect the cables directly to your battery terminals or did you just connect to the positive and use the frame as negative (Ground)?

Gilles & Kathy
BMWMOA# 154719
IBA# 71594
2011 Ostra Gray RT
06 Mercedes-Benz E350 Estate (parts and people hauler)
2012 BMW X3 (parts and people hauler)
86 Porsche 911 Cabriolet (my "new" baby)



For her I climbed the highest mountain!
For her I swam across the deepest ocean!
For her I walked through the largest desert!
And then she left me... She said I was never home!!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zippy_gg is offline  
post #6 of 6 Old Sep 26th, 2011, 2:30 pm
Junior Member
 
Join Date: Sep 2011
Location: gahanna, OH, USA
Posts: 4
Re: 2006 LT Horn Relay

When I jumped the bike, I connected both leads from the car directly to the bike battery.
moneyseeds is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring info needed for the redesigned starter relay. zuchero K1200LT 27 Jun 26th, 2016 8:00 am
My new stebel horn isn't working Bobnoxous Batteries, Chargers, & Electrical 9 Aug 29th, 2009 6:52 am
Help with switch idea jarhead354 K1200LT 13 Feb 27th, 2009 11:18 am
Stebel Nautilus Compact installation Randy K1200/1300GT (The Next Generation) 11 Aug 5th, 2008 8:01 am
Oops, I let out the magic smoke jkersh1 K1200LT 4 Oct 27th, 2005 8:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome