a slight smell of antifreeze - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old Feb 6th, 2011, 8:23 am Thread Starter
Senior Member
 
bobst2's Avatar
 
Join Date: Aug 2010
Location: surrey, british columbia, canada
Posts: 473
a slight smell of antifreeze

did winter service a while back finaly got nice enought to ride her. when i took her out for a ride i get a slight antifreeze odor when i take off from a red light. seems to be from the left side. dose not seem to be leaking.
other than not getting the cap on correctly when i changed antifreeze.(nasty piece of buissness with tank on) any other suggestions
bobst2 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old Feb 6th, 2011, 8:25 am
Senior Member
 
mwnahas's Avatar
 
Join Date: Dec 2004
Location: Bedford Hts, OH, USA
Posts: 4,217
Re: a slight smell of antifreeze

did you spill some? is the cap on right now? what is the level in the overflow reservoir?

Just Go
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mike
Cleveland Ohio
2014 K1600 GTL Grey Wolf.
mwnahas is offline  
post #3 of 10 Old Feb 6th, 2011, 8:34 am Thread Starter
Senior Member
 
bobst2's Avatar
 
Join Date: Aug 2010
Location: surrey, british columbia, canada
Posts: 473
Re: a slight smell of antifreeze

i did spill some but have ran the bike in the shed a bit . first time fan cycled it steamed out a while. some may have got on the engine but i have run the bike several times.residual should be gone i think. i am gonn try to take the cap off later today for inspection.level seems normal
bobst2 is offline  
 
post #4 of 10 Old Feb 6th, 2011, 8:37 am
Senior Member
 
Boatzo's Avatar
 
Join Date: Jun 2010
Location: Hartfield, VA, USA
Posts: 1,105
Re: a slight smell of antifreeze

What Michael said.

And, I spilled some and the engine smoked and smelled when I first fired it up. After it burned off everything was OK. I too, did not remove the tank, that was why I spilled some.

Bill
Eastern Virginia (Middle Peninsula)
K3ZXV
05 Honda Sabre 1100
04 Triumph Speedmaster , Black with
California Sidecar Friendship II
99 K1200LT, Basalt Gray "DELILAH" (SOLD)
99 R1100RT ,Glacier Green (SOLD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
Boatzo is offline  
post #5 of 10 Old Feb 6th, 2011, 8:42 am Thread Starter
Senior Member
 
bobst2's Avatar
 
Join Date: Aug 2010
Location: surrey, british columbia, canada
Posts: 473
Re: a slight smell of antifreeze

just checked level in sight glass. it is a little below max line when cold
bobst2 is offline  
post #6 of 10 Old Feb 6th, 2011, 8:46 am Thread Starter
Senior Member
 
bobst2's Avatar
 
Join Date: Aug 2010
Location: surrey, british columbia, canada
Posts: 473
Re: a slight smell of antifreeze

yes my fuel tank was on it was very difficult to r&r the cap. that is what is making me think the cap may not be on correctly
bobst2 is offline  
post #7 of 10 Old Feb 6th, 2011, 9:11 am
Enjoy The Ride
 
saddleman's Avatar
 
Join Date: Sep 2008
Location: Huntersville, NC, USA
Posts: 3,879
Re: a slight smell of antifreeze

I spilled a little the last time I changed my anti-freeze & it took several days of riding for the smell to go away.

Dave Selvig
2004 Black LT
2000 Canon Red LT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
saddleman is offline  
post #8 of 10 Old Feb 6th, 2011, 9:17 am
Senior Member
 
AlaskaFish's Avatar
 
Join Date: Apr 2002
Location: Hillsboro, OR, USA
Posts: 3,136
Cool Re: a slight smell of antifreeze

Bob, you may just have a case of expansion and overflow from the expansion tank. I have had similar smells in warm weather after doing a coolant flush and fill.

John
Quote:
Originally Posted by bobst2
just checked level in sight glass. it is a little below max line when cold

John & Marilyn Fisher
'00 K1200LTC "Katie"
'95 Triumph "Tigger"
'12 Triumph 800XC "Tigger II" (RIP)
'12 Triumph 1200 Explorer "Shadow Tigger"
Hillsboro, Oregon

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AlaskaFish is offline  
post #9 of 10 Old Feb 6th, 2011, 4:11 pm
Senior Member
 
Join Date: Sep 2009
Location: Greensburg, pa,
Posts: 254
Re: a slight smell of antifreeze

also check the condition of the radiator cap, over time the rubber does wear out
edmann is offline  
post #10 of 10 Old Feb 9th, 2011, 11:28 pm
Senior Member
 
wa1200lt's Avatar
 
Join Date: Apr 2009
Location: Vancouver, WA, USA
Posts: 2,745
Re: a slight smell of antifreeze

When I changed the antifreze in mine I got the bit o honey smell for the first few rides and then it went away

Loren

WAK1200LT
Loren

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cave quid dicis, quando, et cui
wa1200lt is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Smell from '99 LT oxbowfarm38 K1200LT 9 Mar 22nd, 2010 4:18 am
AntiFreeze (all over again) CharlieVT K1200LT 2 Jan 6th, 2008 4:20 pm
K1200RS Fuel Smell? old1951 Other K-Bikes Discussion 1 Apr 23rd, 2007 8:07 pm
Does Old Brake Fluid Smell? Jerrod Maguire K1200LT 7 Dec 13th, 2005 2:00 pm
Oooh that smell, Can't you smell----- early1 K1200LT 12 Nov 29th, 2005 1:05 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome