Bike has a new clutch, cruise control doesn't work - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Feb 5th, 2011, 5:00 pm Thread Starter
Senior Member
 
calvarez's Avatar
 
Join Date: Nov 2010
Location: Gilbert, AZ, USA
Posts: 348
Bike has a new clutch, cruise control doesn't work

Just got the bike back with a new clutch. It's MUCH faster and lighter-feeling now that I have $1700 less to carry in my wallet.

Anyway the CC won't engage. I can take it back to the shop, of course, and they will fix it, but thought I'd ask about some obvious things I might check that would be quicker than another shop trip.

The clutch switch sounds normal (can hear it click). I haven't done an electrical test on it yet. Brake lights aren't stuck on. The speedo and the trip computer both work normally. ABS isn't complaining.

When I press the button to set the CC, nothing happens. No light, no action. It was working perfectly before I took the bike in for the clutch.

Carlos Alvarez
Gilbert, AZ
2000 K1200LT-I
calvarez is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Feb 5th, 2011, 5:28 pm Thread Starter
Senior Member
 
calvarez's Avatar
 
Join Date: Nov 2010
Location: Gilbert, AZ, USA
Posts: 348
Re: Bike has a new clutch, cruise control doesn't work

Found the CC diagnostic and tried it. It fails on number 5, rotate the throttle to full. That does nothing (should turn on the light). So am I right that it's most likely to be that the microswitch on the throttle valve is not connected? IE, take the bike apart again to get to it?

Carlos Alvarez
Gilbert, AZ
2000 K1200LT-I
calvarez is offline  
post #3 of 5 Old Feb 5th, 2011, 6:26 pm Thread Starter
Senior Member
 
calvarez's Avatar
 
Join Date: Nov 2010
Location: Gilbert, AZ, USA
Posts: 348
Re: Bike has a new clutch, cruise control doesn't work

Well WTF...I took it for a ride, and just after a short full-throttle run, decided to play with the switch. It worked. Is it possible the shop just failed to do the TPS calibration after having the battery off? Now I'm confused. But it worked fine for many miles and on/off cycles.

Carlos Alvarez
Gilbert, AZ
2000 K1200LT-I
calvarez is offline  
 
post #4 of 5 Old Feb 5th, 2011, 7:07 pm
Senior Member
 
mwnahas's Avatar
 
Join Date: Dec 2004
Location: Bedford Hts, OH, USA
Posts: 4,217
Re: Bike has a new clutch, cruise control doesn't work

Ever have the throttle cable changed? Upgraded? it may be time. Mine went intermittent on me and the CC stopped working in the cold until I got the throttle cable upgrade. Just a thought.

Just Go
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mike
Cleveland Ohio
2014 K1600 GTL Grey Wolf.
mwnahas is offline  
post #5 of 5 Old Feb 5th, 2011, 9:27 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,215
Re: Bike has a new clutch, cruise control doesn't work

You probably just "pulled" the cables back into alignment. Routing is critical on re-assembly after a clutch job. Cycling them from full on to past off most likely did it.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Cruise Control - R1150RT LaChuparosa RT Series 9 Dec 29th, 2012 3:08 pm
Slipping Clutch - Clutch Slave Cylinder lhendrick K1200LT 24 Mar 29th, 2009 7:02 pm
PIAA 1100X Lights coupled with Cruise control ? Orhansky Lighting 3 Jul 23rd, 2007 8:20 pm
Section speed trap in The Netherlands vvk Europe 4 Apr 18th, 2006 3:40 am
Speed traps in The Netherlands vvk Chit Chat 0 Oct 24th, 2005 9:38 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome