LT radio - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Jan 13th, 2011, 9:58 am Thread Starter
Junior Member
 
keith41902's Avatar
 
Join Date: Jun 2010
Location: OTTAWA, ONTARIO, CANADA
Posts: 19
LT radio

Hey guys,
Got a 03 LT and my stock radio has terrible reception. Any ideas?

Keith D
keith41902 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Jan 13th, 2011, 12:32 pm
Senior Member
 
Join Date: Aug 2006
Location: Bergen County, NJ, USA
Posts: 715
Re: LT radio

If the radio works but just has bad reception, it's most certainly an antenna/ antenna cable issue. My CL had the same problem, the issue was where the cable end attached to the underside of the antenna. It looked like a poor design to me, with only friction holding the cable wire to the metal sleeve inside, and gravity and vibration would conspire to loosen the connection. The center gold wire was thinner than a hair and it was crucial to have that wire make contact where it's supposed to. I had to jury-rig a solution that included using a clear adhesive to hold everything once I jammed it all in place. The repair has been holding up and reception is now strong.

2010 Honda NT700V
1978 Honda CB400T II

Formerly
2011 R1200 RT
'04 R1150 RT-P
'04 R1200CLC
'06 Triumph Scrambler
'02 K1200LT
'01 R1200C Montana
'00 H-D Dyna Defender

" Twas a woman that drove me to drink and I didn't even have the decency to thank her! " - W.C. Fields

Last edited by George_S; Jan 13th, 2011 at 12:45 pm.
George_S is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
Radio Repair Update - When is the next LT ready? Vince_nj1 K1200LT 28 Oct 2nd, 2010 2:46 pm
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome