Electronic Cruise Control - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 20 Old Sep 27th, 2010, 7:23 am Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Electronic Cruise Control

The cruise control on my '03 LT apparently crapped out this week-end. I rode 277 miles on Saturday from my home in middle GA to St George Island, FL. I used my cruise control a lot to prevent wrist fatigue. It rained several times during the trip. No problems. During the night Saturday night it rained hard most of the night. On Sunday morning when we left headed north there was still a slight drizzle. About 5 miles into the trip, while only traveling at 45 mph, my throttle suddenly started accelerating as if it were resuming a former cruise setting. I tapped the brakes and the system cut off. I noticed the switch was still in the on position, which is where I leave it most of the time. I thought maybe I had accidentally hit the "set" or "resume" switch my accident. A few miles later I turned north on hwy 65 and set the cruise at 63 mph. All seemed to be ok for a couple of miles and then the bike started slowing down as if the cruise had been turned off, but the yellow set light was still lit on the dash board. I turned the cruise off on the handle bar and then turned it back on. I reset the cruise at 63 mph and it went back to working. Once again after a mile or two it started slowing again, but the set light was still on. I thought maybe the heavy rain had gotten something wet so I just turned the system off. An hour or so up the road when my wrist was getting numb I tried the CC again. This time nothing happened. The set light does not come on and the speed does not set. Any advice on this one? I didn't see anything posted in the HOW.

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old Sep 27th, 2010, 7:27 am
LAF
Lifetime Supporter
 
LAF's Avatar
 
Join Date: Jul 2007
Location: Harrisburg , PA, USA
Posts: 2,985
Re: Electronic Cruise Control

You can run the cruise control diag and see what happens. I dont have a link to a thread but if you search you will find it. You at least will have a starting point.

Lee
17.5 R1200 GSW Black Low
15 R1200 RTLC San Marino Blue Metallic (Sold)
10 Liquid Silver FJR1300 (Sold)
O7 Biarritz Blue Metallic LT (Totaled 2010)
ATGATT I am breathing proof.
BMW MOA #135959
LAF is offline  
post #3 of 20 Old Sep 27th, 2010, 7:40 am
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Electronic Cruise Control

Quote:
Originally Posted by LAF
You can run the cruise control diag and see what happens. I dont have a link to a thread but if you search you will find it. You at least will have a starting point.
Lee is right - good starting point is to run the diagnostic. Here it is, as pulled from the Service section of the Hall of Wisdom files. You can look it up afterwards, and/or print it out so you have a copy when at the bike.

1. With the igniton switch OFF, switch on the cruise control.Press and hold the 2. SET button to the SET position and switch on the Ignition switch (LIGHT)
3. Release the SET button (LIGHT GOES OFF), move to RESET position (LIGHT)
4. Release the button (LIGHT OFF) switch OFF the cruise control switch (LIGHT)
5. Switch the cruise control switch back on (LIGHT OFF)
6. Close throttle. (LIGHT), relaese throttle. (LIGHT OFF)
7. Pull clutch lever (LIGHT),release clutch lever (LIGHT OFF)
8. Pull front brake lever, (LIGHT) release lever (LIGHT OFF)
9. Push foot brake pedal (LIGHT ON), hold for 5 seconds.(LIGHT SHOULD GO OFF), release foot brake pedal (LIGHT ON)
10. Rotate rear wheel (LIGHT SHOULD GO OFF/ON)
11. Switch off ignition.
Dick is offline  
 
post #4 of 20 Old Sep 27th, 2010, 8:31 am Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

Thanks Guys. I will try this as soon as I get home this afternoon. Whatever it is causing the problem I have got to get it fixed. The LT is a great bike but it would be a bitch to ride it on a long trip without the CC. When it works the CC is awesome!
Ride Safely,
Steve

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #5 of 20 Old Sep 27th, 2010, 11:04 am
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Electronic Cruise Control

Quote:
Originally Posted by Dick
Lee is right - good starting point is to run the diagnostic. Here it is, as pulled from the Service section of the Hall of Wisdom files. You can look it up afterwards, and/or print it out so you have a copy when at the bike.

1. With the igniton switch OFF, switch on the cruise control.Press and hold the 2. SET button to the SET position and switch on the Ignition switch (LIGHT)
3. Release the SET button (LIGHT GOES OFF), move to RESET position (LIGHT)
4. Release the button (LIGHT OFF) switch OFF the cruise control switch (LIGHT)
5. Switch the cruise control switch back on (LIGHT OFF)
6. Close throttle. (LIGHT), relaese throttle. (LIGHT OFF)
7. Pull clutch lever (LIGHT),release clutch lever (LIGHT OFF)
8. Pull front brake lever, (LIGHT) release lever (LIGHT OFF)
9. Push foot brake pedal (LIGHT ON), hold for 5 seconds.(LIGHT SHOULD GO OFF), release foot brake pedal (LIGHT ON)
10. Rotate rear wheel (LIGHT SHOULD GO OFF/ON)
11. Switch off ignition.

Dick, Where do I sent the research fee's? I have a CC issue after Barbara's Heart surgury! Just worked through the steps above. All except the rear wheel get a lighted response... odd!

Now if I could only use my mental telepathy to let the Wrencher Extraordinaire know of my troubles...

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #6 of 20 Old Sep 27th, 2010, 3:49 pm
LAF
Lifetime Supporter
 
LAF's Avatar
 
Join Date: Jul 2007
Location: Harrisburg , PA, USA
Posts: 2,985
Re: Electronic Cruise Control

Quote:
Originally Posted by shoswell
Dick, Where do I sent the research fee's? I have a CC issue after Barbara's Heart surgury! Just worked through the steps above. All except the rear wheel get a lighted response... odd!

Now if I could only use my mental telepathy to let the Wrencher Extraordinaire know of my troubles...
ABS sensor need adjusting on the rear? You do need to set that distance on that sensor I believe.

Also I know that rear wire has been known to get a wear in it and cause problems from a wire tie being pulled very tight.
.

Lee
17.5 R1200 GSW Black Low
15 R1200 RTLC San Marino Blue Metallic (Sold)
10 Liquid Silver FJR1300 (Sold)
O7 Biarritz Blue Metallic LT (Totaled 2010)
ATGATT I am breathing proof.
BMW MOA #135959
LAF is offline  
post #7 of 20 Old Sep 27th, 2010, 6:33 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,232
Re: Electronic Cruise Control

Quote:
Originally Posted by shoswell
Just worked through the steps above. All except the rear wheel get a lighted response... odd!

Now if I could only use my mental telepathy to let the Wrencher Extraordinaire know of my troubles...
I don't know what to say Hoss. I never got the rear wheel deal to work either. But as long as your speedo is working the wiring there should be OK on that pick up. It should be working if everything passed the test.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #8 of 20 Old Sep 29th, 2010, 9:12 am Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

After running the diagnostic check as outlined previously it is obvious I have a problem with my ECC. When I hold the set button in the on position and turn on the ignition the set light comes on and when I release the set button the light goes out. When I press the set button again nothing happens. When I carry out the rest of the diagnostics the light does not come back on.
Any suggestions.
Thanks,

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #9 of 20 Old Sep 29th, 2010, 11:46 am
Senior Member
 
pushin9s's Avatar
 
Join Date: Feb 2007
Location: Maryville, TN, US
Posts: 312
Re: Electronic Cruise Control

It could be your switch. I've had the one on my GT replaced twice in one month!! Yuck! On the trusty LT though, the only problem I've ever had with it was the clutch switch. And the funny thing about it was that when I ran the diagnostic, it ALWAYS pointed to the throttle switch. After replacing the throttle cables and adjusting everything there, the CC still would not work. Running the diagnostic again pointed to the throttle. So after heeding the advice on this forum, I adjusted the clutch switch and viola', the CC has worked flawlessly ever since. Don't make up the news, just report it.

Before I spent big bucks on a new switch and ECC, I'd adjust the clutch and front brake switches first. Stranger things have happened.

Greg

"Loud lives save pipes"

00 K1200LT (Emil) 94,840 trouble free miles. Gone, but not forgotten
02 R1150RT (Artie) 109,000 miles. Favorite bike. With me to the end.
10 K1300GT (The Phantom) 10,110 miles. Like flying a T-38 on 2 wheels. Gone.
12 K1600GTL (Johnny 5) 3,500. A great compromise between the LT and GT

A gaggle of Japanese bikes, then I woke up.
pushin9s is offline  
post #10 of 20 Old Sep 29th, 2010, 12:36 pm Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

Greg,
I had no idea there are all these switches associated with the ECC. Where exactly is the clutch switch? Is it on the handlebar or down near the slave cylinder or where. How is it adjusted? What would cause it to get out of adjustment?
Could something have gotten wet in all the hard rain I was riding in? I have ridden in hard rain before without any problems but that doesn't mean it didn't happen this time.
Thanks for all the replies,
Steve

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #11 of 20 Old Sep 29th, 2010, 4:34 pm Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

I don't know where the gremlins went but they are gone. I know nothing fixes itself but today the diagnostic test went perfectly all the way down to the light turning on and off as I spun the rear wheel. I'm thinking now that is was rain related for sure. Dang I hate intermittent problems. It is so hard to trouble shoot them. Oh well, hopefully the problem want return in a couple of weeks when I am riding the blue ridge parkway

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #12 of 20 Old Sep 29th, 2010, 10:06 pm
Senior Member
 
pushin9s's Avatar
 
Join Date: Feb 2007
Location: Maryville, TN, US
Posts: 312
Re: Electronic Cruise Control

[QUOTE=K12smitty]Greg,
I had no idea there are all these switches associated with the ECC. Where exactly is the clutch switch? Is it on the handlebar or down near the slave cylinder or where. How is it adjusted? What would cause it to get out of adjustment?
Could something have gotten wet in all the hard rain I was riding in? I have ridden in hard rain before without any problems but that doesn't mean it didn't happen this time.
Thanks for all the replies,
Steve[/QUOTE

Steve, the clutch switch is under the handlebar beneath a cover under your clutch side switch gear. Three tiny screws hold the plastic cover in place. Once the cover is removed you'll see a little micro switch under the switch gear housing. Loosen the screw(s) and with a small slot screwdriver, put some steady,but not hard, pressure on the switch toward the front of the bike. Hold this pressure while you retighten the screws on the switch. You'll not see the switch move and probably not even feel it moving at all, but if it is the culprit it'll make all the difference in the world.

Sounds like you could have had a water logged CC switch too. But I will tell you when my CC quit due to the maladjusted clutch switch the CC would not work at all (no yellow cruise light or anything) until the sun had beat down on it for a couple or four hours. If it was cloudy or really cold the CC failed. If it was a sunny day and the bike sat out, or ran down the interstate for a few hours the CC would work until it either got cloudy or cool. Don't ask me why, I never have figured it out but I do know as soon as I got home and did some extra research on this forum I did the clutch switch adjustment and the CC started working immediately. If that doesn't fix yours, there is another switch just like it under the front brake lever too but from what I've read and talked with others, the clutch is the normal culprit.

Greg

"Loud lives save pipes"

00 K1200LT (Emil) 94,840 trouble free miles. Gone, but not forgotten
02 R1150RT (Artie) 109,000 miles. Favorite bike. With me to the end.
10 K1300GT (The Phantom) 10,110 miles. Like flying a T-38 on 2 wheels. Gone.
12 K1600GTL (Johnny 5) 3,500. A great compromise between the LT and GT

A gaggle of Japanese bikes, then I woke up.
pushin9s is offline  
post #13 of 20 Old Sep 30th, 2010, 8:23 am Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

Thanks Greg. That is great information to know. If the gremlins return that will be the first thing I look at.
This forum is so awesome!

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #14 of 20 Old Sep 30th, 2010, 10:17 pm
Member
 
Chilly's Avatar
 
Join Date: Apr 2010
Location: Fort Collins, CO, USA
Posts: 40
Re: Electronic Cruise Control

Has anyone ever tried by-passing the "throttle micro switch" and if so did you have
luck solving the sometimes works -sometimes doesn't cruise problem??

Thx!

Bill
Colorado Native -


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Rocky Mtn High "it's much more than a John Denver song!"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2012 R1200RT - The gray shark - oh what a ride!
1995 Honda "Pacific Coast" Honda's woefully underpowered answer to the LT
2002 K1200LTC Royal Blue (SOLD to Grant (Colo Sprgs) as he could fix the ABS)
1987 G1200A (SOLD)
1984 GL1200A (my first "big" bike)
1983 GL650i (I wish I still had this all org collector)
Chilly is offline  
post #15 of 20 Old Oct 1st, 2010, 12:28 am
Senior Member
 
pushin9s's Avatar
 
Join Date: Feb 2007
Location: Maryville, TN, US
Posts: 312
Re: Electronic Cruise Control

Quote:
Originally Posted by Chilly
Has anyone ever tried by-passing the "throttle micro switch" and if so did you have
luck solving the sometimes works -sometimes doesn't cruise problem??

Thx!
Not sure I'd bypass any of the CC switches as they are a safety device. I know you can hit a brake or clutch or turn the switch off, but sometimes when I need to slow in a hurry I just roll the throttle forward and kick it off that way. Just my $0.02 worth.

Greg

"Loud lives save pipes"

00 K1200LT (Emil) 94,840 trouble free miles. Gone, but not forgotten
02 R1150RT (Artie) 109,000 miles. Favorite bike. With me to the end.
10 K1300GT (The Phantom) 10,110 miles. Like flying a T-38 on 2 wheels. Gone.
12 K1600GTL (Johnny 5) 3,500. A great compromise between the LT and GT

A gaggle of Japanese bikes, then I woke up.
pushin9s is offline  
post #16 of 20 Old Oct 1st, 2010, 7:35 am
Member
 
Chilly's Avatar
 
Join Date: Apr 2010
Location: Fort Collins, CO, USA
Posts: 40
Re: Electronic Cruise Control

Thanks Greg and I agree about the safety issue - just a bad design I think - too sensitive none of my auto have a throttle cutout in the cruise circuit - I've never used the "roll it forward" to turn mine off as I had the old style throttle cables (now have the new ones - much smoother) and it would have thrown me off in the jerking action of the throttle closing - just food ofr thought - I wonder if a stronger spring in there might do the trick?

Bill
Colorado Native -


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Rocky Mtn High "it's much more than a John Denver song!"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2012 R1200RT - The gray shark - oh what a ride!
1995 Honda "Pacific Coast" Honda's woefully underpowered answer to the LT
2002 K1200LTC Royal Blue (SOLD to Grant (Colo Sprgs) as he could fix the ABS)
1987 G1200A (SOLD)
1984 GL1200A (my first "big" bike)
1983 GL650i (I wish I still had this all org collector)
Chilly is offline  
post #17 of 20 Old Oct 1st, 2010, 9:46 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,232
Re: Electronic Cruise Control

You just have to follow the adjustment procedures in the manual. That switch is very reliable if you have it set correctly. Mine has never given me an issue and I have to really roll it off to clear it. I also have the new style cables now as my "05" did not come with them. (took delivery in 04). Cruise still works perfectly.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #18 of 20 Old Oct 2nd, 2010, 9:16 am
Member
 
av8trto's Avatar
 
Join Date: Jul 2010
Location: Eagle, ID, USA
Posts: 94
Re: Electronic Cruise Control

With all the various interconnections the cruise control uses it could obviously be any adjustment, switch, sensor or combination there of. The diagnostic advice is good but you need to simulate a wet or damp bike to make it accurate.

What I have experienced is that if the CC switch module on the handle bar gets wet for any reason; dew, rain or washing the bike my cruise gets temperamental. I have just waited until I think it has dried out and then reset the CC on/off switch, turn it back to on and then it works. This just exercises the contacts and resets the logic. I have gotten where I don't even try the cruise if the CC switch module has been wet.

I am thinking the the waterproof characteristics of the switch diminish with age or that the design is limited in keeping the moisture out. With micro current or voltage any moisture can cause it to fail.

This is just what works for me.

I am not a motorcycle mechanic but I have been a licensed aircraft mechanic for thirty years. I appreciate all the advice I have read on this forum.

Last edited by av8trto; Oct 2nd, 2010 at 9:23 am.
av8trto is offline  
post #19 of 20 Old Oct 5th, 2010, 12:40 pm Thread Starter
Senior Member
 
K12smitty's Avatar
 
Join Date: Mar 2010
Location: Warner Robins, GA, USA
Posts: 150
Re: Electronic Cruise Control

I sprayed copious amounts of WD-40 all around the CC switch. Hopefully this will help keep moisture out. So far a good washing didn't cause a failure. I guess only another "frog strangling" rainy ride will tell the tale.
Thanks to all who responded.

Ride Safely,
Steve

'09 K1200LT "Clyde"
'03 K1200LT (totaled out 3-16-11) "The Beast"
'97 K1100LT (104,000) "Red Ryder" (Sold Feb 2013)
'09 KLR 650 "Killer"
'05 KLR 250 "Lil' Killer"
'09 Kymco People 200 S "Wife's Trainer"
'09 Kymco xCiting 500i "Wife's next step"

It is amazing what a little "throttle therapy" will do for you.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
K12smitty is offline  
post #20 of 20 Old Nov 16th, 2010, 6:25 am
cws
Senior Member
 
cws's Avatar
 
Join Date: Aug 2005
Location: Sydney, NSW, Australia
Posts: 3,182
Garage
Re: Electronic Cruise Control

+1 to the combined genius and generosity of this group yet again.... finally managed to sort out my faulty cruise control yesterday (self dis-engaging), once I'd worked out exactly how to get to the switches.... tricky bits of plastic on the clutch side!
Adjusted both the clutch switch (outward toward the clutch lever) and brake switch (forward toward the brake lever).
Tested on some really bumpy roads this evening coming home, and not a problem.
Hopefully that's now good for another 5 years!

Chris
Sydney, NSW
2005 Dark Graphite Metallic K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 Orient Blue Metallic K1200GT SE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(sold 2019)
2000 Red Honda CB250 (the toy)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ulysses #45310
GS911


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

cws is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electronic Cruise Control - R1150RT LaChuparosa RT Series 9 Dec 29th, 2012 3:08 pm
MCCruise.com electronic cruise control installed Randy GS Series 16 Jun 22nd, 2007 9:04 am
Electronic cruise control jkersh1 K1200/1300GT (The Next Generation) 2 Oct 19th, 2006 12:31 am
Section speed trap in The Netherlands vvk Europe 4 Apr 18th, 2006 3:40 am
Speed traps in The Netherlands vvk Chit Chat 0 Oct 24th, 2005 9:38 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome