Bike electronic went out while jump starting - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Sep 25th, 2010, 2:22 pm Thread Starter
Member
 
Join Date: Jul 2009
Location: Richmond, TX, Fort Bend
Posts: 33
Bike electronic went out while jump starting

I was trying to jump start my 02 bmw k1200 lt from my truck battery. I hooked up the cables and the dash light came on etc. I hit the starter and all dash light wnet out and now seems the electric system is doa. I checked the fuses and all seems to be good. Any suggestio ns?
DesertCoyote is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Sep 25th, 2010, 3:24 pm
BMW Guru
 
Ted Shred's Avatar
 
Join Date: Feb 2003
Location: Nor Cal, , USA
Posts: 8,469
Re: Bike electronic went out while jump starting

If the bike battery is too far gone it won't jump start or charge with a trickle charger. Time for a new battery I'd say.

__________
2016 R1200GS Adventure
2006 DRZ400E

2007 G650 X Challenge
2006 GT200
2005 R1200GS


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ted Shred is offline  
post #3 of 7 Old Sep 25th, 2010, 3:44 pm Thread Starter
Member
 
Join Date: Jul 2009
Location: Richmond, TX, Fort Bend
Posts: 33
Re: Bike electronic went out while jump starting

But even when I put a jumper cable on it my dash board lit up. Hit the starter and dash board light were off. Still could be the battery?
DesertCoyote is offline  
 
post #4 of 7 Old Sep 25th, 2010, 4:09 pm
Senior Member
 
Boatzo's Avatar
 
Join Date: Jun 2010
Location: Hartfield, VA, USA
Posts: 1,105
Re: Bike electronic went out while jump starting

Try letting the jumpers connected for about 5 min. That should bring up your battery some if it isn't completely shot. If you can get the thing charged up, get a load test on the battery, that will give you a idea of the condition of the battery.

Bill
Eastern Virginia (Middle Peninsula)
K3ZXV
05 Honda Sabre 1100
04 Triumph Speedmaster , Black with
California Sidecar Friendship II
99 K1200LT, Basalt Gray "DELILAH" (SOLD)
99 R1100RT ,Glacier Green (SOLD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
Boatzo is offline  
post #5 of 7 Old Sep 25th, 2010, 4:22 pm
BMW Guru
 
Ted Shred's Avatar
 
Join Date: Feb 2003
Location: Nor Cal, , USA
Posts: 8,469
Re: Bike electronic went out while jump starting

Quote:
Originally Posted by DesertCoyote
But even when I put a jumper cable on it my dash board lit up. Hit the starter and dash board light were off. Still could be the battery?
Yep, you need a new battery. How old is it? Keep it on a tender when not riding?

__________
2016 R1200GS Adventure
2006 DRZ400E

2007 G650 X Challenge
2006 GT200
2005 R1200GS


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ted Shred is offline  
post #6 of 7 Old Sep 26th, 2010, 7:42 am
Senior Member
 
wolfstudios's Avatar
 
Join Date: Feb 2004
Location: , Northeast Ohio,
Posts: 137
Re: Bike electronic went out while jump starting

Did you put the negative clamp on the negative post on the battery?
I put that (-)clamp on the frame once and blew out the reverser module and the gas level sensor. Never thought it would do that!
Must keep jumper cables on the battery terminals!

Wolf

71 Triumph 650 - 30,000 miles
76 Suzuki GT750 - 40,000 miles
85 1200cc Suzuki Madura - 107,000 miles
86 1200cc Yamaha Venture - 60,000 miles
99 BMW K1200LT - 158,000 (Sold)
09 BMW K1200LT -41,399 miles (and counting)
wolfstudios is offline  
post #7 of 7 Old Sep 26th, 2010, 9:33 am
Lifetime Supporter
 
deanwoolsey's Avatar
 
Join Date: Aug 2008
Location: Topeka, KS, USA
Posts: 3,105
Re: Bike electronic went out while jump starting

BMW does not use a frame ground system like we see in an automobile. As stated above, do not connect a jumper cable to the frame. Jumping properly from a larger battery should not cause issues as long as the cables are properly connected at the battery posts. I would charge the battery up, disconnect the negative post for a minute or two and then reconnect it. Maybe you'll get lucky. Pay close attention as there are multiple connections on the posts and it is easy to miss one. You did jump pos. to pos. and neg. to neg., yes?
deanwoolsey is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
DUI Interesting article! vvk Bike Talk 69 Nov 13th, 2008 6:39 pm
GAGSC 2008 ... my experience Colyn Ride Tales 6 Oct 1st, 2008 1:12 am
This newbie LT guy was in bike accident jdsd-tourteam K1200LT 43 Jan 25th, 2008 9:44 am
Bike is dead! Would like to jump it with a portable battery k1201ltc North East 14 Jan 12th, 2008 10:54 am
Suggestions for Wife's Starting Bike tarheel_rider Chit Chat 22 Apr 9th, 2006 8:13 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome