99 K12LT Dead radio fix - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Sep 13th, 2010, 10:50 pm Thread Starter
Junior Member
 
Flyboy53's Avatar
 
Join Date: Aug 2009
Location: Arlington, WA, USA
Posts: 17
99 K12LT Dead radio fix

I wanted to share a victory in doing a self repair for my dead audio system.

My 99 LT had an intermittent loss of all sound from the speakers. The displays and controls seemed to work normally, just no sound. After a while it went dead completely. I tried some of the suggestions found here on the forums with no luck and the dealer suggested a new main unit, but those are rare and big bucks..

With nothing to lose I tore into the stingray and finally had the radio unit on my bench. After disassembling the case, I looked it over with a magnifying glass. I eventually spotted what looked like a crack in a large toroid coil. I cleaned it and added some solder to the crack area. I also used some 'shoe goo' type potting compound to keep the coil from vibrating.

Put it all back together and the music returned!

I hope this may help someone else.
Attached Thumbnails
Click image for larger version

Name:	RaDIO fix 2.jpg
Views:	122
Size:	963.7 KB
ID:	28834  

Back in the game-
'99 K1200LT Basalt Grey - New to me in '09
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


These are long gone:
'84 Honda CB700 Nighthawk
'82 Honda Goldwing Aspencade
'76 Goldwing
'71 Honda CB750
'70 Honda CB 350
'67 Honda CB 160
And a bunch of dirt bikes and dual sports
Flyboy53 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Sep 14th, 2010, 1:29 am
Senior Member
 
Axle's Avatar
 
Join Date: Oct 2007
Location: portland, victoria, Australia
Posts: 1,478
Garage
Re: 99 K12LT Dead radio fix

well done

Regards Linton
From the land of Kangaroo's and Koalas
and no koalas are not Bears



2002 K1200LT
2010 Suzuki GSX 1250FA (the Wifes)
2004 Cub Kamparoo Sprint
My Toys
1976 Datsun 260Z
1989 Nissan 300zx TT
Axle is offline  
post #3 of 4 Old Sep 14th, 2010, 3:15 am
Senior Member
 
wa1200lt's Avatar
 
Join Date: Apr 2009
Location: Vancouver, WA, USA
Posts: 2,745
Re: 99 K12LT Dead radio fix

Successful CPR on am LT radio. Great job bringing it back to life!.

WAK1200LT
Loren

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Cave quid dicis, quando, et cui
wa1200lt is offline  
 
post #4 of 4 Old Sep 14th, 2010, 8:49 am
Senior Member
 
Razmataz's Avatar
 
Join Date: Aug 2008
Location: Pesotum, Il, USA
Posts: 1,334
Re: 99 K12LT Dead radio fix

Great find...thanks for the post.

BMW 1200 LTC 2002


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Illinois...The Only State Where The Governors Make The License Plates
Razmataz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
Help Trouble Shooting Dead Radio Lynn_Keen K1200LT 9 May 16th, 2009 1:29 pm
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome