Brake lights quit working - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jul 21st, 2010, 11:49 pm Thread Starter
Member
 
TVPearson's Avatar
 
Join Date: Apr 2010
Location: Springfield, MO, USA
Posts: 72
Brake lights quit working

I was adding an LED brake light kit to my 2000 LT. I ran the wire off the harness behind the rear lens up under the top case and out to the light strip. Anyway, to make a long story short, I pinched the wires while installing the top case and shorted out the brake lights. I assumed it would have blown a fuse but upon checking, I noticed that the fuse was a 15 amp while the manual calls for a 4 amp. ( I suppose the PO did this??)
The fuse did not blow and I do not have any brake lights. I checked the bulbs and they are all good, so do you guys think I blew the brake light relay? I did some research in the archives and from what I can tell, I need to take off the right side tupperware, and the relay is somewhere under the gas tank? Is this correct? By the way, I am supposed to leave in the morning for a trip through the Ozark mountains with another couple, I don't think that will be happening....

2000 K1200LTI
TVPearson is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jul 22nd, 2010, 12:11 am Thread Starter
Member
 
TVPearson's Avatar
 
Join Date: Apr 2010
Location: Springfield, MO, USA
Posts: 72
Re: Brake lights quit working

Quote:
Originally Posted by TVPearson
I was adding an LED brake light kit to my 2000 LT. I ran the wire off the harness behind the rear lens up under the top case and out to the light strip. Anyway, to make a long story short, I pinched the wires while installing the top case and shorted out the brake lights. I assumed it would have blown a fuse but upon checking, I noticed that the fuse was a 15 amp while the manual calls for a 4 amp. ( I suppose the PO did this??)
The fuse did not blow and I do not have any brake lights. I checked the bulbs and they are all good, so do you guys think I blew the brake light relay? I did some research in the archives and from what I can tell, I need to take off the right side tupperware, and the relay is somewhere under the gas tank? Is this correct? By the way, I am supposed to leave in the morning for a trip through the Ozark mountains with another couple, I don't think that will be happening....
Wow, after posting my question, I just kept reading on the forum. I found one particular post about the same problem and someone replied to check the top fuse AND the third fuse down, low and behold, the third fuse was blown!!! Now, why doesn't the manual tell us that??
A BIG thanks to all those who contribute on this site. If I hurry up, I can get the bike back together and still make my trip in the morning.
Once again, thanks!!

2000 K1200LTI
TVPearson is offline  
post #3 of 3 Old Jul 23rd, 2010, 7:57 am
cws
Senior Member
 
cws's Avatar
 
Join Date: Aug 2005
Location: Sydney, NSW, Australia
Posts: 3,179
Garage
Re: Brake lights quit working

Have a great trip, Terry!
cheers

Chris
Sydney, NSW
2005 Dark Graphite Metallic K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 Orient Blue Metallic K1200GT SE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(sold 2019)
2000 Red Honda CB250 (the toy)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Ulysses #45310
GS911


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

cws is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights stuck on. JPSpen K1200LT 5 Jul 22nd, 2010 7:17 am
Brake light relay - lights stuck on saileyboy K1200LT 7 Sep 3rd, 2009 3:40 pm
Add running & brake lights to turn signals ArthurKnowles K1200LT 7 Jun 17th, 2008 1:01 am
Led Brake Lights userexist Lighting 4 Oct 31st, 2006 7:40 am
Flashing brake lights? NOGILLS2 K1200LT 7 Nov 16th, 2005 8:23 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome