New HID kills radio reception - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Jul 2nd, 2010, 6:06 am Thread Starter
Junior Member
 
Daft-Jim's Avatar
 
Join Date: Aug 2009
Location: Epsom, , England
Posts: 24
New HID kills radio reception

Just fitted a HID to my low beam on the LT.

Great, EXCEPT, radio reception take a huge hit when I turn it on.
Daft-Jim is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Jul 2nd, 2010, 1:58 pm
Senior Member
 
PATTERSON's Avatar
 
Join Date: Dec 2005
Location: RENTON, WA, USA
Posts: 436
Re: New HID kills radio reception

Re-route your wiring as far from anything to do with the radio as possible.....

Patterson/USAF1....'05 LT
and the little guy behind me is the world famous "Marty Hill"
Never look into a lazer with the remaining eye
363K on BMW's
PATTERSON is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated with XM Radio Customer Service wcarter Satellite Radio 19 Jan 16th, 2019 9:24 am
Radio Static / No Reception BeemerBoyLT K1200LT 1 Oct 20th, 2009 9:57 am
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
weatherband radio reception jpicco K1200LT 8 Mar 10th, 2008 12:39 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome