Speaker Issue - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old May 5th, 2010, 12:55 pm Thread Starter
Junior Member
 
carleupshaw's Avatar
 
Join Date: Apr 2010
Location: Houston, Texas, USA
Posts: 2
Speaker Issue

I have a 2005 K1200LT and when I turn on the radio all of the speakers work for about 5 to 10 seconds and then just the front left one works. Does anyone have any ideas that could help me out.
carleupshaw is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old May 5th, 2010, 1:53 pm
Senior Member
 
sheldan2's Avatar
 
Join Date: Mar 2005
Location: kings mountain, NC, usa
Posts: 2,099
Re: Speaker Issue

Do a hard reset by disconnectong the battery for an hour or so, then see if that fix's the problem. If not your amp in your radio is toast.

Courage doesn't always roar. Sometimes it is the quiet voice at the end of the day saying " I'll try again tomorrow".


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sheldan2 is offline  
post #3 of 4 Old May 5th, 2010, 6:46 pm Thread Starter
Junior Member
 
carleupshaw's Avatar
 
Join Date: Apr 2010
Location: Houston, Texas, USA
Posts: 2
Re: Speaker Issue

Thanks I will try that. If it is the amp do I have to replace the whole radio or is that something that might could be fixed by a radio shop.
carleupshaw is offline  
 
post #4 of 4 Old May 5th, 2010, 7:57 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,269
Re: Speaker Issue

Only Becker can fix these and they do it by replacing the entire board. The final amps are what is known as "ball grid array" chips and not easily replaced if at all. Much better for maufacturing but a sacrifice for service.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio/ Speaker Issue tankman1001 K1200LT 7 Apr 12th, 2009 10:58 am
Left rear speaker issue???? Timmy K1200LT 4 Mar 24th, 2008 5:52 pm
Left rear speaker issue???? Timmy K1200LT 2 Mar 21st, 2008 9:00 am
Speaker issue?????? Timmy K1200LT 2 Feb 28th, 2008 10:05 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome