Rear speaker not working????? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jan 16th, 2010, 8:39 pm Thread Starter
 
Join Date: Jan 2010
Posts: 1
Rear speaker not working?????

rear speaker not working can anybody offer advice on how to fix?
ToolmanTim is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jan 16th, 2010, 9:56 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: Rear speaker not working?????

Two things can cause this. Blown output chips in the radio (not real likely) or corroded connections in the barrel connector(more likely). There are two barrel connectors. One is under the rear seat and the other is under the left side tupperware (opposite the gas filler). Often a disconnect and clean up with some contact cleaner followed with some diectric grease will restore the sound.

Before doing anything double check the fader control to ensure it didn't change. Step through the "note" button until you see FAD.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 4 Old Jan 18th, 2010, 8:00 am
Senior Member
 
BMWWANDRR's Avatar
 
Join Date: Feb 2006
Location: Full time RVer, , USA
Posts: 269
Re: Rear speaker not working?????

This has happened twice to my rear speakers. Both times it was bad amps and the whole unit had to be replaced. Good thing is, once it is replaced by BMW the warranty is two years on that part.

Greg and Melanie
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

06 BMW K12LT "WANDRR"
05 DL1000 "WNDRR2"
02 Triumph Trophy 1200 "WNDRR3", in Heidelburg

WANDRR Motorcycle Tours
wandrrmotorcycletours.com
BMWMOA, BMWMOAL, IBA, MTF

ITS ALL ABOUT THE RIDE
BMWWANDRR is offline  
 
post #4 of 4 Old Jan 18th, 2010, 11:30 am
Senior Member
 
Join Date: Mar 2005
Location: Palma de Mallorca
Posts: 1,985
Re: Rear speaker not working?????

Over the past 5 years I have replaced a rear speaker and a front one. They had simply stopped working.

Replacing the rear one is a piece of cake compared to the front one.
simoncharles is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tech Session in Easton, Pa. on March 21 firstbeemer North East 61 Mar 11th, 2011 2:55 pm
Rear Speaker Replacement Suggestions wkclark Intercom, CB, & 2-Way Radios 1 Aug 25th, 2008 10:46 am
Rt Rear Speaker Out-'03LT reggosnell K1200LT 15 Jun 28th, 2008 7:18 pm
Yet another rear end mystery! gdroege K1200LT 10 Oct 28th, 2007 1:59 pm
Linked brakes negative bmwrubbercow K1200LT 19 Aug 4th, 2006 4:00 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome