LT rear speakers come on initially and then cuts out - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old Oct 26th, 2009, 5:08 pm Thread Starter
Junior Member
 
joseph_p's Avatar
 
Join Date: Dec 2007
Location: Brisbane, Queensland, Australia
Posts: 26
LT rear speakers come on initially and then cuts out

Has any one had trouble with their K1200LT rear speakers (I've got a 2003 model) ? The saga started when one day the radio wouldn't come one. I unplugged the battery for about 20mins and then it all came on (thanks to help I got from this forum). However shortly after (about 20 secs) the rear speakers cut out. When I unplugged the battery again, the rear speakers came back on (front speakers are working fine), but again after about 10 secs they cut out. Over the last few months, I've unplugged the brown wire to the battery and not always have the rear speakers come back on and then cut out (1 out of 10 times the rear speakers come on and then cut out after about 10 secs)

I took the bike to the local bike mechanic who only specialises in BMW bikes and he tried recharging the battery and swapping in a new battery and he too experiencd the rear speakers coming on for about 10 secs when he reconnected a battery (2 times out of about 10 times and the other 8 times the rear speakers didn't even come on) and then the rear speakers cut out- showing it's definitely NOT a connection/ wiring issue. Everything else with the radio/ CD works fine. Also checked the fader and tried going from full forward speakers to full rear speakers and when it goes to "10 on the rear speakers" the sound cuts out altogether.

His suggestion was to take it to the BMW dealers because the entire radio unit might be faulty and might need to be replaced - $ound$ expen$ive

Anyone have any thoughts about what else I can do/ try? Such a dilemma, I just can't enjoy the ride as much without surround sound music when the musics only coming from the front speakers.

Please help.... even if it's a one liner to say "before you take it to the dealer, try this...." or "look at this link..." or "tell your mechanic to try this...."

Thanks in advance
Joseph
joseph_p is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old Oct 26th, 2009, 7:24 pm
Lifetime Supporter
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: LT rear speakers come on initially and then cuts out

"2 times out of about 10 times" If you clean up the wiring harnesses under the stingray and apply fresh dielectric grease the problems go away.

And 9 out of 10 doctors agree!

My name is Hoss and I approved this message!

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #3 of 11 Old Oct 26th, 2009, 8:34 pm
Senior Member
 
Vince_nj1's Avatar
 
Join Date: Mar 2003
Location: Whippany, NJ, USA
Posts: 155
Re: LT rear speakers come on initially and then cuts out

You can try that, but my bet is that the radio amp is failing. I tried all the tricks listed on this forum and nothing worked. I had to replace the radio. Chicago BMW. I think I paid somewhere around $800.

Vince - 2003 LT.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vince_nj1 is offline  
 
post #4 of 11 Old Oct 27th, 2009, 5:04 pm Thread Starter
Junior Member
 
joseph_p's Avatar
 
Join Date: Dec 2007
Location: Brisbane, Queensland, Australia
Posts: 26
Re: LT rear speakers come on initially and then cuts out

Quote:
Originally Posted by Vince_nj1
You can try that, but my bet is that the radio amp is failing. I tried all the tricks listed on this forum and nothing worked. I had to replace the radio. Chicago BMW. I think I paid somewhere around $800.
Let's hope the 2 out of 10 solution works that Hoss proposed is gonna work, if not it's gonna be bloody expensive.

Anyone else have any ideas? I'll try anything (almost) and takeit to the dealer as a last resort.
joseph_p is offline  
post #5 of 11 Old Oct 27th, 2009, 5:28 pm
Senior Member
 
Ajlelectronics's Avatar
 
Join Date: Dec 2006
Location: Gloucester, Gloucestershire, England
Posts: 361
Re: LT rear speakers come on initially and then cuts out

Quote:
Originally Posted by joseph_p
Let's hope the 2 out of 10 solution works that Hoss proposed is gonna work, if not it's gonna be bloody expensive.

Anyone else have any ideas? I'll try anything (almost) and takeit to the dealer as a last resort.
Percussive maintenance may show where the problem lies.

Use the flat of your hand to hit the stingray area, see if you can provoke it to come and go. If so, take the stingray apart and remake all connectors, paying special attention to the three connectors at the top left that connect to the bike. If still no improvement, a bit of remaking soldered joints on the board may help. You are mainly interested in joints around the PA area.

Just pussin' through.
Ajlelectronics is offline  
post #6 of 11 Old Oct 27th, 2009, 8:23 pm
Lifetime Supporter
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: LT rear speakers come on initially and then cuts out

Quote:
Originally Posted by Ajlelectronics
Percussive maintenance may show where the problem lies.

Use the flat of your hand to hit the stingray area, see if you can provoke it to come and go. If so, take the stingray apart and remake all connectors, paying special attention to the three connectors at the top left that connect to the bike. If still no improvement, a bit of remaking soldered joints on the board may help. You are mainly interested in joints around the PA area.
I don't care who you are...Thats funny right there!

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #7 of 11 Old Oct 29th, 2009, 4:57 pm Thread Starter
Junior Member
 
joseph_p's Avatar
 
Join Date: Dec 2007
Location: Brisbane, Queensland, Australia
Posts: 26
Re: LT rear speakers come on initially and then cuts out

I like it.... "Percussive maintenance".

I'm not a DIY/ Mechanically-minded kinda guy. (I know how to get on my LT, turn on the music and ride - and occationally stop to put fuel and air in). Therefore with regards to removing the stingray.... can I do that without removing the fairings? Or is even this activity better left to "a professional"?
joseph_p is offline  
post #8 of 11 Old Apr 28th, 2010, 9:47 pm
Junior Member
 
Join Date: Apr 2010
Location: Fort Lauderdale, Florida, USA
Posts: 5
Re: LT rear speakers come on initially and then cuts out

My front speakers have cut out just like your back speakers. As with yours they come on for a few seconds then cut out. I took it all apart, cleaned everything reversed the wiring etc and could not solve the problem. I believe it is an amplifier problem in the radio. Replacement is ridiculously expensive so I bought an ipod, portable satellite radio and a Nolan helmet with N-Com. I have also removed the six CD player to give more room for stuff.
ruddur is offline  
post #9 of 11 Old Apr 29th, 2010, 3:04 am
Junior Member
 
Join Date: Nov 2006
Location: Jakarta, , Indonesia
Posts: 8
Re: LT rear speakers come on initially and then cuts out

I have an 03, tried all the things this excellent site has to offer but still ended up having to replace the radio..it is costly, but when you get back on the road enjoying the bike and the music, the lighter wallet becomes easier to live with..
nyoung is offline  
post #10 of 11 Old Apr 29th, 2010, 11:22 am
Lifetime Supporter
 
Join Date: May 2003
Location: Phoenix, AZ, USA
Posts: 1,305
Re: LT rear speakers come on initially and then cuts out

I have an '02. When the radio amp went TU the sound from all the speakers was distorted. When the warranty replacement crapped out (still under warranty) the techs found that even with the new radio the right side speakers didn't work. That turned out to be a bad control element, the thing with the buttons, that is separate from the radio unit.

Motor On ,/'


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jkersh1 is offline  
post #11 of 11 Old Apr 29th, 2010, 8:27 pm
Senior Member
 
GlennM86's Avatar
 
Join Date: Mar 2008
Location: Virginia Beach, VA, USA
Posts: 605
Re: LT rear speakers come on initially and then cuts out

Quote:
Originally Posted by joseph_p
Anyone else have any ideas? I'll try anything (almost) and takeit to the dealer as a last resort.

Have you considered replacing the factory radio with a Marine Jensen?

There have been several members that have had luck with this mod. Looks good too.

Recommend searching for Jensen and reading those threads as an alternative to the BMW radio.

Just a thought...

Good luck

Glenn
Virginia Beach VA and Washington DC

2006 K1200LT "Phoenix Helena": Dark Graphite (#946)
2005 K1200LT "Dolly": Dark Graphite (#946) - Totaled July 2011
2002 K1200LT "Helga"-totaled Apr 2009
Iron Butt Membership # 45813


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

<By Motorcycle>


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

<By Car or Ship>
GlennM86 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome