Battery problems revisited - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Oct 4th, 2005, 7:50 am Thread Starter
Senior Member
 
NOGILLS2's Avatar
 
Join Date: Nov 2004
Location: Hammond, LA, USA
Posts: 1,899
Cool Battery problems revisited

About a month ago ,seems like an eternity after all that has happened since then, I posted about battery questions the "Beerburner", sometimes would not start, sometimes it would. It had become very agravating and embarrassing to ask for a jump start, several of you recomended a new battery. So I ordered an Odyssey battery, the charge apeared on my card bill, but no battery, it still has not shown up, so I protested the charge and ordered with a different company. I then left for Salt Lake City, when I arrived home a BIG box was on my porch with the new battery, I built a side post adapter for the ground and hooked it up and WAAALAAA, new fire in the "Beerburner". Runs like a new bike!!!

NOGILLS2


Booze Brother# 69
2003 K1200LTE "BEERBURNER" RIP 07/21/09
2006 Aluma Trailer "AFTERBURNER" SOLD
2007 ST1300ABS "Quicksilver"




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.







To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NOGILLS2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bike only 14 months old - battery problems Thor1340 K1200LT 14 Aug 30th, 2006 5:59 pm
Battery Concern please advise Hulkster Batteries, Chargers, & Electrical 8 Feb 6th, 2006 1:41 am
Battery Charger bugged Batteries, Chargers, & Electrical 4 Dec 11th, 2005 10:55 am
How NOT to treat your battery.... Zotter Batteries, Chargers, & Electrical 8 Nov 22nd, 2005 2:51 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome