Radio quit - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old Aug 19th, 2009, 3:30 pm Thread Starter
Junior Member
 
thoganco's Avatar
 
Join Date: Jul 2009
Location: Forest lake, MN, United States
Posts: 6
Radio quit

I need some input from you wise sages of LT domain. I purchased a dealer maintained '03 with 17k miles on it. I have ridden it for a couple of months. On a sunny day I am flying down the interstate and the radio goes out. Radio, com, cd. Dead. when I turn it on, I get a glow from the LCD screen but little else.

I have unplugged the battery (which is new) waited 30 minutes (actually a couple of hours) and re-powered, and same result. Checked fuse. Dealer says new radio time. Any suggestions?

TIA

Tim
thoganco is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old Aug 19th, 2009, 5:21 pm
 
Join Date: Aug 2009
Posts: 2
Re: Radio quit

I had the same problem on my 2003 LT, good thing it was underwarranty, it cost around $1300 bucks, ooohhh.
mpchiari is offline  
post #3 of 15 Old Aug 19th, 2009, 5:25 pm
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Radio quit

Yep time for a new / Preowned radio. I found a good used one for about $250.00 when mine went out.

Stevie Shreeve
katnapinn is offline  
 
post #4 of 15 Old Aug 19th, 2009, 6:08 pm
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Radio quit

It will take some "tupperware" removal but there is a fuse behind the radio, under the stingray. As a side note and not to think ill, but you did check the fuses under the seat, right?

http://www.bmwlt.com/forums/showthre...702#post404702

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI

Last edited by shoswell; Aug 19th, 2009 at 6:22 pm.
shoswell is offline  
post #5 of 15 Old Aug 19th, 2009, 10:56 pm Thread Starter
Junior Member
 
thoganco's Avatar
 
Join Date: Jul 2009
Location: Forest lake, MN, United States
Posts: 6
Re: Radio quit

Yep, checked the fuses. is there a bone yard online for used radios?

Thanks for the replies.
thoganco is offline  
post #6 of 15 Old Aug 19th, 2009, 11:11 pm
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Radio quit

Quote:
Originally Posted by thoganco
Yep, checked the fuses. is there a bone yard online for used radios?

Thanks for the replies.
DId you "reset" the bike? disconnect the battery? I'm giving you all options that I have read or done prior to help out.... Once the problem is down to the RDU you're mostly screwed!

http://www.bmwlt.com/forums/showthread.php?t=1244

http://www.bmwlt.com/forums/showthread.php?t=49165

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #7 of 15 Old Aug 20th, 2009, 6:05 am
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Radio quit

Quote:
Originally Posted by thoganco
Yep, checked the fuses. is there a bone yard online for used radios?

Thanks for the replies.
HERE is on on E-Bay

Stevie Shreeve
katnapinn is offline  
post #8 of 15 Old Aug 20th, 2009, 8:44 am
Senior Member
 
AlaskaFish's Avatar
 
Join Date: Apr 2002
Location: Hillsboro, OR, USA
Posts: 3,136
Cool Re: Radio quit

We have a cassette style radio from our salvaged LT if you cannot solve the problem with fuses or re-setting the radio. If interested PM us, but make it soon, as we are hitting the road for CCR next week!

John

John & Marilyn Fisher
'00 K1200LTC "Katie"
'95 Triumph "Tigger"
'12 Triumph 800XC "Tigger II" (RIP)
'12 Triumph 1200 Explorer "Shadow Tigger"
Hillsboro, Oregon

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AlaskaFish is offline  
post #9 of 15 Old Aug 20th, 2009, 9:15 am Thread Starter
Junior Member
 
thoganco's Avatar
 
Join Date: Jul 2009
Location: Forest lake, MN, United States
Posts: 6
Re: Radio quit

I am assuming that by "resetting" everyone means disconnecting the battery. Thanks to the postings that was the first thing I tried. Then checked fuses, then took the stingray apart.
I have a CD player. As this is a new venture, is it safe to assume that I need to replace it with the same?

T
thoganco is offline  
post #10 of 15 Old Aug 20th, 2009, 10:14 am
Senior Member
 
Join Date: Apr 2002
Location: Myrtle Beach SC, SC, USA
Posts: 2,192
Re: Radio quit

Quote:
Originally Posted by thoganco
I am assuming that by "resetting" everyone means disconnecting the battery. Thanks to the postings that was the first thing I tried. Then checked fuses, then took the stingray apart.
I have a CD player. As this is a new venture, is it safe to assume that I need to replace it with the same?

T
We just replaced a single CD radio with a cassette radio in Jim Bain's '03 without any problem. The advantage of the cassette, (for some) is that you can use it to play MP3 as I do on my bike.

HTH

Jeff in Myrtle Beach
'01 LTC
'99 Icon champagne
'02 KLR 650
TZ 185 2 stroke
Honda R100R beater

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeffklt is offline  
post #11 of 15 Old Aug 20th, 2009, 12:07 pm Thread Starter
Junior Member
 
thoganco's Avatar
 
Join Date: Jul 2009
Location: Forest lake, MN, United States
Posts: 6
Re: Radio quit

How do you use the cassette to play MP3's? Are you using a cassette adapter?
thoganco is offline  
post #12 of 15 Old Aug 20th, 2009, 1:00 pm
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Radio quit

Quote:
Originally Posted by katnapinn
HERE is on on E-Bay

If you do go this route and I suggest you do at this point (its dirt cheap) make sure you use your harnesses if you have a comsystem. they are different. As for the cass vs. cd. No problems should be encountered...

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #13 of 15 Old Aug 20th, 2009, 2:15 pm
Member
 
Join Date: Jul 2008
Location: Wylie, TX, USA
Posts: 98
Re: Radio quit

I went the after market route. I don't know which is bad in my factory unit, the circuit board or the head unit of my old radio. I would guess it is the circuit board but I can't be sure. I had a leak at the bottom of the plastic display window that covers the RDU. I found some corrosion on the board and cleaned it very gently but it still didn't work, Just a glow in the on button.

Anyway, I will sell the radio, the circuit board in a plastic bag without the RDU cover and my 6 cd changer for $100 plus actual shipping if that would help you out any. The cd player has worked fine since I bought the bike but it won't talk to my new radio.
wyliedave is offline  
post #14 of 15 Old Aug 20th, 2009, 2:38 pm Thread Starter
Junior Member
 
thoganco's Avatar
 
Join Date: Jul 2009
Location: Forest lake, MN, United States
Posts: 6
Re: Radio quit

is there a definitive way to isolate where the issue is originating from?
I do have BMW com as well. (if it makes a difference)
thoganco is offline  
post #15 of 15 Old Aug 20th, 2009, 6:31 pm
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Radio quit

Quote:
Originally Posted by thoganco
is there a definitive way to isolate where the issue is originating from?
I do have BMW com as well. (if it makes a difference)
No definitive way to track down the source of the issue to my knowledge. those Germans are bad on support of their product to the novice (Non-certified) types. I would however suspect the RDU as the issue as it controls everything. This seems to be the week point of the system. I have not heard of the CD/cassette going bad other than the play functions. The internals of the CD/Cassette are the "working" guts of the system.

I asked about the Comsystem as the wiring harness that will come with the EBAY stingray will have to be altered to fit your bike unless you use the harness that you have now. Just use the hard parts not the wiring and it should be a plug-and-play day.

Did the reset not work?

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio just quit atps1234 K1200LT 62 May 29th, 2017 10:43 pm
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
No Radio, No Motolights hschisler K1200LT 15 Oct 3rd, 2007 9:05 pm
XM Radio merging with Sirius Radio Tomakazie Satellite Radio 11 Feb 21st, 2007 7:12 am
Radio quit after battery got low BushWacker K1200LT 3 Jan 29th, 2006 6:29 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome