Speedometer Issue - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Aug 17th, 2009, 1:08 pm Thread Starter
Junior Member
 
Join Date: Jul 2009
Location: Falls Church, VA, USA
Posts: 25
Speedometer Issue

I have a 99' LT and was riding this past weekend. While riding, the speedometer decided not to work. I tapped the speedometer screen in the past and it would start to work until it happened again this weekend, tapping the screen would not get it working. I am assuming that it is an electrical issue. Am I correct in thinking this and if so, where would I look to get to the electrical connectors for the speedometer?

Any guidance is appreciated.

Jay
Beamer007 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Aug 17th, 2009, 1:58 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Speedometer Issue

Quote:
Originally Posted by Beamer007
I have a 99' LT and was riding this past weekend. While riding, the speedometer decided not to work. I tapped the speedometer screen in the past and it would start to work until it happened again this weekend, tapping the screen would not get it working. I am assuming that it is an electrical issue. Am I correct in thinking this and if so, where would I look to get to the electrical connectors for the speedometer?

Any guidance is appreciated.

Jay
Hi, Jay -

Over in the Hall of Wisdom section, under troubleshooting, there are tons of threads that discuss the situation of the speedometer and the cruise control being on the fritz. Here is one start, and if you do a search on 'erratic speedometer' or 'erratic cruise control', you'll find plenty to read and you'll find that it is an easy, inexpensive fix. Good luck.
Dick is offline  
post #3 of 4 Old Aug 17th, 2009, 2:33 pm
Senior Member
 
AlaskaFish's Avatar
 
Join Date: Apr 2002
Location: Hillsboro, OR, USA
Posts: 3,136
Wink Re: Speedometer Issue

Hey Jay, the link Dick gave you is probably the one that is your culprit! But if not, you can also check out the links at the bottom of this thread for more info on the subject. It is one of the handy little tricks of this great Site!

John

John & Marilyn Fisher
'00 K1200LTC "Katie"
'95 Triumph "Tigger"
'12 Triumph 800XC "Tigger II" (RIP)
'12 Triumph 1200 Explorer "Shadow Tigger"
Hillsboro, Oregon

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AlaskaFish is offline  
 
post #4 of 4 Old Aug 17th, 2009, 2:57 pm Thread Starter
Junior Member
 
Join Date: Jul 2009
Location: Falls Church, VA, USA
Posts: 25
Re: Speedometer Issue

Thanks for the assistance, I will check it out and let you know.

Jay
Beamer007 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
speedometer error BLB K1200LT 17 Apr 14th, 2016 1:22 am
Speedometer Issue Pjmatz K1200LT 2 Jul 16th, 2009 8:32 pm
Speedometer Question BUGKILLER K1200LT 15 Jun 22nd, 2007 4:13 pm
MapSource lnowell GPS 8 Nov 9th, 2005 3:32 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome