Radio quit after battery got low - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jan 29th, 2006, 4:12 am Thread Starter
Member
 
BushWacker's Avatar
 
Join Date: Dec 2005
Location: Lake Tahoe, NV, USA
Posts: 53
Radio quit after battery got low

I live in Tahoe and there's about 3 feet of snow everywhere so my 05 K1200LT is sitting in the garage. I went to start it up and the thing was almost dead so I put a battery tender on it and let it charge up.

Now that the battery is charged my radio won't work. Is there a reset or something that needs to be set?

I tried the Man and On buttons but nothing seems to work.

Any suggestions?

BushWacker

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"Let's ride we're burnin' daylight!"
BushWacker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jan 29th, 2006, 4:19 am
Senior Member
 
DaFlake's Avatar
 
Join Date: Feb 2004
Location: South San Francisco, CA, USA
Posts: 314
I've read that disconnecting the battery for a period of time worked for some in this forum. http://www.bmwlt.com/forums/showthread.php?t=1244
DaFlake is offline  
post #3 of 4 Old Jan 29th, 2006, 2:45 pm
Rider Journeyman
 
BillyOmaha's Avatar
 
Join Date: Jun 2004
Location: Granite Bay, CA, USA
Posts: 2,015
20 minutes should do...

I concur with "DaFlake". Disconnect the battery for about 20 minutes, reconnect and you should be good to go.


.

Bill "Omaha"

"Life may have begun at 44, but it didn't get thrilling until I shot past 100"

'04 K1200LT "Dieter" Titan Silver, FB 4/23/04
'06 K1200R "Wolfgang" White Aluminum Metallic, FB 6/7/05

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RCB AMA, BMWMOA, Booze Brother "in training"
CCR: '04 Breckenridge CO, '05 Jackson Lake Lodge WY, '06 Chateau Elan GA, '08 Midway UT


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyOmaha is offline  
 
post #4 of 4 Old Jan 29th, 2006, 7:29 pm Thread Starter
Member
 
BushWacker's Avatar
 
Join Date: Dec 2005
Location: Lake Tahoe, NV, USA
Posts: 53
worked

I read the thread you referred to and disconnected the battery for about 10 minutes and yes it worked.

Thanks for the reply, guess I should have searched the threads first. It amazes me how the bikes keep having the same problems over and over.

BushWacker

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

"Let's ride we're burnin' daylight!"
BushWacker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio just quit atps1234 K1200LT 62 May 29th, 2017 11:43 pm
Battery Concern please advise Hulkster Batteries, Chargers, & Electrical 8 Feb 6th, 2006 1:41 am
How NOT to treat your battery.... Zotter Batteries, Chargers, & Electrical 8 Nov 22nd, 2005 2:51 pm
Ran battery dead now radio does not work hd2bmw K1200LT 11 Oct 18th, 2005 3:46 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome