Speedometer Issue - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jul 16th, 2009, 6:55 pm Thread Starter
 
Join Date: Sep 2008
Posts: 10
Speedometer Issue

I have a LT 2002 -13,000 miles, suddenly the speedometer indicator is ocilating from zero to 25 miles/hour when the bike is stoped and engine in idler - as soon as I increase RPM indicator stops to ocilate. During normal ride there is no ocilation and the pointer is stadily indicating the right speed.
BMW dealer says need to replace the ABS pump to fix the issue.
Does anyone have had this issue and what was the fix?
Pjmatz is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jul 16th, 2009, 8:31 pm
Senior Member
 
itspossible's Avatar
 
Join Date: Jan 2007
Location: Thunder Bay, Ontario, Canada
Posts: 408
Re: Speedometer Issue

I have the identical issue but never paid any attention to it since it works fine once I get going, it would be good to know why it happens though.

Ron

2008 RT
2002 LT champagne
2003 Shadow
1986 Yamaha 500
1981 Honda Twinstar
itspossible is offline  
post #3 of 3 Old Jul 16th, 2009, 9:32 pm
Senior Member
 
dvx216's Avatar
 
Join Date: Jun 2008
Location: orrville, oh, usa
Posts: 100
Re: Speedometer Issue

My speedo had this problem after I did the modifications it turned out to be a loose wire on the back of it .
dvx216 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
speedometer error BLB K1200LT 17 Apr 14th, 2016 2:22 am
Speedometer mod photos? Allred K1200LT 8 Nov 15th, 2008 11:02 am
Speedometer Question BUGKILLER K1200LT 15 Jun 22nd, 2007 5:13 pm
MapSource lnowell GPS 8 Nov 9th, 2005 4:32 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome