Here is a good one regarding the O2 sensor - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Jun 7th, 2009, 7:37 am Thread Starter
Member
 
Join Date: Apr 2008
Location: St. Paul, MN, USA
Posts: 32
Here is a good one regarding the O2 sensor

I just completed: Spiegel SS brake line upgrade,
Throttle cable upgrade
Oxygen sensor replacement
Air filter
Fuel Filter
Coolant
Canisterectomy
Spark plugs.
Gas Tank SS quick disconnects.



I ended up having to take it to the dealer because the bike was running really bad and the fuel mileage went down to 27mpg.

There was another fuel related problem that masked itself as a O2 sensor.

The fuel pressure is supposed to be about 40psi. My bike was only running about 10psi, and this set a O2 code in the computer.

Turns out the fuel pump assembly located in the fuel tank had a split hose and the leak (in the fuel tank) would not allow the fuel pump to build the 40psi fuel pressure.

It did cost me $240 to get it fixed, but I would never have found the split fuel line in the fuel tank. I had stripped the tupperware off the bike to save a few bucks on the mechanics labor cost. I figure I saved about 3-4 hours of shop time.

I do think the bad fuel/air mixture problem did cause the computer to richen up the mixture and may have overheated or damaged the O2 sensor.

I am now a happy camper.

'00 Blue K1200LT
'02 XR650L (sold)

Todd
Minnesota

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MNTodd is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Jun 7th, 2009, 8:08 am
Member
 
Join Date: Aug 2008
Location: Martin, TN, USA
Posts: 45
Re: Here is a good one regarding the O2 sensor

Thanks Todd,
That was good info.
roblee55 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Now that was a good bit of AG rubber PhillWard Australia, New Zealand, and AsiaPac 2 Jan 1st, 2007 3:00 am
O2 Sensor Replacement STYLNLT K1200LT 3 Sep 27th, 2006 11:02 am
Where is the inductive speed sensor on 2002+ LTs? piusg K1200LT 4 Mar 4th, 2006 8:36 am
Temp. sensor wit1100 K1200LT 2 Feb 16th, 2006 12:35 pm
Rear Drive Speed Sensor dgl57 K1200LT 12 Jan 13th, 2006 5:08 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome