Another Radio thread.... - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old Jun 6th, 2009, 8:28 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Unhappy Another Radio thread....

Looked to the HOW for advise and found a little information back in '03. After recently washing her, the radio will not work , tape will not work either . She will not power on. Back light on the display however does. Yes, i do have a slit in one of the boots around the buttons, but it would appear that I have been lucky up to this point. Other than the obvious (fuse issue) or the dreaded she's a goner Anyone have any last words to say on the subject? or better yet, anyone have a control head for sale?

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old Jun 6th, 2009, 9:48 pm
Senior Member
 
Join Date: Sep 2003
Location: Austin, TX, USA
Posts: 878
Re: Another Radio thread....

Have you tried disconnecting the battery for ~30 minutes? This will reset the radio (pulling the fuse will not). You will need to reset the throttle position sensor after reconnecting the battery. Key on, fully open the throttle (x2), key off. Start as normal.

ďRes ipsa loquitur, sed quid in infernos dicet?Ē

Alan Stuber
2003 K1200 LTC Titan Silver
Austin, Texas



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
astuber is offline  
post #3 of 18 Old Jun 6th, 2009, 10:04 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,219
Re: Another Radio thread....

You can try to take it apart and dry it out, may get it working again. Then find a suitable soft translucent rubber cover for all the buttons and RTV it in place.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 18 Old Jun 6th, 2009, 10:17 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

Thanks for the suggestions. Both very good. I have the negative side off as we speak. H Hit the bottle and attempting to forget until tomorrow morning. At which time I will be taking the stingray off to accomplish the second task.... While crossing both fingers and toes mind you!
Will cry later when I post the results....

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #5 of 18 Old Jun 6th, 2009, 11:41 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

-1 for the battery "reset"

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #6 of 18 Old Jun 7th, 2009, 12:00 am Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

O.k., hating the fact that I may have to goto the dealer, so found a 2003 stingray complete with radio off of an '03. Seeing that i'd be replacing the entire radio assembly it sound swap right over, correct? simple plug and play, right? again I have an '00. Assistance requested from the powers at be....

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #7 of 18 Old Jun 7th, 2009, 5:54 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,219
Re: Another Radio thread....

They will work but there are some issues with SW versions between controllers and radios. Here is how to check.

I know if you have an old controller and a newer radio there are some current drain issues if you don't turn off the radio before shutting off the bike. Not sure if there are issues the other way around.
Attached Files
File Type: doc Check Radio Ver.doc (21.5 KB, 83 views)

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #8 of 18 Old Jun 7th, 2009, 12:10 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

Quote:
Originally Posted by jzeiler
They will work but there are some issues with SW versions between controllers and radios. Here is how to check.

I know if you have an old controller and a newer radio there are some current drain issues if you don't turn off the radio before shutting off the bike. Not sure if there are issues the other way around.
Thanks for that! Just ordered the parts, I will have to wait to see what the new one says. I do however "religiously" use my battery tender. So you left me an out!

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #9 of 18 Old Jun 7th, 2009, 2:23 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

Quote:
Originally Posted by jzeiler
They will work but there are some issues with SW versions between controllers and radios. Here is how to check.

I know if you have an old controller and a newer radio there are some current drain issues if you don't turn off the radio before shutting off the bike. Not sure if there are issues the other way around.
Call me stuid, but if I have one unit, i.e- RDU and the internals inside the stingray from one bike the "issues" should not be a problem, right? the only pcs left from the old radio will be the handle bar controls. If I read your post correct, its only when you try to combine different RDU's and Radio's. You may still refer to me as stuid. I'm a big boy! I can take it...

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #10 of 18 Old Jun 7th, 2009, 8:47 pm
Senior Member
 
Slim's Avatar
 
Join Date: Aug 2007
Location: NEW HOLLAND, OH, USA
Posts: 155
Re: Another Radio thread....

all the radio problems, mine was fine till i left the radio on all nite and ran the battery down ive tryed every thing posted front left speaker works all the time radio or cd other speakers just work when they want mostly as soon as you turn on the key and 5-15 seconds after bike is started low voltage ? the bike starts fine tho
Slim is offline  
post #11 of 18 Old Jun 9th, 2009, 2:09 am Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

I have cecum to the inevitable.... Replacement needed.

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #12 of 18 Old Jun 9th, 2009, 6:56 am
Senior Member
 
Slim's Avatar
 
Join Date: Aug 2007
Location: NEW HOLLAND, OH, USA
Posts: 155
Re: Another Radio thread....

looked back thru previous owners records and he replaceded the radio less than 10000 miles ago is that all they last?
Slim is offline  
post #13 of 18 Old Jun 9th, 2009, 8:48 am
Senior Member
 
KMC1's Avatar
 
Join Date: Jul 2005
Location: SLC, UT, United States Of America
Posts: 2,337
Re: Another Radio thread....

I have about 26k on my LT and my 2nd radio just shorted out from washing the bike. So, in 26k I'll basically be on my 3rd radio, but the good news is that they usually last more than 1k
This time around I'm going to try something different. (If i decide to fix the radio instead of trading in the LT or sellling it off that is) I'm thinking about finding some kind of membrane (3M Clearshield or similar) and covering the stingray/radio controls area with it to give a layer of water protection that the stock setup is obviously lacking.
HTH

R1200GSA Hi Ho, Hi Ho, It's off to Alaska I go!
(Down to ONE BIKE - ARGH!)
KMC1 is offline  
post #14 of 18 Old Jun 9th, 2009, 9:42 am
Senior Member
 
Steve_R's Avatar
 
Join Date: Mar 2003
Location: Snellville, GA, USA
Posts: 6,424
Re: Another Radio thread....

Don't know what's going on with the radios, my '00 had 104K on it and was still working when I totaled it. Current '01 has 91K and it is still running just fine. You guys must be awfully hard on your equipment.

On His Ride,
Steve
-
KA5MTE
'02 LTE - Red-blooded Dragonfly
'00 Unigo - Dragon's Egg
'01 LTC - Flying Purple People Eater (Ya gotta be old enough to understand)(RIP)
'00 LTC - Canyon Red Rover (RIP)

Have you
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwlt.com lately????



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"To not know me is to lose nothing, to not know Him is to lose everything."
Steve_R is offline  
post #15 of 18 Old Jun 9th, 2009, 11:27 am Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

Quote:
Originally Posted by Steve_R
Don't know what's going on with the radios, my '00 had 104K on it and was still working when I totaled it. Current '01 has 91K and it is still running just fine. You guys must be awfully hard on your equipment.
"Barbara" had 117K before she shut up! and I thought it was a prerequisite to drive the @*&$ out of the LT's? the view is so much better at light speed!

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
post #16 of 18 Old Jun 11th, 2009, 4:14 pm
Senior Member
 
ez_rdr55's Avatar
 
Join Date: Feb 2005
Location: st louis, MO, usa
Posts: 373
Talking Re: Another Radio thread....

Quote:
Originally Posted by Steve_R
You guys must be awfully hard on your equipment.

That's funny because thatís what my stealer blames every thing onÖitís all my fault.
I did have the last laugh though. When it was time to get an adventure bike, guess what I didnít buy.

EZ-RDR55
The opinions expressed herein are mine, and do not represent that of any other humanoid past, present or future on this or any other planet.

'95 H-D FXDWG
'06 Honda CRF250X
'04 KTM 450EXC
'97 Honda XR-600R
'04 K1200LT (Sold)
'07 K1200GT (Sold)
'09 Wee-Strom DL-650ABS
ez_rdr55 is offline  
post #17 of 18 Old Jun 11th, 2009, 4:15 pm
Senior Member
 
TBob's Avatar
 
Join Date: Feb 2006
Location: Mesa, AZ,
Posts: 239
Re: Another Radio thread....

Had the same thing happen to my 03 - radio had to be replaced

Quote:
Originally Posted by shoswell
Looked to the HOW for advise and found a little information back in '03. After recently washing her, the radio will not work , tape will not work either . She will not power on. Back light on the display however does. Yes, i do have a slit in one of the boots around the buttons, but it would appear that I have been lucky up to this point. Other than the obvious (fuse issue) or the dreaded she's a goner Anyone have any last words to say on the subject? or better yet, anyone have a control head for sale?

TBob
09 R1200 GSA
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'03 LT Impala Brown - FOR SALE
'01 KTM 520 EXC

Interested in a Kontour seat? PM me I would be happy to share my Kontour experience.
TBob is offline  
post #18 of 18 Old Jun 20th, 2009, 12:37 pm Thread Starter
Senior Member
 
shoswell's Avatar
 
Join Date: Apr 2008
Location: Nashville, TN, United States
Posts: 1,425
Garage
Re: Another Radio thread....

see http://www.bmwlt.com/forums/showthread.php?t=47525 for the underlying issue!

Hoss
'Stupidity has a knack of getting its way.' --Albert Camus
'05- K1200LT - Gretchen
R.I.P. - '00- K1200LTE- "Barbara" - Retired at 168K 9/2011
MOA, IBA, EXR & RCB and TMI
shoswell is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Repair Update - When is the next LT ready? Vince_nj1 K1200LT 28 Oct 2nd, 2010 2:46 pm
Unusual Radio Issue on an '02 LTE ErnieA K1200LT 20 Feb 14th, 2009 10:12 am
Motorcycle Communicator radio jimmayor007 Intercom, CB, & 2-Way Radios 0 Dec 10th, 2007 4:46 pm
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm
XM Radio merging with Sirius Radio Tomakazie Satellite Radio 11 Feb 21st, 2007 7:12 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome