Not a thing went wrong!! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old May 1st, 2009, 10:24 pm Thread Starter
Senior Member
 
Join Date: Jun 2008
Location: West Kelowna, B.C., Canada
Posts: 160
Not a thing went wrong!!

Went for a spin on the bike today, which was our first warm day, and not a thing went wrong!! The bike started right away, purred for a few seconds before I pushed it off the centerstand and backed it slowly out of the garage. Hit first gear and down our driveway I drove. After a few blocks, I hit a main road and zoom........ What a rush!! Turned on the music and let her rip. It's nice to just get on and ride without any problems or concerns. Oh yes, my only concern is keeping the speed down to legal limits.
After reading all the problems listed on this K1200 LT blog, I thought it was time for a happy thread.
I hope there are more happy stories out there.
Drive safe!!
Cheers!
Jim

1953 Ariel 350
1970 Norton Commando
1975 Honda Excel 250
1977 Kawasaki Z1000 LT
1985 Honda V65 Magna
1989 Yamaha Venture Royalle
2006 BMW K1200 LT
gladiator99 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old May 1st, 2009, 10:39 pm
Senior Member
 
DanDiver's Avatar
 
Join Date: Jun 2003
Location: Tampa, FL, USA
Posts: 4,836
Re: Not a thing went wrong!!

Same thing happens every time I get on my bike too! Been like this for the past 5-6 years.........

Dano
Tampa, Fl.

12 K1600 GTL
02 K1200 LT (gone but not forgotten)
DanDiver is offline  
post #3 of 5 Old May 2nd, 2009, 8:04 am
Senior Member
 
Toolman's Avatar
 
Join Date: Sep 2005
Location: Katy, TX - USA
Posts: 507
Re: Not a thing went wrong!!

Mine exhibits these very same characteristics. Ride-on.

I wish I could think of clever things to say in my signature.
Toolman is offline  
 
post #4 of 5 Old May 2nd, 2009, 8:37 am
Senior Member
 
SilverBuffalo's Avatar
 
Join Date: May 2005
Location: St. Petersburg, FL, USA
Posts: 3,208
Re: Not a thing went wrong!!

What!!!
no Bitching, Moaning or Whining?

Just a great ride on a fabulous motorcycle,
here I thought that only happened to me!


Hans
St. Petersburg FL

2002 K1200LTE
"Silver Buffalo" Totaled 5/06
2005 LT
"Esperanza"
BushtecGenesisTrailer
"Our preferred long distance carrier"



SilverBuffalo is offline  
post #5 of 5 Old May 2nd, 2009, 10:36 am
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 7,107
Re: Not a thing went wrong!!

Stop it, you guys before you jinx my next ride!!

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
The Simplest Thing..... Hairpin K1200LT 12 Nov 26th, 2008 8:25 pm
Weird Thing bmwusmc K1200LT 2 May 20th, 2008 3:10 pm
A funny thing happened on the way back from Big Bend dwsdad Chit Chat 9 Mar 19th, 2008 11:39 am
Clutch issue...whats wrong? fitsman K1200LT 20 Oct 27th, 2007 8:56 pm
Dead Battery: Wrong Charger? ICXC K1200LT 9 Oct 12th, 2006 5:10 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome